gnunet-fuse: update to version 0.19.1
ChangeLog file excert: Fri Dec 30 12:51:11 AM CET 2022 Releasing gnunet-fuse 0.19.1: fix build for GNUnet 0.19.0+. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
This commit is contained in:
parent
09bc74fa23
commit
9a1e65c2fd
2 changed files with 3 additions and 53 deletions
|
@ -2,11 +2,11 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=gnunet-fuse
|
PKG_NAME:=gnunet-fuse
|
||||||
|
|
||||||
PKG_VERSION:=0.16.0
|
PKG_VERSION:=0.19.1
|
||||||
PKG_RELEASE:=$(AUTORELEASE)
|
PKG_RELEASE:=1
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=@GNU/gnunet
|
PKG_SOURCE_URL:=@GNU/gnunet
|
||||||
PKG_HASH:=2cbeb79cc2aa9939d5faaaf52c21da125029cb6646c1db0d3b9e9feea7f23fa6
|
PKG_HASH:=8f1f6f4d76c108ae74c0ec849bc9c02dc8dea412e205c56236c86cb792ccc9b4
|
||||||
|
|
||||||
PKG_LICENSE:=GPL-3.0
|
PKG_LICENSE:=GPL-3.0
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
|
@ -1,50 +0,0 @@
|
||||||
Always use pthread_mutexattr_settype() the
|
|
||||||
pthread_mutexattr_setkind_np() is not available in the glibc and musl
|
|
||||||
version used by OpenWrt.
|
|
||||||
|
|
||||||
This patch was taken from:
|
|
||||||
https://aur.archlinux.org/cgit/aur.git/plain/pthread_mutexattr_settype.patch?h=gnunet-fuse
|
|
||||||
|
|
||||||
--- a/src/fuse/mutex.c
|
|
||||||
+++ b/src/fuse/mutex.c
|
|
||||||
@@ -35,16 +35,6 @@
|
|
||||||
#endif
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-/**
|
|
||||||
- * This prototype is somehow missing in various Linux pthread
|
|
||||||
- * include files. But we need it and it seems to be available
|
|
||||||
- * on all pthread-systems so far. Odd.
|
|
||||||
- */
|
|
||||||
-#ifndef _MSC_VER
|
|
||||||
-extern int pthread_mutexattr_setkind_np (pthread_mutexattr_t * attr,
|
|
||||||
- int kind);
|
|
||||||
-#endif
|
|
||||||
-
|
|
||||||
|
|
||||||
/**
|
|
||||||
* @brief Structure for MUTual EXclusion (Mutex).
|
|
||||||
@@ -67,23 +57,13 @@ GNUNET_mutex_create (int isRecursive)
|
|
||||||
pthread_mutexattr_init (&attr);
|
|
||||||
if (isRecursive)
|
|
||||||
{
|
|
||||||
-#ifdef __linux__
|
|
||||||
- GNUNET_assert (0 == pthread_mutexattr_setkind_np
|
|
||||||
- (&attr, PTHREAD_MUTEX_RECURSIVE_NP));
|
|
||||||
-#elif BSD || SOLARIS || OSX || WINDOWS
|
|
||||||
GNUNET_assert (0 == pthread_mutexattr_settype
|
|
||||||
(&attr, PTHREAD_MUTEX_RECURSIVE));
|
|
||||||
-#endif
|
|
||||||
}
|
|
||||||
else
|
|
||||||
{
|
|
||||||
-#ifdef __linux__
|
|
||||||
- GNUNET_assert (0 == pthread_mutexattr_setkind_np
|
|
||||||
- (&attr, PTHREAD_MUTEX_ERRORCHECK_NP));
|
|
||||||
-#else
|
|
||||||
GNUNET_assert (0 == pthread_mutexattr_settype
|
|
||||||
(&attr, PTHREAD_MUTEX_ERRORCHECK));
|
|
||||||
-#endif
|
|
||||||
}
|
|
||||||
mut = GNUNET_new (struct GNUNET_Mutex);
|
|
||||||
GNUNET_assert (0 == pthread_mutex_init (&mut->pt, &attr));
|
|
Loading…
Reference in a new issue