btrfs-progs: Update to version 6.0.1
This fixes compilation problems with glibc 2.36. Full Changelog: btrfs-progs-6.0 (2022-10-11) ----------------------------- * fi usage: in tabular output, print total size and slack size * mkfs: * option -O now accepts values from -R to unify the interface (-R will continue to work) * zone reset and discard is done in parallel on all devices * removed option --leafsize, deprecated long time ago * corrupt-block: recalculate checksum when changing generation * fixes: * convert: fix reserved range detection and overlaps * mkfs: fix creating files with reserved inode numbers with --rootdir * receive: escape filenames in command attributes * fix extent buffer leaks after transaction abort * experimental: * mkfs: support for block-group-tree (kernel 6.1) * fsverity in send (protocol v3, WIP) * btrfstune -b converts to block-group-tree * other: * cleanups, refactoring * new and updated tests * update documentation btrfs-progs-6.0.1 (2022-11-04) """""""""""""""""""""""""""""" * send: minor speed up for v2 due to increased buffer size * resize: invalid command line options fail with error code * quota rescan: * add long options --status and --wait * new option to wait but don't start rescan * qgroup show: print path by default, updated format * qgroup: new subcommand clear-stale, remove qgroups without their subvolumes * experimental: * add warnings to commands that have it enabled (mkfs, image, btrfstune) * other: * documentation, help text, error message updates btrfs-progs-5.19 (2022-08-16) ----------------------------- * send: support protocol version 2 * fi show: print all missing devices * device stats: add tabular output * replace: add alias to device group (device replace) * check: validate free space tree items * fixes: * convert: support large filesystems (block count > 32bit) * recognize filesystems with verity enabled * mkfs and DUP could write out of order, fix it for zoned mode * build: * optional support for LZO and ZSTD in receive * compatibility with glibc 2.36 (mount.h) * add fallbacks for new GCC builtins * other: * corrupt-block: target specific items, offsets * documentation updates, new pages from wiki * new tests btrfs-progs-5.19.1 (2022-09-12) """"""""""""""""""""""""""""""" * fix memory leaks (extent buffer, path) * check: verify block device size vs item * rescue fix-device-size: allow to shrink device item * receive: fix crash on wrong pinter free() * other: * experimental: support for block-group-tree * documentation updates * new tests btrfs-progs-5.18 (2022-05-25) ----------------------------- * fixes: * dump-tree: don't print traling zeros in checksums * recognize paused balance as exclusive operation state, allow to start device add * convert: properly initialize target filesystem label * mkfs: don't create free space bitmaps for empty filesystem * restore: make lzo support build-time configurable, print supported compression in help text * update kernel-lib sources * other: * documentation updates, finish conversion to RST, CHANGES and INSTALL could be included into RST * fix build detection of experimental mode * new tests btrfs-progs-5.18.1 (2022-06-06) """"""""""""""""""""""""""""""" * fixes: * convert: fix self reference of toplevel directory * build: make kernel lib headers compatible with C++ * zoned mode: verify minimum zone size 4MiB * libbtrfs: cleanups, merge headers and remove declarations of unexported symbols * other: documentation updates btrfs-progs-5.17 (2022-04-26) ----------------------------- * check: * repair wrong num_devices in superblock * recognize overly long xattr names * fix wrong total bytes check for seed device * auto-repair on read on RAID56 * property set: unify handling of empty value to mean default, changed meaning for property 'compression' to allow reset to default and to set NOCOMPRESS, since kernel 5.14 * fixes: * dump-tree: print fs-verity items * fix location of system chunk on zoned filesystem * do not allow setting seeding flag on a filesystem with dirty log * mkfs and subpage support: use sectorsize as nodesize fallback for mixed profiles * preparatory work for extent tree v2, global roots * experimental feature (unstable interface, not built by default, do not use for production) * btrfstune: option --csum to switch checksum algorithm * other: * cleanups, refactoring * update documentation build, remove asciidocs leftovers * update fssum to consider xattrs * add fsstress Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
This commit is contained in:
parent
94a605f775
commit
99f5604905
2 changed files with 2 additions and 45 deletions
|
@ -6,12 +6,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=btrfs-progs
|
||||
PKG_VERSION:=5.16.1
|
||||
PKG_VERSION:=6.0.1
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@KERNEL/linux/kernel/people/kdave/btrfs-progs
|
||||
PKG_HASH:=3da4da5361cf86bddda80edb4c4f30ea076cb4ebec29904fa08afc930ef9e1a8
|
||||
PKG_HASH:=b5316fff1d811e2ad3a067973109eb912bb0d92805735625fd8b82e700201c48
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-v$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=Karel Kočí <karel.koci@nic.cz>
|
||||
|
|
|
@ -1,43 +0,0 @@
|
|||
From b5159062f079d451f23d7f2a0e7d9e2f84934f94 Mon Sep 17 00:00:00 2001
|
||||
From: Rosen Penev <rosenp@gmail.com>
|
||||
Date: Sat, 29 Jan 2022 17:09:56 -0800
|
||||
Subject: [PATCH] btrfs-progs: fix 64-bit mips and powerpc types
|
||||
|
||||
The kernel uses 'unsigned long' for u64 specifically for ppc64 and
|
||||
mips64.
|
||||
|
||||
Remove asm/types.h include as it will get included properly later.
|
||||
|
||||
Fixe -Wformat warnings.
|
||||
|
||||
Signed-off-by: Rosen Penev <rosenp@gmail.com>
|
||||
Signed-off-by: David Sterba <dsterba@suse.com>
|
||||
---
|
||||
cmds/receive-dump.c | 1 -
|
||||
kerncompat.h | 5 +++++
|
||||
2 files changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
--- a/cmds/receive-dump.c
|
||||
+++ b/cmds/receive-dump.c
|
||||
@@ -31,7 +31,6 @@
|
||||
#include <stdlib.h>
|
||||
#include <time.h>
|
||||
#include <ctype.h>
|
||||
-#include <asm/types.h>
|
||||
#include <uuid/uuid.h>
|
||||
#include "common/utils.h"
|
||||
#include "cmds/commands.h"
|
||||
--- a/kerncompat.h
|
||||
+++ b/kerncompat.h
|
||||
@@ -19,6 +19,11 @@
|
||||
#ifndef __KERNCOMPAT_H__
|
||||
#define __KERNCOMPAT_H__
|
||||
|
||||
+#ifndef __SANE_USERSPACE_TYPES__
|
||||
+/* For PPC64 to get LL64 types */
|
||||
+#define __SANE_USERSPACE_TYPES__
|
||||
+#endif
|
||||
+
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <errno.h>
|
Loading…
Reference in a new issue