inadyn: Fix compilation without deprecated OpenSSL APIs
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
483c9fceae
commit
99c54c97e4
2 changed files with 25 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=inadyn
|
||||
PKG_VERSION:=2.3.1
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
PKG_MAINTAINER:=
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
|
24
net/inadyn/patches/010-openssl-deprecated.patch
Normal file
24
net/inadyn/patches/010-openssl-deprecated.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
--- a/src/openssl.c
|
||||
+++ b/src/openssl.c
|
||||
@@ -25,17 +25,21 @@
|
||||
|
||||
int ssl_init(void)
|
||||
{
|
||||
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
|
||||
SSL_library_init();
|
||||
SSL_load_error_strings();
|
||||
OpenSSL_add_all_algorithms();
|
||||
+#endif
|
||||
|
||||
return 0;
|
||||
}
|
||||
|
||||
void ssl_exit(void)
|
||||
{
|
||||
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
|
||||
ERR_free_strings();
|
||||
EVP_cleanup();
|
||||
+#endif
|
||||
}
|
||||
|
||||
static int verify_callback(int preverify_ok, X509_STORE_CTX *ctx)
|
Loading…
Reference in a new issue