gnutls: updated to 3.6.8
Signed-off-by: Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com>
This commit is contained in:
parent
0353ca6833
commit
998b6d4636
2 changed files with 55 additions and 3 deletions
|
@ -8,14 +8,14 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gnutls
|
||||
PKG_VERSION:=3.6.7
|
||||
PKG_VERSION:=3.6.8
|
||||
PKG_RELEASE:=1
|
||||
PKG_USE_MIPS16:=0
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://www.gnupg.org/ftp/gcrypt/gnutls/v3.6
|
||||
PKG_HASH:=5b3409ad5aaf239808730d1ee12fdcd148c0be00262c7edf157af655a8a188e2
|
||||
#PKG_FIXUP:=autoreconf gettext-version
|
||||
PKG_HASH:=aa81944e5635de981171772857e72be231a7e0f559ae0292d2737de475383e83
|
||||
PKG_FIXUP:=autoreconf gettext-version
|
||||
PKG_MAINTAINER:=Nikos Mavrogiannopoulos <nmav@gnutls.org>
|
||||
PKG_LICENSE:=LGPLv2.1+
|
||||
PKG_CPE_ID:=cpe:/a:gnu:gnutls
|
||||
|
|
52
libs/gnutls/patches/001-no-autogen.patch
Normal file
52
libs/gnutls/patches/001-no-autogen.patch
Normal file
|
@ -0,0 +1,52 @@
|
|||
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 2112606601..e0c5c25d5b 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -735,7 +735,7 @@ if test "$enable_tools" != "no" || test "$enable_doc" != "no"; then
|
||||
*** autogen not found. Will not link against system libopts.
|
||||
*** ]])
|
||||
dnl simulate specifying option on the command line
|
||||
- enable_local_libopts=yes
|
||||
+ included_libopts=yes
|
||||
fi
|
||||
LIBOPTS_CHECK([src/libopts])
|
||||
if test "$NEED_LIBOPTS_DIR" = "true";then
|
||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||
index 0374924c53..8dac61cac5 100644
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -272,6 +272,25 @@ libcmd_systemkey_la_LIBADD += $(LTLIBREADLINE) $(INET_PTON_LIB) $(LIB_CLOCK_GETT
|
||||
|
||||
SUFFIXES = .stamp .def .c.bak .h.bak
|
||||
|
||||
+if NEED_LIBOPTS
|
||||
+# case --enable-local-libopts: We only call AUTOGEN if the .bak files are not present.
|
||||
+# Normally we wouldn't want to call AUTOGEN here as it is explicitly asked not to, but
|
||||
+# in certain CI systems, we need to use this
|
||||
+# our CI systems, which work on
|
||||
+.def.stamp:
|
||||
+ b=`echo $@ | sed 's/.stamp$$//'`; \
|
||||
+ if ! test -f $${srcdir}$${b}.c.bak;then \
|
||||
+ echo $${srcdir}$${b}.c.bak; \
|
||||
+ $(AUTOGEN) $<; \
|
||||
+ else \
|
||||
+ srcdir=$(srcdir)/; \
|
||||
+ rm -f $${b}.c $${b}.h; \
|
||||
+ cp -p $${srcdir}$${b}.c.bak $${b}.c; \
|
||||
+ cp -p $${srcdir}$${b}.h.bak $${b}.h; \
|
||||
+ fi
|
||||
+ touch $@
|
||||
+else
|
||||
+# default case. We call autogen, and if that fails we resort to the bundled files.
|
||||
.def.stamp:
|
||||
$(AM_V_GEN) $(AUTOGEN) $< || { \
|
||||
srcdir=''; \
|
||||
@@ -281,6 +300,7 @@ SUFFIXES = .stamp .def .c.bak .h.bak
|
||||
cp -p $${srcdir}$${b}.h.bak $${b}.h; \
|
||||
} && \
|
||||
touch $@
|
||||
+endif
|
||||
|
||||
.c.c.bak:
|
||||
-@rm -f $@
|
Loading…
Reference in a new issue