lpeg: update to 1.0.2
lua-coxpcall: update to 1.17.0 lua-md5: update to 1.3 Signed-off-by: Dirk Chang <dirk@kooiot.com>
This commit is contained in:
parent
f76a90e3da
commit
992da74bbf
4 changed files with 19 additions and 15 deletions
|
@ -8,14 +8,14 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=lpeg
|
PKG_NAME:=lpeg
|
||||||
PKG_VERSION:=0.12.2
|
PKG_VERSION:=1.0.2
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
|
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
|
||||||
PKG_LICENSE:=MIT
|
PKG_LICENSE:=MIT
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://www.inf.puc-rio.br/~roberto/lpeg/
|
PKG_SOURCE_URL:=http://www.inf.puc-rio.br/~roberto/lpeg/
|
||||||
PKG_HASH:=6aad270b91d1b1c6fd75f68e162329a04a644e50e917d55f46cc8384b7120004
|
PKG_HASH:=48d66576051b6c78388faad09b70493093264588fcd0f258ddaab1cdd4a15ffe
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
|
|
@ -8,16 +8,16 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=lua-coxpcall
|
PKG_NAME:=lua-coxpcall
|
||||||
PKG_VERSION:=1.15.0
|
PKG_VERSION:=1.17.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
|
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
|
||||||
PKG_LICENSE:=MIT
|
PKG_LICENSE:=MIT
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_MIRROR_HASH:=2a99faec759aeb858eca3691a40609dd2710255497011e5754c4a2282232154b
|
PKG_MIRROR_HASH:=e037c1aa1d2a2b213fca144d86cd5b5cf2cd77cec6d8f52d056add7ea806f0dc
|
||||||
PKG_SOURCE_URL:=https://github.com/keplerproject/coxpcall.git
|
PKG_SOURCE_URL:=https://github.com/keplerproject/coxpcall.git
|
||||||
PKG_SOURCE_PROTO:=git
|
PKG_SOURCE_PROTO:=git
|
||||||
PKG_SOURCE_VERSION:=979257892884816c97391dfd7b0a7b30dcc8f479
|
PKG_SOURCE_VERSION:=ea22f44e490430e40217f0792bf82eaeaec51903
|
||||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
|
|
@ -8,16 +8,16 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=lua-md5
|
PKG_NAME:=lua-md5
|
||||||
PKG_VERSION:=1.2
|
PKG_VERSION:=1.3
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
|
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
|
||||||
PKG_LICENSE:=MIT
|
PKG_LICENSE:=MIT
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_MIRROR_HASH:=89a186d9e8bb43a6d45207eeba2883600854ea05befda55b38f7ac215b0d5615
|
PKG_MIRROR_HASH:=675b8ba144d14cbe66abfd360d9a8861a18d5b69966768d6cdc78ca3c9fe0baf
|
||||||
PKG_SOURCE_URL:=https://github.com/keplerproject/md5.git
|
PKG_SOURCE_URL:=https://github.com/keplerproject/md5.git
|
||||||
PKG_SOURCE_PROTO:=git
|
PKG_SOURCE_PROTO:=git
|
||||||
PKG_SOURCE_VERSION:=024b65738b4434860777fc43d7cacaefea29ec60
|
PKG_SOURCE_VERSION:=2a98633d7587a4900cfa7cbed340f377f4acd930
|
||||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
@ -60,6 +60,7 @@ define Build/Compile
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Install
|
define Build/Install
|
||||||
|
mkdir -p $(PKG_INSTALL_DIR)/usr/lib/lua
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
LUA_LIBDIR="$(PKG_INSTALL_DIR)/usr/lib/lua" \
|
LUA_LIBDIR="$(PKG_INSTALL_DIR)/usr/lib/lua" \
|
||||||
LUA_DIR="$(PKG_INSTALL_DIR)/usr/lib/lua" \
|
LUA_DIR="$(PKG_INSTALL_DIR)/usr/lib/lua" \
|
||||||
|
|
|
@ -1,19 +1,22 @@
|
||||||
--- lua-md5-1.2/config 2014-06-04 16:55:50.000000000 +0800
|
--- a/config 2019-11-01 13:58:27.907691645 +0800
|
||||||
+++ lua-md5-1.2_new/config 2014-06-04 16:57:54.223539416 +0800
|
+++ b/config 2019-11-01 14:00:52.126290663 +0800
|
||||||
@@ -1,13 +1,13 @@
|
@@ -1,16 +1,16 @@
|
||||||
# Installation directories
|
# Installation directories
|
||||||
|
|
||||||
# Default prefix
|
# Default prefix
|
||||||
-PREFIX = /usr/local
|
-PREFIX = /usr/local
|
||||||
+PREFIX = /usr
|
+PREFIX = /usr
|
||||||
|
|
||||||
|
# Lua version
|
||||||
|
LUA_SYS_VER ?= 5.2
|
||||||
|
|
||||||
# System's libraries directory (where binary libraries are installed)
|
# System's libraries directory (where binary libraries are installed)
|
||||||
-LUA_LIBDIR= $(PREFIX)/lib/lua/5.1
|
-LUA_LIBDIR= $(PREFIX)/lib/lua/$(LUA_SYS_VER)
|
||||||
+LUA_LIBDIR= $(PREFIX)/lib/lua
|
+LUA_LIBDIR= $(PREFIX)/lib/lua
|
||||||
|
|
||||||
# System's lua directory (where Lua libraries are installed)
|
# System's lua directory (where Lua libraries are installed)
|
||||||
-LUA_DIR= $(PREFIX)/share/lua/5.1
|
-LUA_DIR= $(PREFIX)/share/lua/$(LUA_SYS_VER)
|
||||||
+LUA_DIR= $(PREFIX)/lib/lua
|
+LUA_DIR= $(PREFIX)/share/lua
|
||||||
|
|
||||||
# Lua includes directory
|
# Lua includes directory
|
||||||
LUA_INC= $(PREFIX)/include
|
LUA_INC= $(PREFIX)/include
|
||||||
|
|
Loading…
Reference in a new issue