python-ldap: added python-ldap package
Signed-off-by: Dimtrij Trefilov <the-alien@live.ru>
This commit is contained in:
parent
5885f21731
commit
98bc21b08e
2 changed files with 75 additions and 0 deletions
59
lang/python-ldap/Makefile
Normal file
59
lang/python-ldap/Makefile
Normal file
|
@ -0,0 +1,59 @@
|
|||
#
|
||||
# Copyright (C) 2015 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=python-ldap
|
||||
PKG_VERSION:=2.4.20
|
||||
PKG_RELEASE:=1
|
||||
PKG_MAINTAINER:=Dmitry Trefilov <the-alien@live.ru>
|
||||
PKG_LICENSE:=Python-style
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://pypi.python.org/packages/source/p/$(PKG_NAME)
|
||||
PKG_MD5SUM:=f98ecd0581766a43954ba0f218053032
|
||||
|
||||
PKG_BUILD_DEPENDS:=python libopenldap
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
$(call include_mk, python-package.mk)
|
||||
|
||||
define Package/python-ldap
|
||||
SUBMENU:=Python
|
||||
SECTION:=lang
|
||||
CATEGORY:=Languages
|
||||
DEPENDS:=+libopenldap +python
|
||||
TITLE:=Python modules for implementing LDAP clients
|
||||
URL:=http://python-ldap.org/
|
||||
endef
|
||||
|
||||
define Package/python-ldap/description
|
||||
python-ldap provides an object-oriented API to access LDAP directory
|
||||
servers from Python programs. Mainly it wraps the OpenLDAP 2.x libs
|
||||
for that purpose. Additionally the package contains modules for
|
||||
other LDAP-related stuff (e.g. processing LDIF, LDAPURLs, LDAPv3
|
||||
schema, LDAPv3 extended operations and controls, etc.).
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/PyMod,,build_ext \
|
||||
--include-dirs="$(STAGING_DIR)/usr/include:$(STAGING_DIR)/usr/include/sasl" \
|
||||
--library-dirs="$(STAGING_DIR)/usr/lib:$(STAGING_DIR)/usr/lib/sasl2" \
|
||||
build_py \
|
||||
install --prefix="$(PKG_INSTALL_DIR)/usr")
|
||||
endef
|
||||
|
||||
define PyPackage/python-ldap/install
|
||||
$(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
|
||||
$(1)$(PYTHON_PKG_DIR)
|
||||
endef
|
||||
|
||||
$(eval $(call PyPackage,python-ldap))
|
||||
$(eval $(call BuildPackage,python-ldap))
|
16
lang/python-ldap/patches/010-setup_cfg.patch
Normal file
16
lang/python-ldap/patches/010-setup_cfg.patch
Normal file
|
@ -0,0 +1,16 @@
|
|||
From: Dmitrij Trefilov <the-alien@live.ru>
|
||||
|
||||
Subject: [PATCH] lang: removed hardcoded include and library directories from setup.cfg
|
||||
Signed-off-by: Dmitrij Trefilov <the-alien@live.ru>
|
||||
---
|
||||
--- a/setup.cfg
|
||||
+++ b/setup.cfg
|
||||
@@ -1,6 +1,6 @@
|
||||
[_ldap]
|
||||
-library_dirs = /usr/lib /usr/lib64 /usr/local/lib /usr/local/lib64
|
||||
-include_dirs = /usr/include /usr/include/sasl /usr/local/include /usr/local/include/sasl
|
||||
+library_dirs =
|
||||
+include_dirs =
|
||||
defines = HAVE_SASL HAVE_TLS HAVE_LIBLDAP_R
|
||||
extra_compile_args =
|
||||
extra_objects =
|
Loading…
Reference in a new issue