boost: bump to version 1.80.0

This commit updates boost to version 1.80.0

There are no new libraries in this version

The following patches were removed due to upstream update:
* 010-mips1.patch [1]
* 910-json-array-erase-relocate.patch [2]

More info about Boost 1.80.0 can be found at the usual place [3].

[1]: https://github.com/boostorg/config/pull/390
[2]: https://github.com/boostorg/json/pull/695
[3]: https://www.boost.org/users/history/version_1_80_0.html

Signed-off-by: Carlos Miguel Ferreira <carlosmf.pt@gmail.com>
This commit is contained in:
Carlos Miguel Ferreira 2022-08-18 02:40:33 +01:00 committed by Rosen Penev
parent 6e1687df30
commit 97becb5bd7
3 changed files with 5 additions and 101 deletions

View file

@ -11,13 +11,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=boost
PKG_VERSION:=1.79.0
PKG_SOURCE_VERSION:=1_79_0
PKG_VERSION:=1.80.0
PKG_SOURCE_VERSION:=1_80_0
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)_$(PKG_SOURCE_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/$(PKG_NAME)/$(PKG_NAME)/$(PKG_VERSION) https://dl.bintray.com/boostorg/release/$(PKG_VERSION)/source/
PKG_HASH:=475d589d51a7f8b3ba2ba4eda022b170e562ca3b760ee922c146b6c65856ef39
PKG_SOURCE_URL:=@SF/$(PKG_NAME)/$(PKG_NAME)/$(PKG_VERSION) https://boostorg.jfrog.io/artifactory/main/release/$(PKG_VERSION)/source/
PKG_HASH:=1e19565d82e43bc59209a168f5ac899d3ba471d55c7610c677d4ccf2c9c500c0
PKG_MAINTAINER:=Carlos M. Ferreira <carlosmf.pt@gmail.com>
PKG_LICENSE:=BSL-1.0
@ -42,7 +42,7 @@ define Package/boost/Default
endef
define Package/boost/description
This package provides the Boost v1.79.0 libraries.
This package provides the Boost v1.80.0 libraries.
Boost is a set of free, peer-reviewed, portable C++ source libraries.
This package provides the following run-time libraries:

View file

@ -1,49 +0,0 @@
--- a/boostcpp.jam
+++ b/boostcpp.jam
@@ -634,7 +634,7 @@ rule address-model ( )
return <conditional>@boostcpp.deduce-address-model ;
}
-local deducable-architectures = arm mips1 power riscv s390x sparc x86 combined ;
+local deducable-architectures = arm mips power riscv s390x sparc x86 combined ;
feature.feature deduced-architecture : $(deducable-architectures) : propagated optional composite hidden ;
for a in $(deducable-architectures)
{
@@ -645,10 +645,10 @@ rule deduce-architecture ( properties *
{
local result ;
local filtered = [ toolset-properties $(properties) ] ;
- local names = arm mips1 power riscv s390x sparc x86 combined ;
+ local names = arm mips power riscv s390x sparc x86 combined ;
local idx = [ configure.find-builds "default architecture" : $(filtered)
: /boost/architecture//arm
- : /boost/architecture//mips1
+ : /boost/architecture//mips
: /boost/architecture//power
: /boost/architecture//riscv
: /boost/architecture//s390x
--- a/libs/atomic/build/atomic-arch-config.jam
+++ b/libs/atomic/build/atomic-arch-config.jam
@@ -27,9 +27,9 @@ rule deduce-architecture ( properties *
{
return arm ;
}
- else if [ configure.builds /boost/architecture//mips1 : $(properties) : "mips1" ]
+ else if [ configure.builds /boost/architecture//mips : $(properties) : "mips" ]
{
- return mips1 ;
+ return mips ;
}
else if [ configure.builds /boost/architecture//power : $(properties) : "power" ]
{
--- a/libs/config/checks/architecture/Jamfile.jam
+++ b/libs/config/checks/architecture/Jamfile.jam
@@ -18,7 +18,7 @@ obj 64 : 64.cpp ;
obj arm : arm.cpp ;
obj combined : combined.cpp ;
-obj mips1 : mips1.cpp ;
+obj mips : mips1.cpp ;
obj power : power.cpp ;
obj riscv : riscv.cpp ;
obj sparc : sparc.cpp ;

View file

@ -1,47 +0,0 @@
--- a/boost/json/impl/array.ipp
+++ b/boost/json/impl/array.ipp
@@ -491,8 +491,11 @@ erase(
auto const p = &(*t_)[0] +
(pos - &(*t_)[0]);
destroy(p, p + 1);
- relocate(p, p + 1, 1);
--t_->size;
+ if(t_->size > 0)
+ relocate(p, p + 1,
+ t_->size - (p -
+ &(*t_)[0]));
return p;
}
--- a/libs/json/test/array.cpp
+++ b/libs/json/test/array.cpp
@@ -1270,6 +1270,21 @@ public:
}
void
+ testIssue692()
+ {
+ array a;
+ object obj;
+ obj["test1"] = "hello";
+ a.push_back(obj);
+ a.push_back(obj);
+ a.push_back(obj);
+ a.push_back(obj);
+ a.push_back(obj);
+ while(a.size())
+ a.erase(a.begin());
+ }
+
+ void
run()
{
testDestroy();
@@ -1283,6 +1298,7 @@ public:
testExceptions();
testEquality();
testHash();
+ testIssue692();
}
};