setools: Avoid using host libraries
This adds $STAGING_DIR to library search paths in setup.py, to avoid
picking up host libraries when linking.
Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
(cherry picked from commit 0aff79f29f
)
This commit is contained in:
parent
0890169df1
commit
97bec5a53a
2 changed files with 13 additions and 1 deletions
|
@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=setools
|
||||
PKG_VERSION:=4.3.0
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=https://github.com/SELinuxProject/setools/releases/download/4.3.0
|
||||
|
|
12
utils/setools/patches/030-remove-host-paths.patch
Normal file
12
utils/setools/patches/030-remove-host-paths.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -79,7 +79,8 @@ class QtHelpCommand(Command):
|
||||
|
||||
|
||||
# Library linkage
|
||||
-lib_dirs = ['.', '/usr/lib64', '/usr/lib', '/usr/local/lib']
|
||||
+owrt_staging_dir = os.environ["STAGING_DIR"]
|
||||
+lib_dirs = ['.', owrt_staging_dir + '/usr/lib64', owrt_staging_dir + '/usr/lib', owrt_staging_dir + '/usr/local/lib' ]
|
||||
include_dirs = []
|
||||
|
||||
with suppress(KeyError):
|
Loading…
Reference in a new issue