flac: Fix debug builds
Signed-off-by: Ted Hess <thess@kitschensync.net>
This commit is contained in:
parent
ea01eccee0
commit
973556f292
2 changed files with 20 additions and 3 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=flac
|
PKG_NAME:=flac
|
||||||
PKG_VERSION:=1.3.1
|
PKG_VERSION:=1.3.1
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=3
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=http://downloads.xiph.org/releases/flac/
|
PKG_SOURCE_URL:=http://downloads.xiph.org/releases/flac/
|
||||||
|
@ -43,8 +43,8 @@ CONFIGURE_ARGS += \
|
||||||
--disable-xmms-plugin \
|
--disable-xmms-plugin \
|
||||||
--disable-ogg \
|
--disable-ogg \
|
||||||
--disable-oggtest \
|
--disable-oggtest \
|
||||||
--disable-debug \
|
$(if $(CONFIG_DEBUG),--enable-debug) \
|
||||||
--enable-static \
|
--enable-static
|
||||||
|
|
||||||
TARGET_CFLAGS += $(FPIC)
|
TARGET_CFLAGS += $(FPIC)
|
||||||
|
|
||||||
|
|
17
libs/flac/patches/005-gcc_debug_options.patch
Normal file
17
libs/flac/patches/005-gcc_debug_options.patch
Normal file
|
@ -0,0 +1,17 @@
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -348,11 +348,11 @@ fi
|
||||||
|
|
||||||
|
if test "x$debug" = xtrue; then
|
||||||
|
CPPFLAGS="-DDEBUG $CPPFLAGS"
|
||||||
|
- CFLAGS=$(echo "$CFLAGS" | sed 's/-g//')
|
||||||
|
- CFLAGS="-g $CFLAGS"
|
||||||
|
+ CFLAGS=$(echo "$CFLAGS" | sed 's/-g[0-9]*//')
|
||||||
|
+ CFLAGS="-g3 $CFLAGS"
|
||||||
|
else
|
||||||
|
CPPFLAGS="-DNDEBUG $CPPFLAGS"
|
||||||
|
- CFLAGS=$(echo "$CFLAGS" | sed 's/-O2//;s/-g//')
|
||||||
|
+ CFLAGS=$(echo "$CFLAGS" | sed 's/-O2//;s/-g[0-9]*//')
|
||||||
|
CFLAGS="-O3 -funroll-loops $CFLAGS"
|
||||||
|
fi
|
||||||
|
|
Loading…
Reference in a new issue