shairplay: remove
This package is not only abandoned upstream, it has not worked with iOS versions since at least 2019: https://github.com/juhovh/shairplay/pull/80 Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
303b7b665c
commit
96b349be98
6 changed files with 0 additions and 159 deletions
|
@ -1,55 +0,0 @@
|
|||
#
|
||||
# Copyright (C) 2014-2016 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=shairplay
|
||||
PKG_SOURCE_DATE:=2018-08-24
|
||||
PKG_SOURCE_VERSION:=096b61ad14c90169f438e690d096e3fcf87e504e
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_DATE).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/juhovh/shairplay/tar.gz/$(PKG_SOURCE_VERSION)?
|
||||
PKG_HASH:=7e2b013ffe75ea2f13fb12b1aa38b8e2e8b1899ac292d57f05d7b352a3a181cf
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_SOURCE_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/shairplay
|
||||
SECTION:=sound
|
||||
CATEGORY:=Sound
|
||||
DEPENDS:=+libao +libavahi-compat-libdnssd +libltdl +libpthread
|
||||
TITLE:=Shairplay
|
||||
endef
|
||||
|
||||
define Package/shairplay/description
|
||||
Free portable AirPlay server implementation similar to ShairPort.
|
||||
endef
|
||||
|
||||
define Package/shairplay/conffiles
|
||||
/etc/config/shairplay
|
||||
endef
|
||||
|
||||
define Package/shairplay/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/shairplay $(1)/usr/bin/
|
||||
$(INSTALL_DIR) $(1)/usr/share/shairplay
|
||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/airport.key $(1)/usr/share/shairplay/
|
||||
$(INSTALL_DIR) $(1)/etc/init.d
|
||||
$(INSTALL_BIN) files/shairplay.init $(1)/etc/init.d/shairplay
|
||||
$(INSTALL_DIR) $(1)/etc/config
|
||||
$(INSTALL_CONF) files/shairplay.config $(1)/etc/config/shairplay
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,shairplay))
|
|
@ -1,10 +0,0 @@
|
|||
config shairplay main
|
||||
option disabled '1'
|
||||
option respawn '1'
|
||||
option apname 'AirPlay'
|
||||
option port '5000'
|
||||
option password ''
|
||||
option hwaddr ''
|
||||
option ao_driver 'oss'
|
||||
option ao_devicename ''
|
||||
option ao_deviceid ''
|
|
@ -1,51 +0,0 @@
|
|||
#!/bin/sh /etc/rc.common
|
||||
# Copyright (C) 2014 OpenWrt.org
|
||||
|
||||
START=90
|
||||
USE_PROCD=1
|
||||
|
||||
append_arg() {
|
||||
local cfg="$1"
|
||||
local var="$2"
|
||||
local opt="$3"
|
||||
local def="$4"
|
||||
local val
|
||||
|
||||
config_get val "$cfg" "$var"
|
||||
[ -n "$val" -o -n "$def" ] && procd_append_param command $opt="${val:-$def}"
|
||||
}
|
||||
|
||||
start_instance() {
|
||||
local cfg="$1"
|
||||
local aux
|
||||
|
||||
config_get_bool aux "$cfg" 'disabled' '0'
|
||||
[ "$aux" = 1 ] && return 1
|
||||
|
||||
procd_open_instance
|
||||
|
||||
procd_set_param command /usr/bin/shairplay
|
||||
|
||||
append_arg "$cfg" apname "--apname" "AirPlay"
|
||||
append_arg "$cfg" port "--server_port"
|
||||
append_arg "$cfg" password "--password"
|
||||
append_arg "$cfg" hwaddr "--hwaddr"
|
||||
|
||||
append_arg "$cfg" ao_driver "--ao_driver"
|
||||
append_arg "$cfg" ao_devicename "--ao_devicename"
|
||||
append_arg "$cfg" ao_deviceid "--ao_deviceid"
|
||||
|
||||
config_get_bool aux "$cfg" 'respawn' '0'
|
||||
[ "$aux" = 1 ] && procd_set_param respawn
|
||||
|
||||
procd_close_instance
|
||||
}
|
||||
|
||||
service_triggers() {
|
||||
procd_add_reload_trigger "shairplay"
|
||||
}
|
||||
|
||||
start_service() {
|
||||
config_load shairplay
|
||||
config_foreach start_instance shairplay
|
||||
}
|
|
@ -1,11 +0,0 @@
|
|||
--- a/src/shairplay.c
|
||||
+++ b/src/shairplay.c
|
||||
@@ -350,7 +350,7 @@ main(int argc, char *argv[])
|
||||
raop_cbs.audio_destroy = audio_destroy;
|
||||
raop_cbs.audio_set_volume = audio_set_volume;
|
||||
|
||||
- raop = raop_init_from_keyfile(10, &raop_cbs, "airport.key", NULL);
|
||||
+ raop = raop_init_from_keyfile(10, &raop_cbs, "/usr/share/shairplay/airport.key", NULL);
|
||||
if (raop == NULL) {
|
||||
fprintf(stderr, "Could not initialize the RAOP service\n");
|
||||
fprintf(stderr, "Please make sure the airport.key file is in the current directory.\n");
|
|
@ -1,11 +0,0 @@
|
|||
--- a/src/lib/alac/alac.c
|
||||
+++ b/src/lib/alac/alac.c
|
||||
@@ -29,7 +29,7 @@
|
||||
*
|
||||
*/
|
||||
|
||||
-static const int host_bigendian = 0;
|
||||
+#define host_bigendian (htonl(42) == 42)
|
||||
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
|
@ -1,21 +0,0 @@
|
|||
From 031c3d802e51bbc233b1044f812402a66bfcf237 Mon Sep 17 00:00:00 2001
|
||||
From: Memphiz <memphis@machzwo.de>
|
||||
Date: Fri, 21 Dec 2018 20:39:11 +0100
|
||||
Subject: [PATCH] [configure] - only check for dns_sd.h in case libdl was not
|
||||
found
|
||||
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -19,7 +19,7 @@ LT_LIB_DLLOAD
|
||||
|
||||
# Checks for header files.
|
||||
AC_HEADER_STDC
|
||||
-if test yes = "$libltdl_cv_func_dlopen" || test yes = "$libltdl_cv_lib_dl_dlopen"
|
||||
+if test no = "$libltdl_cv_func_dlopen" && test no = "$libltdl_cv_lib_dl_dlopen"
|
||||
then
|
||||
AC_CHECK_HEADERS([dns_sd.h], [],
|
||||
[AC_MSG_ERROR([Could not find dns_sd.h header, please install libavahi-compat-libdnssd-dev or equivalent.])])
|
Loading…
Reference in a new issue