libuhttpd: Update to 2.1.2
Signed-off-by: Jianhui Zhao <jianhuizhao329@gmail.com>
This commit is contained in:
parent
76c4865971
commit
960dfe244a
2 changed files with 45 additions and 4 deletions
12
libs/libuhttpd/Makefile
Executable file → Normal file
12
libs/libuhttpd/Makefile
Executable file → Normal file
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libuhttpd
|
||||
PKG_VERSION:=2.0.3
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=2.1.2
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
|
||||
PKG_SOURCE_URL=https://github.com/zhaojh329/libuhttpd.git
|
||||
PKG_MIRROR_HASH:=f20e4081ba1bbea277a3c86f28fa451d54546817a58814fff91470550a5b8e5d
|
||||
PKG_MIRROR_HASH:=0f80b643ca4fa652df1a4510384e941e045b1ad8124fa4c8128a56861189b325
|
||||
CMAKE_INSTALL:=1
|
||||
|
||||
PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_SOURCE_SUBDIR)
|
||||
|
@ -39,6 +39,7 @@ define Package/libuhttpd-nossl
|
|||
$(Package/libuhttpd/default)
|
||||
TITLE += (NO SSL)
|
||||
VARIANT:=nossl
|
||||
CONFLICTS:=libuhttpd-openssl libuhttpd-wolfssl libuhttpd-mbedtls
|
||||
endef
|
||||
|
||||
define Package/libuhttpd-openssl
|
||||
|
@ -46,6 +47,7 @@ define Package/libuhttpd-openssl
|
|||
TITLE += (openssl)
|
||||
DEPENDS += +libustream-openssl
|
||||
VARIANT:=openssl
|
||||
CONFLICTS:=libuhttpd-wolfssl libuhttpd-mbedtls
|
||||
endef
|
||||
|
||||
define Package/libuhttpd-wolfssl
|
||||
|
@ -53,6 +55,7 @@ define Package/libuhttpd-wolfssl
|
|||
TITLE += (wolfssl)
|
||||
DEPENDS += +libustream-wolfssl
|
||||
VARIANT:=wolfssl
|
||||
CONFLICTS:=libuhttpd-mbedtls
|
||||
endef
|
||||
|
||||
define Package/libuhttpd-mbedtls
|
||||
|
@ -67,8 +70,9 @@ ifeq ($(BUILD_VARIANT),nossl)
|
|||
endif
|
||||
|
||||
define Package/libuhttpd/default/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/ $(1)/usr/lib/lua/
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libuhttpd.so* $(1)/usr/lib/
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/lua/uhttpd.so* $(1)/usr/lib/lua/
|
||||
endef
|
||||
|
||||
Package/libuhttpd-nossl/install = $(Package/libuhttpd/default/install)
|
||||
|
|
37
libs/libuhttpd/patches/001-fix-find-lua.patch
Normal file
37
libs/libuhttpd/patches/001-fix-find-lua.patch
Normal file
|
@ -0,0 +1,37 @@
|
|||
Index: libuhttpd-2.1.0/src/CMakeLists.txt
|
||||
===================================================================
|
||||
--- libuhttpd-2.1.0.orig/src/CMakeLists.txt
|
||||
+++ libuhttpd-2.1.0/src/CMakeLists.txt
|
||||
@@ -8,7 +8,7 @@ set(UHTTPD_VERSION_PATCH 0)
|
||||
|
||||
# Check the third party Libraries
|
||||
find_package(Libubox REQUIRED)
|
||||
-find_package(Lua)
|
||||
+find_package(Lua51)
|
||||
|
||||
include_directories(${CMAKE_CURRENT_BINARY_DIR} ${LIBUBOX_INCLUDE_DIR})
|
||||
|
||||
@@ -20,9 +20,9 @@ option(UHTTPD_SSL_SUPPORT "SSL support"
|
||||
|
||||
|
||||
set(LUA_SUPPORT_DEFAULT "ON")
|
||||
-if (NOT LUA_FOUND)
|
||||
+if (NOT LUA51_FOUND)
|
||||
set(LUA_SUPPORT_DEFAULT "OFF")
|
||||
-endif (NOT LUA_FOUND)
|
||||
+endif (NOT LUA51_FOUND)
|
||||
|
||||
set(UHTTPD_LUA_SUPPORT_CONFIG 1)
|
||||
option(UHTTPD_LUA_SUPPORT "LUA support" ${LUA_SUPPORT_DEFAULT})
|
||||
@@ -34,9 +34,9 @@ else ()
|
||||
endif ()
|
||||
|
||||
if (UHTTPD_LUA_SUPPORT)
|
||||
- if (NOT LUA_FOUND)
|
||||
+ if (NOT LUA51_FOUND)
|
||||
message(FATAL_ERROR "Lua was not found on your system")
|
||||
- endif (NOT LUA_FOUND)
|
||||
+ endif (NOT LUA51_FOUND)
|
||||
|
||||
include_directories(${LUA_INCLUDE_DIR})
|
||||
list(APPEND EXTRA_LIBS ${LUA_LIBRARY})
|
Loading…
Reference in a new issue