Revert "jose: fix static library usage"
This reverts commit c61b70918b
.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry picked from commit f5d3b820c529de94f2a55e078e8f5f2ff87755e9)
This commit is contained in:
parent
5a02ae2fe8
commit
9550d45fd4
2 changed files with 3 additions and 11 deletions
|
@ -19,13 +19,15 @@ PKG_MAINTAINER:=Tibor Dudlák <tibor.dudlak@gmail.com>
|
|||
PKG_LICENSE:=Apache-2.0
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_BUILD_DEPENDS:=openssl
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/meson.mk
|
||||
|
||||
define Package/jose
|
||||
SECTION:=utils
|
||||
TITLE:=Provides a full crypto stack including key generation, signing and encryption.
|
||||
DEPENDS:=+jansson +libopenssl +zlib
|
||||
DEPENDS:=+jansson
|
||||
URL:=https://github.com/latchset/jose
|
||||
endef
|
||||
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- a/cmd/meson.build
|
||||
+++ b/cmd/meson.build
|
||||
@@ -22,6 +22,6 @@ executable(meson.project_name(),
|
||||
'alg.c',
|
||||
'fmt.c',
|
||||
dependencies: jansson,
|
||||
- link_with: libjose,
|
||||
+ link_whole: libjose,
|
||||
install: true
|
||||
)
|
Loading…
Reference in a new issue