sslh: bump to v1.18

Signed-off-by: Mircea Horea IONICĂ <mionica@gmail.com>
Signed-off-by: Jonathan McCrohan <jmccrohan@gmail.com>
This commit is contained in:
Jonathan McCrohan 2017-02-27 00:13:47 +00:00
parent 71ca24ccb9
commit 950ab7445a
4 changed files with 15 additions and 102 deletions

View file

@ -1,5 +1,5 @@
# #
# Copyright (C) 2009-2014 OpenWrt.org # Copyright (C) 2009-2017 OpenWrt.org
# #
# This is free software, licensed under the GNU General Public License v2. # This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information. # See /LICENSE for more information.
@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=sslh PKG_NAME:=sslh
PKG_VERSION:=v1.17 PKG_VERSION:=v1.18
PKG_RELEASE:=2 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://rutschle.net/tech/ PKG_SOURCE_URL:=http://rutschle.net/tech/sslh/
PKG_MD5SUM:=1fc3ada4bafaca5a9786cc1431f48ed4 PKG_MD5SUM:=0e3568d5d234516c634d4df156473298
PKG_LICENSE:=GPL-2.0+ PKG_LICENSE:=GPL-2.0+
PKG_LICENSE_FILES:=COPYING PKG_LICENSE_FILES:=COPYING
@ -37,6 +37,7 @@ define Build/Compile
CC="$(TARGET_CC)" \ CC="$(TARGET_CC)" \
CFLAGS="$(TARGET_CFLAGS)" \ CFLAGS="$(TARGET_CFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)" \ LDFLAGS="$(TARGET_LDFLAGS)" \
ENABLE_REGEX= \
USELIBCONFIG= \ USELIBCONFIG= \
USELIBWRAP= \ USELIBWRAP= \
USELIBPCRE= \ USELIBPCRE= \

View file

@ -1,5 +1,5 @@
#!/bin/sh /etc/rc.common #!/bin/sh /etc/rc.common
# Copyright (C) 2009-2012 OpenWrt.org # Copyright (C) 2009-2017 OpenWrt.org
START=95 START=95

View file

@ -1,6 +1,8 @@
diff --git a/Makefile b/Makefile
index b1cf9ce..28f90c3 100644
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -45,16 +45,12 @@ all: sslh $(MAN) echosrv @@ -65,16 +65,12 @@ all: sslh $(MAN) echosrv
version.h: version.h:
./genver.sh >version.h ./genver.sh >version.h
@ -15,15 +17,15 @@
- $(CC) $(CFLAGS) $(LDFLAGS) -o sslh-select sslh-select.o $(OBJS) $(LIBS) - $(CC) $(CFLAGS) $(LDFLAGS) -o sslh-select sslh-select.o $(OBJS) $(LIBS)
- #strip sslh-select - #strip sslh-select
- -
echosrv: $(OBJS) echosrv.o systemd-sslh-generator: systemd-sslh-generator.o
$(CC) $(CFLAGS) $(LDFLAGS) -o echosrv echosrv.o probe.o common.o $(LIBS) $(CC) $(CFLAGS) $(LDFLAGS) -o systemd-sslh-generator systemd-sslh-generator.o -lconfig
@@ -85,7 +81,7 @@ distclean: clean @@ -110,7 +106,7 @@ distclean: clean
rm -f tags cscope.* rm -f tags cscope.*
clean: clean:
- rm -f sslh-fork sslh-select echosrv version.h $(MAN) *.o *.gcov *.gcno *.gcda *.png *.html *.css *.info - rm -f sslh-fork sslh-select echosrv version.h $(MAN) systemd-sslh-generator *.o *.gcov *.gcno *.gcda *.png *.html *.css *.info
+ rm -f sslh-fork echosrv version.h $(MAN) *.o *.gcov *.gcno *.gcda *.png *.html *.css *.info + rm -f sslh-fork echosrv version.h $(MAN) systemd-sslh-generator *.o *.gcov *.gcno *.gcda *.png *.html *.css *.info
tags: tags:
ctags --globals -T *.[ch] ctags --globals -T *.[ch]

View file

@ -1,90 +0,0 @@
From 3aefaf300478cd6fbc4892d5baaf70521ed323af Mon Sep 17 00:00:00 2001
From: Yves Rutschle <git1@rutschle.net>
Date: Thu, 9 Jul 2015 15:31:42 +0200
Subject: [PATCH] Added Makefile option to build without libpcre
---
--- a/Makefile
+++ b/Makefile
@@ -2,6 +2,7 @@
VERSION=$(shell ./genver.sh -r)
USELIBCONFIG=1 # Use libconfig? (necessary to use configuration files)
+USELIBPCRE=1 # Use libpcre? (necessary to use regex probe)
USELIBWRAP?= # Use libwrap?
USELIBCAP= # Use libcap?
COV_TEST= # Perform test coverage?
@@ -27,6 +28,10 @@ ifneq ($(strip $(USELIBWRAP)),)
CPPFLAGS+=-DLIBWRAP
endif
+ifneq ($(strip $(USELIBPCRE)),)
+ CPPFLAGS+=-DLIBPCRE
+endif
+
ifneq ($(strip $(USELIBCONFIG)),)
LIBS:=$(LIBS) -lconfig
CPPFLAGS+=-DLIBCONFIG
--- a/probe.c
+++ b/probe.c
@@ -21,7 +21,9 @@
#define _GNU_SOURCE
#include <stdio.h>
+#ifdef LIBPCRE
#include <regex.h>
+#endif
#include <ctype.h>
#include "probe.h"
@@ -226,6 +228,7 @@ static int is_tls_protocol(const char *p
static int regex_probe(const char *p, int len, struct proto *proto)
{
+#ifdef LIBPCRE
regex_t **probe = proto->data;
regmatch_t pos = { 0, len };
@@ -233,6 +236,11 @@ static int regex_probe(const char *p, in
/* try them all */;
return (*probe != NULL);
+#else
+ /* Should never happen as we check when loading config file */
+ fprintf(stderr, "FATAL: regex probe called but not built in\n");
+ exit(5);
+#endif
}
/*
--- a/sslh-main.c
+++ b/sslh-main.c
@@ -25,7 +25,9 @@
#ifdef LIBCONFIG
#include <libconfig.h>
#endif
+#ifdef LIBPCRE
#include <regex.h>
+#endif
#include "common.h"
#include "probe.h"
@@ -174,6 +176,7 @@ static int config_listen(config_t *confi
#ifdef LIBCONFIG
static void setup_regex_probe(struct proto *p, config_setting_t* probes)
{
+#ifdef LIBPCRE
int num_probes, errsize, i, res;
char *err;
const char * expr;
@@ -201,6 +204,10 @@ static void setup_regex_probe(struct pro
exit(1);
}
}
+#else
+ fprintf(stderr, "line %d: regex probe specified but not compiled in\n", config_setting_source_line(probes));
+ exit(5);
+#endif
}
#endif