mariadb: update to 10.9.8
Remove upstreamed patch. Signed-off-by: Rosen Penev <rosenp@gmail.com> Tested-by: Michael Heimpold <mhei@heimpold.de>
This commit is contained in:
parent
1db5c54617
commit
94fd89a609
5 changed files with 8 additions and 18 deletions
|
@ -9,13 +9,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mariadb
|
||||
PKG_VERSION:=10.9.3
|
||||
PKG_RELEASE:=4
|
||||
PKG_VERSION:=10.9.8
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL := https://archive.mariadb.org/$(PKG_NAME)-$(PKG_VERSION)/source
|
||||
|
||||
PKG_HASH:=9a1e229972fcccc8270e633f68d3fb824da151dcf4f53da1df8d947aca876bee
|
||||
PKG_HASH:=fcdc6f73882477c20310e795a02f746e54934aa7a8b368900bd45e78a5daf6ed
|
||||
PKG_MAINTAINER:=Michal Hrusecky <Michal@Hrusecky.net>
|
||||
PKG_LICENSE:=GPL-2.0-only
|
||||
PKG_LICENSE_FILES:=COPYING THIRDPARTY
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/scripts/mysql_install_db.sh
|
||||
+++ b/scripts/mysql_install_db.sh
|
||||
@@ -437,7 +437,7 @@ fi
|
||||
@@ -439,7 +439,7 @@ fi
|
||||
|
||||
|
||||
# Try to determine the hostname
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/scripts/mysql_install_db.sh
|
||||
+++ b/scripts/mysql_install_db.sh
|
||||
@@ -369,6 +369,14 @@ then
|
||||
@@ -371,6 +371,14 @@ then
|
||||
exit 1
|
||||
fi
|
||||
plugindir=`find_in_dirs --dir auth_pam.so $basedir/lib*/plugin $basedir/lib*/mysql/plugin $basedir/lib/*/mariadb19/plugin`
|
||||
|
@ -15,7 +15,7 @@
|
|||
pamtooldir=$plugindir
|
||||
# relative from where the script was run for a relocatable install
|
||||
elif test -n "$dirname0" -a -x "$rel_mysqld" -a ! "$rel_mysqld" -ef "@sbindir@/mariadbd"
|
||||
@@ -501,7 +509,9 @@ do
|
||||
@@ -503,7 +511,9 @@ do
|
||||
fi
|
||||
done
|
||||
|
||||
|
@ -26,7 +26,7 @@
|
|||
then
|
||||
if test -z "$srcdir" -a "$in_rpm" -eq 0
|
||||
then
|
||||
@@ -522,6 +532,10 @@ then
|
||||
@@ -524,6 +534,10 @@ then
|
||||
echo
|
||||
fi
|
||||
fi
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/support-files/CMakeLists.txt
|
||||
+++ b/support-files/CMakeLists.txt
|
||||
@@ -62,7 +62,7 @@ IF(UNIX AND NOT WITHOUT_SERVER)
|
||||
@@ -66,7 +66,7 @@ IF(UNIX AND NOT WITHOUT_SERVER)
|
||||
INSTALL(FILES magic DESTINATION ${inst_location} COMPONENT SupportFiles)
|
||||
INSTALL(DIRECTORY policy DESTINATION ${inst_location} COMPONENT SupportFiles)
|
||||
FIND_PROGRAM(CHECKMODULE checkmodule)
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- a/tpool/aio_liburing.cc
|
||||
+++ b/tpool/aio_liburing.cc
|
||||
@@ -23,6 +23,7 @@ Foundation, Inc., 51 Franklin Street, Fi
|
||||
#include <algorithm>
|
||||
#include <vector>
|
||||
#include <thread>
|
||||
+#include <stdexcept>
|
||||
#include <mutex>
|
||||
|
||||
namespace
|
Loading…
Reference in a new issue