zile: Fix build with latest ncurses changes
Signed-off-by: Ted Hess <thess@kitschensync.net>
This commit is contained in:
parent
ba451bd8aa
commit
946ee98146
3 changed files with 2 additions and 28 deletions
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2006-2014 OpenWrt.org
|
||||
# Copyright (C) 2006-2016 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=zile
|
||||
PKG_VERSION:=2.3.24
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=4
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@GNU/zile
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- a/m4/ax_with_curses.m4
|
||||
+++ b/m4/ax_with_curses.m4
|
||||
@@ -72,7 +72,7 @@ AC_DEFUN([AX_WITH_CURSES],
|
||||
AC_CACHE_CHECK([for working ncursesw], ax_cv_ncursesw,
|
||||
[LIBS="$ax_save_LIBS -lncursesw"
|
||||
AC_TRY_LINK(
|
||||
- [#include <ncurses.h>],
|
||||
+ [#include <ncursesw/ncurses.h>],
|
||||
[chtype a; int b=A_STANDOUT, c=KEY_LEFT; initscr(); ],
|
||||
ax_cv_ncursesw=yes, ax_cv_ncursesw=no)])
|
||||
if test "$ax_cv_ncursesw" = yes
|
|
@ -1,15 +0,0 @@
|
|||
--- a/src/term_curses.c
|
||||
+++ b/src/term_curses.c
|
||||
@@ -23,7 +23,11 @@
|
||||
|
||||
#include <stdlib.h>
|
||||
#ifdef HAVE_NCURSES_H
|
||||
-#include <ncurses.h>
|
||||
+# ifdef HAVE_NCURSESW
|
||||
+# include <ncursesw/ncurses.h>
|
||||
+# else
|
||||
+# include <ncurses.h>
|
||||
+# endif
|
||||
#else
|
||||
#include <curses.h>
|
||||
#endif
|
Loading…
Reference in a new issue