lm-sensors: fix musl compatibility
Only use `asm/io.h` for uClibc, else include `sys/io.h` Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
This commit is contained in:
parent
22cd467290
commit
940c522cf6
2 changed files with 46 additions and 2 deletions
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2006-2014 OpenWrt.org
|
||||
# Copyright (C) 2006-2015 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=lm-sensors
|
||||
PKG_VERSION:=3.3.5
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=lm_sensors-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://dl.lm-sensors.org/lm-sensors/releases
|
||||
|
|
44
utils/lm-sensors/patches/100-musl-compat.patch
Normal file
44
utils/lm-sensors/patches/100-musl-compat.patch
Normal file
|
@ -0,0 +1,44 @@
|
|||
--- a/prog/dump/isadump.c
|
||||
+++ b/prog/dump/isadump.c
|
||||
@@ -38,7 +38,7 @@
|
||||
|
||||
|
||||
/* To keep glibc2 happy */
|
||||
-#if defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ >= 0
|
||||
+#if !defined(__UCLIBC__)
|
||||
#include <sys/io.h>
|
||||
#else
|
||||
#include <asm/io.h>
|
||||
--- a/prog/dump/isaset.c
|
||||
+++ b/prog/dump/isaset.c
|
||||
@@ -34,7 +34,7 @@
|
||||
|
||||
|
||||
/* To keep glibc2 happy */
|
||||
-#if defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ >= 0
|
||||
+#if !defined(__UCLIBC__)
|
||||
#include <sys/io.h>
|
||||
#else
|
||||
#include <asm/io.h>
|
||||
--- a/prog/dump/superio.c
|
||||
+++ b/prog/dump/superio.c
|
||||
@@ -21,7 +21,7 @@
|
||||
|
||||
#include <stdlib.h>
|
||||
|
||||
-#if defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ >= 0
|
||||
+#if !defined(__UCLIBC__)
|
||||
#include <sys/io.h>
|
||||
#else
|
||||
#include <asm/io.h>
|
||||
--- a/prog/dump/util.c
|
||||
+++ b/prog/dump/util.c
|
||||
@@ -12,7 +12,7 @@
|
||||
#include "util.h"
|
||||
|
||||
/* To keep glibc2 happy */
|
||||
-#if defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ >= 0
|
||||
+#if !defined(__UCLIBC__)
|
||||
#include <sys/io.h>
|
||||
#else
|
||||
#include <asm/io.h>
|
Loading…
Reference in a new issue