Merge pull request #3086 from kissg1988/pillow
pillow: upgrade to version 3.3.1
This commit is contained in:
commit
931b32ada2
2 changed files with 52 additions and 50 deletions
|
@ -7,7 +7,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=pillow
|
||||
PKG_VERSION:=3.2.0
|
||||
PKG_VERSION:=3.3.1
|
||||
PKG_RELEASE=1
|
||||
PKG_LICENSE:=CUSTOM
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
@ -15,7 +15,7 @@ PKG_LICENSE_FILES:=LICENSE
|
|||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/python-pillow/Pillow.git
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=344cb709ed0111adcc6ad47cc007507c3f5efeb3
|
||||
PKG_SOURCE_VERSION:=aab33141f381d5577cdef9033b7fdff79122a10c
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
||||
PKG_BUILD_DEPENDS:=python python-setuptools
|
||||
|
||||
|
@ -28,7 +28,7 @@ define Package/pillow
|
|||
CATEGORY:=Languages
|
||||
TITLE:=The friendly PIL fork
|
||||
MAINTAINER:=Gergely Kiss <mail.gery@gmail.com>
|
||||
URL:=https://www.pillowproject.com/
|
||||
URL:=https://python-pillow.org/
|
||||
DEPENDS:=+python +libfreetype +libjpeg +zlib +libtiff
|
||||
endef
|
||||
|
||||
|
|
|
@ -1,30 +1,33 @@
|
|||
diff -rupN Pillow-3.2.0.orig/setup.py Pillow-3.2.0/setup.py
|
||||
--- Pillow-3.2.0.orig/setup.py 2016-04-01 14:17:23.000000000 +0200
|
||||
+++ Pillow-3.2.0/setup.py 2016-04-28 23:24:08.633969175 +0200
|
||||
@@ -90,11 +90,11 @@ except (ImportError, OSError):
|
||||
diff -rupN pillow-3.3.1.orig/setup.py pillow-3.3.1/setup.py
|
||||
--- pillow-3.3.1.orig/setup.py 2016-08-22 17:45:05.000000000 +0200
|
||||
+++ pillow-3.3.1/setup.py 2016-08-22 18:09:51.947745155 +0200
|
||||
@@ -111,12 +111,12 @@ except (ImportError, OSError):
|
||||
|
||||
NAME = 'Pillow'
|
||||
PILLOW_VERSION = '3.2.0'
|
||||
TCL_ROOT = None
|
||||
PILLOW_VERSION = '3.3.1'
|
||||
-JPEG_ROOT = None
|
||||
+JPEG_ROOT = _lib_include(os.environ['STAGING_DIR'] + "/usr")
|
||||
JPEG2K_ROOT = None
|
||||
-ZLIB_ROOT = None
|
||||
+ZLIB_ROOT = _lib_include(os.environ['STAGING_DIR'] + "/usr")
|
||||
IMAGEQUANT_ROOT = None
|
||||
-TIFF_ROOT = None
|
||||
-FREETYPE_ROOT = None
|
||||
+ZLIB_ROOT = _lib_include(os.environ['STAGING_DIR'] + "/usr")
|
||||
+TIFF_ROOT = _lib_include(os.environ['STAGING_DIR'] + "/usr")
|
||||
+FREETYPE_ROOT = _lib_include(os.environ['STAGING_DIR'] + "/usr")
|
||||
LCMS_ROOT = None
|
||||
|
||||
|
||||
@@ -187,129 +187,6 @@ class pil_build_ext(build_ext):
|
||||
_add_directory(library_dirs, os.path.join(prefix, "lib"))
|
||||
@@ -221,161 +221,6 @@ class pil_build_ext(build_ext):
|
||||
_add_directory(include_dirs, os.path.join(prefix, "include"))
|
||||
|
||||
- #
|
||||
#
|
||||
- # add platform directories
|
||||
-
|
||||
- if sys.platform == "cygwin":
|
||||
- if self.disable_platform_guessing:
|
||||
- pass
|
||||
-
|
||||
- elif sys.platform == "cygwin":
|
||||
- # pythonX.Y.dll.a is in the /usr/lib/pythonX.Y/config directory
|
||||
- _add_directory(library_dirs,
|
||||
- os.path.join("/usr/lib", "python%s" %
|
||||
|
@ -42,7 +45,6 @@ diff -rupN Pillow-3.2.0.orig/setup.py Pillow-3.2.0/setup.py
|
|||
- _add_directory(include_dirs, "/opt/local/include")
|
||||
-
|
||||
- # if Homebrew is installed, use its lib and include directories
|
||||
- import subprocess
|
||||
- try:
|
||||
- prefix = subprocess.check_output(['brew', '--prefix']).strip(
|
||||
- ).decode('latin1')
|
||||
|
@ -122,10 +124,10 @@ diff -rupN Pillow-3.2.0.orig/setup.py Pillow-3.2.0/setup.py
|
|||
- raise ValueError(
|
||||
- "Unable to identify Linux platform: `%s`" % platform_)
|
||||
-
|
||||
- # XXX Kludge. Above /\ we brute force support multiarch. Here we
|
||||
- # try Barry's more general approach. Afterward, something should
|
||||
- # work ;-)
|
||||
- self.add_multiarch_paths()
|
||||
- # XXX Kludge. Above /\ we brute force support multiarch. Here we
|
||||
- # try Barry's more general approach. Afterward, something should
|
||||
- # work ;-)
|
||||
- self.add_multiarch_paths()
|
||||
-
|
||||
- elif sys.platform.startswith("gnu"):
|
||||
- self.add_multiarch_paths()
|
||||
|
@ -143,38 +145,38 @@ diff -rupN Pillow-3.2.0.orig/setup.py Pillow-3.2.0/setup.py
|
|||
- _add_directory(include_dirs, "/opt/local/include")
|
||||
-
|
||||
- # FIXME: check /opt/stuff directories here?
|
||||
-
|
||||
# locate tkinter libraries
|
||||
|
||||
if _tkinter:
|
||||
@@ -343,21 +220,6 @@ class pil_build_ext(build_ext):
|
||||
else:
|
||||
TCL_ROOT = None
|
||||
|
||||
- # add standard directories
|
||||
-
|
||||
- # look for tcl specific subdirectory (e.g debian)
|
||||
- if _tkinter:
|
||||
- tcl_dir = "/usr/include/tcl" + TCL_VERSION
|
||||
- if os.path.isfile(os.path.join(tcl_dir, "tk.h")):
|
||||
- _add_directory(include_dirs, tcl_dir)
|
||||
-
|
||||
- # standard locations
|
||||
- _add_directory(library_dirs, "/usr/local/lib")
|
||||
- _add_directory(include_dirs, "/usr/local/include")
|
||||
- if not self.disable_platform_guessing:
|
||||
- _add_directory(library_dirs, "/usr/local/lib")
|
||||
- _add_directory(include_dirs, "/usr/local/include")
|
||||
-
|
||||
- _add_directory(library_dirs, "/usr/lib")
|
||||
- _add_directory(include_dirs, "/usr/include")
|
||||
- _add_directory(library_dirs, "/usr/lib")
|
||||
- _add_directory(include_dirs, "/usr/include")
|
||||
- # alpine, at least
|
||||
- _add_directory(library_dirs, "/lib")
|
||||
-
|
||||
# on Windows, look for the OpenJPEG libraries in the location that
|
||||
# the official installer puts them
|
||||
if sys.platform == "win32":
|
||||
@@ -449,7 +311,7 @@ class pil_build_ext(build_ext):
|
||||
# look for freetype2 include files
|
||||
freetype_version = 0
|
||||
for dir in self.compiler.include_dirs:
|
||||
- if os.path.isfile(os.path.join(dir, "ft2build.h")):
|
||||
+ if os.path.isfile(os.path.join(dir, "freetype2/ft2build.h")):
|
||||
freetype_version = 21
|
||||
dir = os.path.join(dir, "freetype2")
|
||||
break
|
||||
- # on Windows, look for the OpenJPEG libraries in the location that
|
||||
- # the official installer puts them
|
||||
- if sys.platform == "win32":
|
||||
- program_files = os.environ.get('ProgramFiles', '')
|
||||
- best_version = (0, 0)
|
||||
- best_path = None
|
||||
- for name in os.listdir(program_files):
|
||||
- if name.startswith('OpenJPEG '):
|
||||
- version = tuple([int(x) for x in name[9:].strip().split(
|
||||
- '.')])
|
||||
- if version > best_version:
|
||||
- best_version = version
|
||||
- best_path = os.path.join(program_files, name)
|
||||
-
|
||||
- if best_path:
|
||||
- _dbg('Adding %s to search list', best_path)
|
||||
- _add_directory(library_dirs, os.path.join(best_path, 'lib'))
|
||||
- _add_directory(include_dirs,
|
||||
- os.path.join(best_path, 'include'))
|
||||
-
|
||||
- #
|
||||
# insert new dirs *before* default libs, to avoid conflicts
|
||||
# between Python PYD stub libs and real libraries
|
||||
|
||||
|
|
Loading…
Reference in a new issue