Merge pull request #13472 from RussellSenior/add-stm32flash-support-for-stm32g431
stm32flash: add support for STM32G431xx
This commit is contained in:
commit
92be53fa31
2 changed files with 12 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=stm32flash
|
||||
PKG_VERSION:=0.5
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
|
|
11
utils/stm32flash/patches/100-add_support_for_stm32g4.patch
Normal file
11
utils/stm32flash/patches/100-add_support_for_stm32g4.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/dev_table.c
|
||||
+++ b/dev_table.c
|
||||
@@ -90,6 +90,8 @@ const stm32_dev_t devices[] = {
|
||||
{0x434, "STM32F469xx" , 0x20003000, 0x20060000, 0x08000000, 0x08200000, 1, f4db , 0x1FFEC000, 0x1FFFC00F, 0x1FFF0000, 0x1FFF7800, 0},
|
||||
/* F7 */
|
||||
{0x449, "STM32F74xxx/75xxx" , 0x20004000, 0x20050000, 0x08000000, 0x08100000, 1, f7 , 0x1FFF0000, 0x1FFF001F, 0x1FF00000, 0x1FF0EDC0, 0},
|
||||
+ /* G4 */
|
||||
+ {0x468, "STM32G431xx/441xx" , 0x20000000, 0x20004000, 0x08000000, 0x08020000, 1, p_2k , 0x1FFF7800, 0x1FFF780F, 0x1FFF0000, 0x1FFF7000, 0},
|
||||
/* L0 */
|
||||
{0x425, "STM32L031xx/041xx" , 0x20001000, 0x20002000, 0x08000000, 0x08008000, 32, p_128 , 0x1FF80000, 0x1FF8001F, 0x1FF00000, 0x1FF01000, 0},
|
||||
{0x417, "STM32L05xxx/06xxx" , 0x20001000, 0x20002000, 0x08000000, 0x08010000, 32, p_128 , 0x1FF80000, 0x1FF8001F, 0x1FF00000, 0x1FF01000, 0},
|
Loading…
Reference in a new issue