python-hyperlink: Update to 20.0.1
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
This commit is contained in:
parent
c158c02bc5
commit
9277f74abd
2 changed files with 18 additions and 14 deletions
|
@ -8,11 +8,11 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=python-hyperlink
|
PKG_NAME:=python-hyperlink
|
||||||
PKG_VERSION:=19.0.0
|
PKG_VERSION:=20.0.1
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PYPI_NAME:=hyperlink
|
PYPI_NAME:=hyperlink
|
||||||
PKG_HASH:=4288e34705da077fada1111a24a0aa08bb1e76699c9ce49876af722441845654
|
PKG_HASH:=47fcc7cd339c6cb2444463ec3277bdcfe142c8b1daf2160bdd52248deec815af
|
||||||
|
|
||||||
PKG_LICENSE:=MIT
|
PKG_LICENSE:=MIT
|
||||||
PKG_LICENSE_FILES:=LICENSE
|
PKG_LICENSE_FILES:=LICENSE
|
||||||
|
@ -30,6 +30,7 @@ define Package/python3-hyperlink
|
||||||
URL:=https://github.com/python-hyper/hyperlink
|
URL:=https://github.com/python-hyper/hyperlink
|
||||||
DEPENDS:= \
|
DEPENDS:= \
|
||||||
+python3-light \
|
+python3-light \
|
||||||
|
+python3-codecs \
|
||||||
+python3-idna
|
+python3-idna
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
@ -39,6 +40,11 @@ on RFC 3986 and 3987, the Hyperlink URL makes working with both URIs and
|
||||||
IRIs easy.
|
IRIs easy.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Py3Package/python3-hyperlink/filespec
|
||||||
|
+|$(PYTHON3_PKG_DIR)
|
||||||
|
-|$(PYTHON3_PKG_DIR)/hyperlink/hypothesis.py
|
||||||
|
endef
|
||||||
|
|
||||||
$(eval $(call Py3Package,python3-hyperlink))
|
$(eval $(call Py3Package,python3-hyperlink))
|
||||||
$(eval $(call BuildPackage,python3-hyperlink))
|
$(eval $(call BuildPackage,python3-hyperlink))
|
||||||
$(eval $(call BuildPackage,python3-hyperlink-src))
|
$(eval $(call BuildPackage,python3-hyperlink-src))
|
||||||
|
|
|
@ -1,13 +1,11 @@
|
||||||
--- a/setup.py
|
--- a/setup.py
|
||||||
+++ b/setup.py
|
+++ b/setup.py
|
||||||
@@ -24,8 +24,9 @@ setup(name='hyperlink',
|
@@ -25,7 +25,7 @@ setup(
|
||||||
author=__author__,
|
author=__author__,
|
||||||
author_email=__contact__,
|
author_email=__contact__,
|
||||||
url=__url__,
|
url=__url__,
|
||||||
- packages=['hyperlink', 'hyperlink.test'],
|
- packages=find_packages(where="src"),
|
||||||
+ packages=['hyperlink'],
|
+ packages=find_packages(where="src", exclude=["*.test", "*.test.*"]),
|
||||||
include_package_data=True,
|
package_dir={"": "src"},
|
||||||
+ exclude_package_data={'':['test/*']},
|
package_data=dict(hyperlink=["py.typed"]),
|
||||||
zip_safe=False,
|
zip_safe=False,
|
||||||
license=__license__,
|
|
||||||
platforms='any',
|
|
||||||
|
|
Loading…
Reference in a new issue