grep: update to 2.22
Signed-off-by: Julen Landa Alustiza <julen@zokormazo.info>
This commit is contained in:
parent
5ec2a5e810
commit
91f81c65e9
2 changed files with 4 additions and 19 deletions
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2010-2012 OpenWrt.org
|
||||
# Copyright (C) 2010-2015 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=grep
|
||||
PKG_VERSION:=2.21
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=2.22
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@GNU/grep
|
||||
PKG_MD5SUM:=43c48064d6409862b8a850db83c8038a
|
||||
PKG_MD5SUM:=e1015e951a49a82b02e38891026ef5df
|
||||
|
||||
PKG_LICENSE:=GPL-3.0
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
diff --git a/src/kwset.c b/src/kwset.c
|
||||
index 4003c8d..376f7c3 100644
|
||||
--- a/src/kwset.c
|
||||
+++ b/src/kwset.c
|
||||
@@ -643,6 +643,8 @@ bmexec_trans (kwset_t kwset, char const *text, size_t size)
|
||||
if (! tp)
|
||||
return -1;
|
||||
tp++;
|
||||
+ if (ep <= tp)
|
||||
+ break;
|
||||
}
|
||||
}
|
||||
}
|
||||
--
|
||||
cgit v0.9.0.2
|
Loading…
Reference in a new issue