hcxdumptool: update to 6.2.4
Remove upstreamed patch. Refresh other. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
a7f07a6321
commit
911df9bfa5
3 changed files with 6 additions and 27 deletions
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=hcxdumptool
|
PKG_NAME:=hcxdumptool
|
||||||
PKG_VERSION:=6.1.6
|
PKG_VERSION:=6.2.4
|
||||||
PKG_RELEASE:=$(AUTORELEASE)
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/zerbea/hcxdumptool/tar.gz/$(PKG_VERSION)?
|
PKG_SOURCE_URL:=https://codeload.github.com/zerbea/hcxdumptool/tar.gz/$(PKG_VERSION)?
|
||||||
PKG_HASH:=e3212bd808e228c28ecfeeb4a9709480aa178b2e8b15c0a7d96733b648f8da85
|
PKG_HASH:=cadeb4b2f00da3a1df65cb53080e134f201ef73825d35049110764faf699028d
|
||||||
|
|
||||||
PKG_MAINTAINER:=Andreas Nilsen <adde88@gmail.com>
|
PKG_MAINTAINER:=Andreas Nilsen <adde88@gmail.com>
|
||||||
PKG_LICENSE:=MIT
|
PKG_LICENSE:=MIT
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/hcxdumptool.c
|
--- a/hcxdumptool.c
|
||||||
+++ b/hcxdumptool.c
|
+++ b/hcxdumptool.c
|
||||||
@@ -480,10 +480,6 @@ if(rebootflag == true)
|
@@ -571,10 +571,6 @@ if(rebootflag == true)
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -11,7 +11,7 @@
|
||||||
if(errorcount != 0) exit(EXIT_FAILURE);
|
if(errorcount != 0) exit(EXIT_FAILURE);
|
||||||
if(totflag == true) exit(USER_EXIT_TOT);
|
if(totflag == true) exit(USER_EXIT_TOT);
|
||||||
exit(EXIT_SUCCESS);
|
exit(EXIT_SUCCESS);
|
||||||
@@ -7270,8 +7266,6 @@ return true;
|
@@ -7777,8 +7773,6 @@ return true;
|
||||||
/*===========================================================================*/
|
/*===========================================================================*/
|
||||||
static inline bool tlsinit()
|
static inline bool tlsinit()
|
||||||
{
|
{
|
||||||
|
@ -20,7 +20,7 @@
|
||||||
if((tlsctx = SSL_CTX_new(SSLv23_server_method())) == NULL)
|
if((tlsctx = SSL_CTX_new(SSLv23_server_method())) == NULL)
|
||||||
{
|
{
|
||||||
fprintf(stderr, "OpenSSl can't create SSL context\n");
|
fprintf(stderr, "OpenSSl can't create SSL context\n");
|
||||||
@@ -7290,7 +7284,6 @@ if(SSL_CTX_use_PrivateKey_file(tlsctx, e
|
@@ -7797,7 +7791,6 @@ if(SSL_CTX_use_PrivateKey_file(tlsctx, e
|
||||||
if((eaptlsctx = (eaptlsctx_t*)malloc(EAPTLSCTX_SIZE)) == NULL) return false;
|
if((eaptlsctx = (eaptlsctx_t*)malloc(EAPTLSCTX_SIZE)) == NULL) return false;
|
||||||
memset(eaptlsctx, 0, EAPTLSCTX_SIZE);
|
memset(eaptlsctx, 0, EAPTLSCTX_SIZE);
|
||||||
SSL_CTX_set_session_cache_mode(tlsctx, SSL_SESS_CACHE_OFF);
|
SSL_CTX_set_session_cache_mode(tlsctx, SSL_SESS_CACHE_OFF);
|
||||||
|
@ -28,7 +28,7 @@
|
||||||
SSL_CTX_set_verify(tlsctx, (SSL_VERIFY_PEER|SSL_VERIFY_CLIENT_ONCE), eap_tls_clientverify_cb);
|
SSL_CTX_set_verify(tlsctx, (SSL_VERIFY_PEER|SSL_VERIFY_CLIENT_ONCE), eap_tls_clientverify_cb);
|
||||||
#if (OPENSSL_VERSION_NUMBER >= 0x10100000L)
|
#if (OPENSSL_VERSION_NUMBER >= 0x10100000L)
|
||||||
SSL_CTX_set_min_proto_version(tlsctx, TLS1_VERSION);
|
SSL_CTX_set_min_proto_version(tlsctx, TLS1_VERSION);
|
||||||
@@ -7364,8 +7357,6 @@ if(gpiostatusled > 0)
|
@@ -7872,8 +7865,6 @@ if(gpiostatusled > 0)
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
||||||
|
|
|
@ -1,21 +0,0 @@
|
||||||
From 63012853a81aa623f09304baf1f5b0b69f1ebfbd Mon Sep 17 00:00:00 2001
|
|
||||||
From: Tristian <2220506+Tristian@users.noreply.github.com>
|
|
||||||
Date: Tue, 16 Mar 2021 16:17:07 -0400
|
|
||||||
Subject: [PATCH] fix assignment of read-only variable 'stdout'
|
|
||||||
|
|
||||||
- stdout cannot be reassigned on some systems i.e OpenWRT on mipsel
|
|
||||||
---
|
|
||||||
hcxdumptool.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
--- a/hcxdumptool.c
|
|
||||||
+++ b/hcxdumptool.c
|
|
||||||
@@ -7958,7 +7958,7 @@ while((auswahl = getopt_long(argc, argv,
|
|
||||||
else
|
|
||||||
{
|
|
||||||
fd_pcapng = fileno(stdout);
|
|
||||||
- stdout = fopen("/dev/null", "w");
|
|
||||||
+ freopen("/dev/null", "w", stdout);
|
|
||||||
}
|
|
||||||
}
|
|
||||||
pcapngoutname = optarg;
|
|
Loading…
Reference in a new issue