Merge pull request #1491 from tru7/knxd

knxd: fix musl compatibility
This commit is contained in:
Jo-Philipp Wich 2015-06-28 14:57:24 +02:00
commit 90a4712fd8
2 changed files with 12 additions and 2 deletions

View file

@ -11,12 +11,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=knxd
PKG_VERSION=2015-06-02-$(PKG_SOURCE_VERSION)
PKG_VERSION=2015-06-27-$(PKG_SOURCE_VERSION)
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/knxd/knxd.git
PKG_SOURCE_VERSION:=3d3b1a5e8112397d297625d673a2a94507f9ebce
PKG_SOURCE_VERSION:=50e7f6e6bfa13c2b6140b0f76aaa70234bf44b1d
PKG_SOURCE_SUBDIR:=$(PKG_NAME)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.gz

View file

@ -0,0 +1,10 @@
--- a/src/examples/common.h 2015-06-27 15:20:15.266563893 +0200
+++ b/src/examples/common.h 2015-06-27 15:23:09.406457392 +0200
@@ -20,6 +20,7 @@
#include <stdlib.h>
#include <errno.h>
#include <unistd.h>
+#include <sys/select.h>
#include "eibclient.h"
/** unsigned char*/