Bluez: Update to 5.55
Signed-off-by: Johnny Vogels <35307256+jmv2009@users.noreply.github.com>
(cherry picked from commit d653862bd7
)
This commit is contained in:
parent
b86383f038
commit
9072b66e56
3 changed files with 8 additions and 8 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=bluez
|
||||
PKG_VERSION:=5.54
|
||||
PKG_VERSION:=5.55
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@KERNEL/linux/bluetooth/
|
||||
PKG_HASH:=68cdab9e63e8832b130d5979dc8c96fdb087b31278f342874d992af3e56656dc
|
||||
PKG_HASH:=8863717113c4897e2ad3271fc808ea245319e6fd95eed2e934fae8e0894e9b88
|
||||
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -3214,7 +3214,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@@ -3212,7 +3212,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@CLIENT_TRUE@ client/gatt.h client/gatt.c
|
||||
|
||||
@CLIENT_TRUE@client_bluetoothctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
|
||||
|
@ -9,7 +9,7 @@
|
|||
|
||||
@ZSH_COMPLETIONS_TRUE@zshcompletiondir = $(ZSH_COMPLETIONDIR)
|
||||
@ZSH_COMPLETIONS_TRUE@dist_zshcompletion_DATA = completion/zsh/_bluetoothctl
|
||||
@@ -3452,7 +3452,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@@ -3450,7 +3450,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
|
||||
@MESH_TRUE@@TOOLS_TRUE@tools_meshctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
|
||||
@MESH_TRUE@@TOOLS_TRUE@ lib/libbluetooth-internal.la \
|
||||
|
@ -18,7 +18,7 @@
|
|||
|
||||
@MESH_TRUE@@TOOLS_TRUE@tools_mesh_cfgclient_SOURCES = tools/mesh-cfgclient.c \
|
||||
@MESH_TRUE@@TOOLS_TRUE@ tools/mesh/model.h tools/mesh/config-model.h \
|
||||
@@ -3520,7 +3520,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@@ -3517,7 +3517,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@READLINE_TRUE@ tools/obex-client-tool.c
|
||||
|
||||
@READLINE_TRUE@tools_obex_client_tool_LDADD = lib/libbluetooth-internal.la \
|
||||
|
@ -27,7 +27,7 @@
|
|||
|
||||
@READLINE_TRUE@tools_obex_server_tool_SOURCES = $(gobex_sources) $(btio_sources) \
|
||||
@READLINE_TRUE@ tools/obex-server-tool.c
|
||||
@@ -3529,15 +3529,15 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@@ -3526,15 +3526,15 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@READLINE_TRUE@tools_bluetooth_player_SOURCES = tools/bluetooth-player.c
|
||||
@READLINE_TRUE@tools_bluetooth_player_LDADD = gdbus/libgdbus-internal.la \
|
||||
@READLINE_TRUE@ src/libshared-glib.la \
|
||||
|
@ -46,7 +46,7 @@
|
|||
|
||||
@DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_SOURCES = attrib/gatttool.c attrib/att.c attrib/gatt.c \
|
||||
@DEPRECATED_TRUE@@READLINE_TRUE@ attrib/gattrib.c btio/btio.c \
|
||||
@@ -3546,7 +3546,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@@ -3543,7 +3543,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@DEPRECATED_TRUE@@READLINE_TRUE@ client/display.h
|
||||
|
||||
@DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_LDADD = lib/libbluetooth-internal.la \
|
||||
|
|
|
@ -34,7 +34,7 @@ This commit prevents the call to btd_adv_manager_refresh for non-LE devices.
|
|||
|
||||
--- a/src/adapter.c
|
||||
+++ b/src/adapter.c
|
||||
@@ -567,7 +567,8 @@ static void settings_changed(struct btd_
|
||||
@@ -573,7 +573,8 @@ static void settings_changed(struct btd_
|
||||
g_dbus_emit_property_changed(dbus_conn, adapter->path,
|
||||
ADAPTER_INTERFACE, "Discoverable");
|
||||
store_adapter_info(adapter);
|
||||
|
|
Loading…
Reference in a new issue