Merge pull request #7558 from pprindeville/perl-update-5.28.1
perl: update to 5.28.1
This commit is contained in:
commit
8f745900df
9 changed files with 32 additions and 58 deletions
|
@ -11,7 +11,7 @@ include perlver.mk
|
|||
|
||||
PKG_NAME:=perl
|
||||
PKG_VERSION:=$(PERL_VERSION)
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_URL:=\
|
||||
https://cpan.metacpan.org/src/5.0 \
|
||||
|
@ -21,7 +21,7 @@ PKG_SOURCE_URL:=\
|
|||
https://mirrors.sonic.net/cpan/src/5.0 \
|
||||
https://www.cpan.org/src/5.0
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_HASH:=059b3cb69970d8c8c5964caced0335b4af34ac990c8e61f7e3f90cd1c2d11e49
|
||||
PKG_HASH:=fea7162d4cca940a387f0587b93f6737d884bf74d8a9d7cfd978bc12cd0b202d
|
||||
|
||||
PKG_LICENSE:=GPL-1.0+ Artistic-1.0-Perl
|
||||
PKG_LICENSE_FILES:=Copying Artistic README
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
# Set the version here
|
||||
PERL_REVISION=5
|
||||
PERL_VERSION=28
|
||||
PERL_SUBVERSION=0
|
||||
PERL_SUBVERSION=1
|
||||
|
||||
# (api_revison, api_version, api_subversion) = (revision, version, 0) usually
|
||||
PERL_API_REVISION=5
|
||||
|
|
|
@ -8,8 +8,6 @@ Subject: (perl #133411) don't try to load Storable with -Dusecrosscompile
|
|||
dist/Storable/stacksize | 10 +++++++---
|
||||
2 files changed, 15 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/dist/Storable/Makefile.PL b/dist/Storable/Makefile.PL
|
||||
index a5d9e66891..db420ab30b 100644
|
||||
--- a/dist/Storable/Makefile.PL
|
||||
+++ b/dist/Storable/Makefile.PL
|
||||
@@ -90,12 +90,19 @@ sub depend {
|
||||
|
@ -33,8 +31,6 @@ index a5d9e66891..db420ab30b 100644
|
|||
|
||||
release : dist
|
||||
git tag \$(VERSION)
|
||||
diff --git a/dist/Storable/stacksize b/dist/Storable/stacksize
|
||||
index 7abd3a84cc..14e0739734 100644
|
||||
--- a/dist/Storable/stacksize
|
||||
+++ b/dist/Storable/stacksize
|
||||
@@ -7,6 +7,9 @@ use Cwd;
|
||||
|
@ -68,6 +64,3 @@ index 7abd3a84cc..14e0739734 100644
|
|||
if ($^O eq "MSWin32") {
|
||||
require Win32;
|
||||
my ($str, $major, $minor) = Win32::GetOSVersion();
|
||||
--
|
||||
2.11.0
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/Makefile.SH
|
||||
+++ b/Makefile.SH
|
||||
@@ -334,22 +334,11 @@ MANIFEST_SRT = MANIFEST.srt
|
||||
@@ -339,22 +339,11 @@ MANIFEST_SRT = MANIFEST.srt
|
||||
|
||||
!GROK!THIS!
|
||||
|
||||
|
|
|
@ -1,8 +1,6 @@
|
|||
Index: perl-5.26.1/perl.c
|
||||
===================================================================
|
||||
--- perl-5.26.1.orig/perl.c
|
||||
+++ perl-5.26.1/perl.c
|
||||
@@ -1878,16 +1878,6 @@ S_Internals_V(pTHX_ CV *cv)
|
||||
--- a/perl.c
|
||||
+++ b/perl.c
|
||||
@@ -1987,16 +1987,6 @@ S_Internals_V(pTHX_ CV *cv)
|
||||
PUSHs(Perl_newSVpvn_flags(aTHX_ non_bincompat_options,
|
||||
sizeof(non_bincompat_options) - 1, SVs_TEMP));
|
||||
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- a/Makefile.SH 2017-10-17 11:59:52.938763142 -0600
|
||||
+++ b/Makefile.SH 2017-10-17 12:13:46.202555604 -0600
|
||||
--- a/Makefile.SH
|
||||
+++ b/Makefile.SH
|
||||
@@ -275,6 +275,7 @@ LNS = $lns
|
||||
# NOTE: some systems don't grok "cp -f". XXX Configure test needed?
|
||||
CPS = $cp
|
||||
|
@ -120,8 +120,8 @@
|
|||
!NO!SUBS!
|
||||
|
||||
case $osname in
|
||||
@@ -1119,8 +1120,8 @@ pod/perl5280delta.pod: pod/perldelta.pod
|
||||
$(LNS) perldelta.pod pod/perl5280delta.pod
|
||||
@@ -1119,8 +1120,8 @@ pod/perl5281delta.pod: pod/perldelta.pod
|
||||
$(LNS) perldelta.pod pod/perl5281delta.pod
|
||||
|
||||
extra.pods: $(MINIPERL_EXE)
|
||||
- -@test ! -f extra.pods || rm -f `cat extra.pods`
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/Makefile.SH 2017-10-15 18:57:08.436234652 -0600
|
||||
+++ b/Makefile.SH 2017-10-15 19:02:47.587658819 -0600
|
||||
@@ -328,7 +328,7 @@ PATH_SEP = $p_
|
||||
--- a/Makefile.SH
|
||||
+++ b/Makefile.SH
|
||||
@@ -333,7 +333,7 @@ PATH_SEP = $p_
|
||||
# Macros to invoke a copy of miniperl during the build. Targets which
|
||||
# are built using these macros should depend on \$(MINIPERL_EXE)
|
||||
MINIPERL_EXE = miniperl\$(EXE_EXT)
|
||||
|
@ -9,7 +9,7 @@
|
|||
|
||||
# Macros to invoke sort the MANIFEST during build
|
||||
MANIFEST_SRT = MANIFEST.srt
|
||||
@@ -991,7 +991,7 @@ NAMESPACEFLAGS = -force_flat_namespace
|
||||
@@ -996,7 +996,7 @@ lib/buildcustomize.pl: $& $(miniperl_obj
|
||||
@$(RMS) miniperl.xok
|
||||
$(CC) $(CLDFLAGS) $(NAMESPACEFLAGS) -o $(MINIPERL_EXE) \
|
||||
$(miniperl_objs) $(libs)
|
||||
|
@ -18,7 +18,7 @@
|
|||
$(MINIPERL) -f write_buildcustomize.pl
|
||||
!NO!SUBS!
|
||||
;;
|
||||
@@ -1002,16 +1002,16 @@ lib/buildcustomize.pl: $& $(miniperl_obj
|
||||
@@ -1007,7 +1007,7 @@ lib/buildcustomize.pl: \$& \$(miniperl_d
|
||||
@\$(RMS) miniperl.xok
|
||||
@\$(RMS) \$(MINIPERL_EXE)
|
||||
\$(LNS) \$(HOST_PERL) \$(MINIPERL_EXE)
|
||||
|
@ -27,8 +27,7 @@
|
|||
\$(MINIPERL) -f write_buildcustomize.pl 'osname' "$osname"
|
||||
!GROK!THIS!
|
||||
else
|
||||
$spitshell >>$Makefile <<'!NO!SUBS!'
|
||||
lib/buildcustomize.pl: $& $(miniperl_dep) write_buildcustomize.pl
|
||||
@@ -1016,7 +1016,7 @@ lib/buildcustomize.pl: $& $(miniperl_dep
|
||||
@$(RMS) miniperl.xok
|
||||
$(CC) $(CLDFLAGS) -o $(MINIPERL_EXE) \
|
||||
$(miniperl_objs) $(libs)
|
||||
|
|
|
@ -7,11 +7,9 @@ Date: Wed May 23 15:32:47 2018 -0600
|
|||
Several problems with this compile option were not caught before 5.28
|
||||
was frozen.
|
||||
|
||||
diff --git a/embed.fnc b/embed.fnc
|
||||
index 0f06e38..36f9f97 100644
|
||||
--- a/embed.fnc
|
||||
+++ b/embed.fnc
|
||||
@@ -2765,9 +2765,11 @@ s |bool |isa_lookup |NN HV *stash|NN const char * const name \
|
||||
@@ -2793,9 +2793,11 @@ s |bool |isa_lookup |NN HV *stash|NN con
|
||||
#endif
|
||||
|
||||
#if defined(PERL_IN_LOCALE_C)
|
||||
|
@ -23,11 +21,9 @@ index 0f06e38..36f9f97 100644
|
|||
# ifdef HAS_NL_LANGINFO
|
||||
sn |const char*|my_nl_langinfo|const nl_item item|bool toggle
|
||||
# else
|
||||
diff --git a/embed.h b/embed.h
|
||||
index cf3ad9e..fb66c26 100644
|
||||
--- a/embed.h
|
||||
+++ b/embed.h
|
||||
@@ -1724,16 +1724,16 @@
|
||||
@@ -1796,16 +1796,16 @@
|
||||
#define unshare_hek_or_pvn(a,b,c,d) S_unshare_hek_or_pvn(aTHX_ a,b,c,d)
|
||||
# endif
|
||||
# if defined(PERL_IN_LOCALE_C)
|
||||
|
@ -47,8 +43,6 @@ index cf3ad9e..fb66c26 100644
|
|||
# if defined(USE_POSIX_2008_LOCALE)
|
||||
#define emulate_setlocale S_emulate_setlocale
|
||||
# endif
|
||||
diff --git a/locale.c b/locale.c
|
||||
index 7653340..f8f77fb 100644
|
||||
--- a/locale.c
|
||||
+++ b/locale.c
|
||||
@@ -1264,6 +1264,7 @@ S_locking_setlocale(pTHX_
|
||||
|
@ -59,7 +53,7 @@ index 7653340..f8f77fb 100644
|
|||
|
||||
STATIC void
|
||||
S_set_numeric_radix(pTHX_ const bool use_locale)
|
||||
@@ -1299,6 +1300,10 @@ S_set_numeric_radix(pTHX_ const bool use_locale)
|
||||
@@ -1299,6 +1300,10 @@ S_set_numeric_radix(pTHX_ const bool use
|
||||
}
|
||||
|
||||
# endif
|
||||
|
@ -87,7 +81,7 @@ index 7653340..f8f77fb 100644
|
|||
#ifdef WIN32
|
||||
|
||||
STATIC char *
|
||||
@@ -2139,11 +2145,20 @@ Perl_setlocale(const int category, const char * locale)
|
||||
@@ -2139,11 +2145,20 @@ Perl_setlocale(const int category, const
|
||||
{
|
||||
/* This wraps POSIX::setlocale() */
|
||||
|
||||
|
@ -109,7 +103,7 @@ index 7653340..f8f77fb 100644
|
|||
|
||||
#ifdef USE_LOCALE_NUMERIC
|
||||
|
||||
@@ -2262,6 +2277,8 @@ Perl_setlocale(const int category, const char * locale)
|
||||
@@ -2262,6 +2277,8 @@ Perl_setlocale(const int category, const
|
||||
|
||||
return retval;
|
||||
|
||||
|
@ -118,7 +112,7 @@ index 7653340..f8f77fb 100644
|
|||
}
|
||||
|
||||
PERL_STATIC_INLINE const char *
|
||||
@@ -2414,13 +2431,16 @@ S_my_nl_langinfo(const int item, bool toggle)
|
||||
@@ -2414,13 +2431,16 @@ S_my_nl_langinfo(const int item, bool to
|
||||
dTHX;
|
||||
const char * retval;
|
||||
|
||||
|
@ -137,7 +131,7 @@ index 7653340..f8f77fb 100644
|
|||
|
||||
#if defined(HAS_NL_LANGINFO) /* nl_langinfo() is available. */
|
||||
# if ! defined(HAS_THREAD_SAFE_NL_LANGINFO_L) \
|
||||
@@ -2468,6 +2488,8 @@ S_my_nl_langinfo(const int item, bool toggle)
|
||||
@@ -2468,6 +2488,8 @@ S_my_nl_langinfo(const int item, bool to
|
||||
do_free = TRUE;
|
||||
}
|
||||
|
||||
|
@ -146,7 +140,7 @@ index 7653340..f8f77fb 100644
|
|||
if (toggle) {
|
||||
if (PL_underlying_numeric_obj) {
|
||||
cur = PL_underlying_numeric_obj;
|
||||
@@ -2478,6 +2500,8 @@ S_my_nl_langinfo(const int item, bool toggle)
|
||||
@@ -2478,6 +2500,8 @@ S_my_nl_langinfo(const int item, bool to
|
||||
}
|
||||
}
|
||||
|
||||
|
@ -176,7 +170,7 @@ index 7653340..f8f77fb 100644
|
|||
|
||||
SAVEFREEPV(errstr);
|
||||
return errstr;
|
||||
@@ -5301,10 +5324,17 @@ L<C<Perl_switch_to_global_locale>|perlapi/switch_to_global_locale>.
|
||||
@@ -5301,10 +5324,17 @@ L<C<Perl_switch_to_global_locale>|perlap
|
||||
bool
|
||||
Perl_sync_locale()
|
||||
{
|
||||
|
@ -267,8 +261,6 @@ index 7653340..f8f77fb 100644
|
|||
}
|
||||
|
||||
#if defined(DEBUGGING) && defined(USE_LOCALE)
|
||||
diff --git a/makedef.pl b/makedef.pl
|
||||
index dbd756d..661b71d 100644
|
||||
--- a/makedef.pl
|
||||
+++ b/makedef.pl
|
||||
@@ -574,6 +574,9 @@ unless ($define{USE_LOCALE_COLLATE}) {
|
||||
|
@ -291,11 +283,9 @@ index dbd756d..661b71d 100644
|
|||
);
|
||||
}
|
||||
|
||||
diff --git a/perl.h b/perl.h
|
||||
index 3e1f6cd..d457776 100644
|
||||
--- a/perl.h
|
||||
+++ b/perl.h
|
||||
@@ -5657,6 +5657,9 @@ typedef struct am_table_short AMTS;
|
||||
@@ -5656,6 +5656,9 @@ typedef struct am_table_short AMTS;
|
||||
# define IN_LC_COMPILETIME(category) 0
|
||||
# define IN_LC_RUNTIME(category) 0
|
||||
# define IN_LC(category) 0
|
||||
|
@ -305,11 +295,9 @@ index 3e1f6cd..d457776 100644
|
|||
#endif
|
||||
|
||||
|
||||
diff --git a/proto.h b/proto.h
|
||||
index 3e027ab..558c33a 100644
|
||||
--- a/proto.h
|
||||
+++ b/proto.h
|
||||
@@ -4669,8 +4669,6 @@ PERL_CALLCONV SV* Perl_hfree_next_entry(pTHX_ HV *hv, STRLEN *indexp);
|
||||
@@ -4886,8 +4886,6 @@ PERL_CALLCONV SV* Perl_hfree_next_entry(
|
||||
assert(hv); assert(indexp)
|
||||
#endif
|
||||
#if defined(PERL_IN_LOCALE_C)
|
||||
|
@ -318,7 +306,7 @@ index 3e027ab..558c33a 100644
|
|||
#ifndef PERL_NO_INLINE_FUNCTIONS
|
||||
PERL_STATIC_INLINE const char * S_save_to_buffer(const char * string, char **buf, Size_t *buf_size, const Size_t offset)
|
||||
__attribute__warn_unused_result__;
|
||||
@@ -4678,17 +4676,19 @@ PERL_STATIC_INLINE const char * S_save_to_buffer(const char * string, char **buf
|
||||
@@ -4895,17 +4893,19 @@ PERL_STATIC_INLINE const char * S_save_t
|
||||
assert(buf_size)
|
||||
#endif
|
||||
|
||||
|
@ -339,11 +327,9 @@ index 3e027ab..558c33a 100644
|
|||
# if defined(USE_POSIX_2008_LOCALE)
|
||||
STATIC const char* S_emulate_setlocale(const int category, const char* locale, unsigned int index, const bool is_index_valid);
|
||||
# endif
|
||||
diff --git a/sv.c b/sv.c
|
||||
index 07865bb..81223ca 100644
|
||||
--- a/sv.c
|
||||
+++ b/sv.c
|
||||
@@ -13330,10 +13330,15 @@ Perl_sv_vcatpvfn_flags(pTHX_ SV *const sv, const char *const pat, const STRLEN p
|
||||
@@ -13330,10 +13330,15 @@ Perl_sv_vcatpvfn_flags(pTHX_ SV *const s
|
||||
|
||||
SvTAINT(sv);
|
||||
|
||||
|
@ -359,11 +345,9 @@ index 07865bb..81223ca 100644
|
|||
}
|
||||
|
||||
/* =========================================================================
|
||||
diff --git a/t/lib/warnings/regexec b/t/lib/warnings/regexec
|
||||
index 900dd6e..b9e53c9 100644
|
||||
--- a/t/lib/warnings/regexec
|
||||
+++ b/t/lib/warnings/regexec
|
||||
@@ -215,6 +215,10 @@ Use of \b{} or \B{} for non-UTF-8 locale is wrong. Assuming a UTF-8 locale at -
|
||||
@@ -215,6 +215,10 @@ Use of \b{} or \B{} for non-UTF-8 locale
|
||||
Use of \b{} or \B{} for non-UTF-8 locale is wrong. Assuming a UTF-8 locale at - line 17.
|
||||
########
|
||||
# NAME (?[ ]) in non-UTF-8 locale
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
PERL_VERSION:=5.28.0
|
||||
PERL_VERSION:=5.28.1
|
||||
|
||||
PERL_EXPLODE:=$(subst ., ,$(PERL_VERSION))
|
||||
|
||||
|
|
Loading…
Reference in a new issue