nspr: update to 4.22
drop upstreamed patches
Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
(cherry picked from commit af9209fb31
)
This commit is contained in:
parent
78e241c54b
commit
8f48dc3341
4 changed files with 6 additions and 94 deletions
|
@ -7,7 +7,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=nspr
|
||||
PKG_VERSION:=4.21
|
||||
PKG_VERSION:=4.22
|
||||
PKG_RELEASE:=1
|
||||
PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
|
||||
PKG_LICENCE:=MPL-2.0
|
||||
|
@ -16,7 +16,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|||
PKG_SOURCE_URL:= \
|
||||
https://download.cdn.mozilla.net/pub/$(PKG_NAME)/releases/v$(PKG_VERSION)/src/ \
|
||||
https://archive.mozilla.org/pub/$(PKG_NAME)/releases/v$(PKG_VERSION)/src/
|
||||
PKG_HASH:=15ea32c7b100217b6e3193bc03e77f485d9bf7504051443ba9ce86d1c17c6b5a
|
||||
PKG_HASH:=c9e4b6cc24856ec93202fe13704b38b38ba219f0f2aeac93090ce2b6c696d430
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
|
|
|
@ -26,7 +26,7 @@ diff --git a/lib/ds/Makefile.in b/lib/ds/Makefile.in
|
|||
index e737791..b578476 100644
|
||||
--- a/nspr/lib/ds/Makefile.in
|
||||
+++ b/nspr/lib/ds/Makefile.in
|
||||
@@ -114,13 +114,7 @@ GARBAGE += $(TINC)
|
||||
@@ -110,13 +110,7 @@ GARBAGE += $(TINC)
|
||||
|
||||
$(TINC):
|
||||
@$(MAKE_OBJDIR)
|
||||
|
@ -45,7 +45,7 @@ diff --git a/lib/libc/src/Makefile.in b/lib/libc/src/Makefile.in
|
|||
index e8a6d9f..978ed28 100644
|
||||
--- a/nspr/lib/libc/src/Makefile.in
|
||||
+++ b/nspr/lib/libc/src/Makefile.in
|
||||
@@ -116,13 +116,7 @@ GARBAGE += $(TINC)
|
||||
@@ -112,13 +112,7 @@ GARBAGE += $(TINC)
|
||||
|
||||
$(TINC):
|
||||
@$(MAKE_OBJDIR)
|
||||
|
@ -64,7 +64,7 @@ diff --git a/lib/prstreams/Makefile.in b/lib/prstreams/Makefile.in
|
|||
index aeb2944..f318097 100644
|
||||
--- a/nspr/lib/prstreams/Makefile.in
|
||||
+++ b/nspr/lib/prstreams/Makefile.in
|
||||
@@ -116,13 +116,7 @@ endif
|
||||
@@ -110,13 +110,7 @@ endif
|
||||
|
||||
$(TINC):
|
||||
@$(MAKE_OBJDIR)
|
||||
|
@ -83,7 +83,7 @@ diff --git a/pr/src/Makefile.in b/pr/src/Makefile.in
|
|||
index 19c5a69..b4ac31c 100644
|
||||
--- a/nspr/pr/src/Makefile.in
|
||||
+++ b/nspr/pr/src/Makefile.in
|
||||
@@ -326,13 +326,7 @@ GARBAGE += $(TINC)
|
||||
@@ -310,13 +310,7 @@ GARBAGE += $(TINC)
|
||||
|
||||
$(TINC):
|
||||
@$(MAKE_OBJDIR)
|
||||
|
|
|
@ -1,88 +0,0 @@
|
|||
From 6cb5b0be8837222a1e01745f2cf57cd0e593186d Mon Sep 17 00:00:00 2001
|
||||
From: Antoine Tenart <antoine.tenart@free-electrons.com>
|
||||
Date: Mon, 23 Oct 2017 10:28:20 +0200
|
||||
Subject: [PATCH] Add ARC support
|
||||
|
||||
[Alexey: Rebased on top of other patches like RiscV, NIOS2 etc].
|
||||
|
||||
Signed-off-by: Antoine Tenart <antoine.tenart@bootlin.com>
|
||||
Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
|
||||
|
||||
Upstream-Status: Submitted [ https://bugzilla.mozilla.org/show_bug.cgi?id=1492378 ]
|
||||
---
|
||||
pr/include/md/_linux.cfg | 45 ++++++++++++++++++++++++++++++++++++++++
|
||||
pr/include/md/_linux.h | 2 ++
|
||||
2 files changed, 47 insertions(+)
|
||||
|
||||
diff --git a/pr/include/md/_linux.cfg b/pr/include/md/_linux.cfg
|
||||
index fec8525378dc..5f4fa0eac783 100644
|
||||
--- a/nspr/pr/include/md/_linux.cfg
|
||||
+++ b/nspr/pr/include/md/_linux.cfg
|
||||
@@ -1157,6 +1157,51 @@
|
||||
#define PR_BYTES_PER_WORD_LOG2 3
|
||||
#define PR_BYTES_PER_DWORD_LOG2 3
|
||||
|
||||
+#elif defined(__arc__)
|
||||
+
|
||||
+#define IS_LITTLE_ENDIAN 1
|
||||
+#undef IS_BIG_ENDIAN
|
||||
+
|
||||
+#define PR_BYTES_PER_BYTE 1
|
||||
+#define PR_BYTES_PER_SHORT 2
|
||||
+#define PR_BYTES_PER_INT 4
|
||||
+#define PR_BYTES_PER_INT64 8
|
||||
+#define PR_BYTES_PER_LONG 4
|
||||
+#define PR_BYTES_PER_FLOAT 4
|
||||
+#define PR_BYTES_PER_DOUBLE 8
|
||||
+#define PR_BYTES_PER_WORD 4
|
||||
+#define PR_BYTES_PER_DWORD 8
|
||||
+
|
||||
+#define PR_BITS_PER_BYTE 8
|
||||
+#define PR_BITS_PER_SHORT 16
|
||||
+#define PR_BITS_PER_INT 32
|
||||
+#define PR_BITS_PER_INT64 64
|
||||
+#define PR_BITS_PER_LONG 32
|
||||
+#define PR_BITS_PER_FLOAT 32
|
||||
+#define PR_BITS_PER_DOUBLE 64
|
||||
+#define PR_BITS_PER_WORD 32
|
||||
+
|
||||
+#define PR_BITS_PER_BYTE_LOG2 3
|
||||
+#define PR_BITS_PER_SHORT_LOG2 4
|
||||
+#define PR_BITS_PER_INT_LOG2 5
|
||||
+#define PR_BITS_PER_INT64_LOG2 6
|
||||
+#define PR_BITS_PER_LONG_LOG2 5
|
||||
+#define PR_BITS_PER_FLOAT_LOG2 5
|
||||
+#define PR_BITS_PER_DOUBLE_LOG2 6
|
||||
+#define PR_BITS_PER_WORD_LOG2 5
|
||||
+
|
||||
+#define PR_ALIGN_OF_SHORT 2
|
||||
+#define PR_ALIGN_OF_INT 4
|
||||
+#define PR_ALIGN_OF_LONG 4
|
||||
+#define PR_ALIGN_OF_INT64 4
|
||||
+#define PR_ALIGN_OF_FLOAT 4
|
||||
+#define PR_ALIGN_OF_DOUBLE 4
|
||||
+#define PR_ALIGN_OF_POINTER 4
|
||||
+#define PR_ALIGN_OF_WORD 4
|
||||
+
|
||||
+#define PR_BYTES_PER_WORD_LOG2 2
|
||||
+#define PR_BYTES_PER_DWORD_LOG2 3
|
||||
+
|
||||
#else
|
||||
|
||||
#error "Unknown CPU architecture"
|
||||
diff --git a/pr/include/md/_linux.h b/pr/include/md/_linux.h
|
||||
index 8e04fad479a1..628b1217e9c8 100644
|
||||
--- a/nspr/pr/include/md/_linux.h
|
||||
+++ b/nspr/pr/include/md/_linux.h
|
||||
@@ -63,6 +63,8 @@
|
||||
#define _PR_SI_ARCHITECTURE "riscv32"
|
||||
#elif defined(__riscv) && (__riscv_xlen == 64)
|
||||
#define _PR_SI_ARCHITECTURE "riscv64"
|
||||
+#elif defined(__arc__)
|
||||
+#define _PR_SI_ARCHITECTURE "arc"
|
||||
#else
|
||||
#error "Unknown CPU architecture"
|
||||
#endif
|
||||
--
|
||||
2.17.1
|
||||
|
Loading…
Reference in a new issue