xinetd: socket bind: Invalid argument (errno = 22) when using USERID on ipv6
Use right size of addresses in bind() call. Also use getpeername addresses when connecting to ident service to prevent address family mismatch between socket(), bind() and connect() calls. --- Christian Schoenebeck via github pull request #205: Reported for a long time in the web. Still exists in the current sources. Already reported and offert on TRAC Ticket #15821. You can find a lot of entries on "Google" about the reported problem. I got the same error on my WNDR3800 and von VirtualBox X86. I copied the patch to my local trunk build system and recompiled. The problem was fixed. Signed-off-by: Christian Schoenebeck <christian.schoenebeck@gmail.com> Signed-off-by: Jonathan McCrohan <jmccrohan@gmail.com>
This commit is contained in:
parent
61a1fdeb4a
commit
8eb8659e41
2 changed files with 43 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=xinetd
|
||||
PKG_VERSION:=2.3.15
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.xinetd.org
|
||||
|
|
42
net/xinetd/patches/004-ident-bind.patch
Normal file
42
net/xinetd/patches/004-ident-bind.patch
Normal file
|
@ -0,0 +1,42 @@
|
|||
xinetd: socket bind: Invalid argument (errno = 22) when using USERID on ipv6
|
||||
|
||||
Use right size of addresses in bind() call. Also use getpeername addresses when
|
||||
connecting to ident service to prevent address family mismatch between socket(),
|
||||
bind() and connect() calls.
|
||||
|
||||
Author: Jan Safranek <jsafrane@redhat.com>
|
||||
Reviewed-By: Adam Tkac <atkac@redhat.com>
|
||||
|
||||
#diff -up xinetd-2.3.14/xinetd/ident.c.orig xinetd-2.3.14/xinetd/ident.c
|
||||
--- a/xinetd/ident.c
|
||||
+++ b/xinetd/ident.c
|
||||
@@ -97,7 +98,13 @@ idresult_e log_remote_user( const struct
|
||||
}
|
||||
|
||||
CLEAR( sin_contact );
|
||||
- sin_remote = *CONN_XADDRESS( SERVER_CONNECTION( serp ) ) ;
|
||||
+
|
||||
+ sin_len = sizeof( sin_remote );
|
||||
+ if ( getpeername( SERVER_FD( serp ), &sin_remote.sa, &sin_len ) == -1 )
|
||||
+ {
|
||||
+ msg( LOG_ERR, func, "(%d) getpeername: %m", getpid() ) ;
|
||||
+ return( IDR_ERROR ) ;
|
||||
+ }
|
||||
sin_contact = sin_remote;
|
||||
memcpy( &sin_bind, &sin_local, sizeof(sin_bind) ) ;
|
||||
local_port = 0;
|
||||
@@ -121,7 +128,13 @@ idresult_e log_remote_user( const struct
|
||||
msg( LOG_ERR, func, "socket creation: %m" ) ;
|
||||
return( IDR_ERROR ) ;
|
||||
}
|
||||
- if ( bind(sd, &sin_bind.sa, sizeof(sin_bind.sa)) == -1 )
|
||||
+
|
||||
+ if ( sin_bind.sa.sa_family == AF_INET )
|
||||
+ sin_len = sizeof( sin_bind.sa_in ) ;
|
||||
+ else
|
||||
+ sin_len = sizeof( sin_bind.sa_in6 ) ;
|
||||
+
|
||||
+ if ( bind(sd, &sin_bind.sa, sin_len) == -1 )
|
||||
{
|
||||
msg( LOG_ERR, func, "socket bind: %m" ) ;
|
||||
(void) Sclose( sd ) ;
|
Loading…
Reference in a new issue