lpc2list: remove deprecated functions
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
d8d06cfca2
commit
8d927653d7
3 changed files with 24 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=lpc21isp
|
||||
PKG_VERSION:=197
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=4
|
||||
PKG_LICENSE:=LGPL-3.0-or-later
|
||||
PKG_LICENSE_FILES:=README gpl.txt lgpl-3.0.txt
|
||||
|
||||
|
|
11
devel/lpc21isp/patches/110-bzero.patch
Normal file
11
devel/lpc21isp/patches/110-bzero.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/lpc21isp.c
|
||||
+++ b/lpc21isp.c
|
||||
@@ -533,7 +533,7 @@ static void OpenSerialPort(ISP_ENVIRONMENT *IspEnvironment)
|
||||
|
||||
tcgetattr(IspEnvironment->fdCom, &IspEnvironment->oldtio); /* save current port settings */
|
||||
|
||||
- bzero(&IspEnvironment->newtio, sizeof(IspEnvironment->newtio));
|
||||
+ memset(&IspEnvironment->newtio, 0, sizeof(IspEnvironment->newtio));
|
||||
IspEnvironment->newtio.c_cflag = CS8 | CLOCAL | CREAD;
|
||||
|
||||
#if defined(__FreeBSD__) || defined(__OpenBSD__)
|
12
devel/lpc21isp/patches/120-nanosleep.patch
Normal file
12
devel/lpc21isp/patches/120-nanosleep.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- a/lpc21isp.c
|
||||
+++ b/lpc21isp.c
|
||||
@@ -1130,7 +1130,8 @@ void ClearSerialPortBuffers(ISP_ENVIRONMENT *IspEnvironment)
|
||||
*/
|
||||
void Sleep(unsigned long MilliSeconds)
|
||||
{
|
||||
- usleep(MilliSeconds*1000); //convert to microseconds
|
||||
+ struct timespec m = { MilliSeconds / 1000 , (MilliSeconds % 1000 ) * 1000 * 1000};
|
||||
+ nanosleep(&m, &m); //convert to nanoseconds
|
||||
}
|
||||
#endif // defined COMPILE_FOR_LINUX
|
||||
|
Loading…
Reference in a new issue