python-incremental: Update to 22.10.0, redo patch, add host build
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
This commit is contained in:
parent
59b7a81964
commit
8d81b67327
2 changed files with 21 additions and 15 deletions
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2018 OpenWrt.org
|
||||
# Copyright (C) 2018, 2021, 2023 Jeffery To
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -8,11 +8,11 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=python-incremental
|
||||
PKG_VERSION:=21.3.0
|
||||
PKG_VERSION:=22.10.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PYPI_NAME:=incremental
|
||||
PKG_HASH:=02f5de5aff48f6b9f665d99d48bfc7ec03b6e3943210de7cfc88856d755d6f57
|
||||
PKG_HASH:=912feeb5e0f7e0188e6f42241d2f450002e11bbc0937c65865045854c24c0bd0
|
||||
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
@ -20,7 +20,9 @@ PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
|
|||
|
||||
include ../pypi.mk
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
include ../python3-package.mk
|
||||
include ../python3-host-build.mk
|
||||
|
||||
define Package/python3-incremental
|
||||
SECTION:=lang
|
||||
|
@ -28,7 +30,7 @@ define Package/python3-incremental
|
|||
SUBMENU:=Python
|
||||
TITLE:=Versions your Python projects
|
||||
URL:=https://github.com/twisted/incremental
|
||||
DEPENDS:=+python3-light
|
||||
DEPENDS:=+python3-light +python3-distutils +python3-pkg-resources
|
||||
endef
|
||||
|
||||
define Package/python3-incremental/description
|
||||
|
@ -38,3 +40,4 @@ endef
|
|||
$(eval $(call Py3Package,python3-incremental))
|
||||
$(eval $(call BuildPackage,python3-incremental))
|
||||
$(eval $(call BuildPackage,python3-incremental-src))
|
||||
$(eval $(call HostBuild))
|
||||
|
|
|
@ -1,11 +1,14 @@
|
|||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -31,7 +31,7 @@ setup(
|
||||
"Programming Language :: Python :: 3.5",
|
||||
"Programming Language :: Python :: 3.6",
|
||||
],
|
||||
- packages=find_packages("src", exclude=("exampleproj",)),
|
||||
+ packages=find_packages("src", exclude=("exampleproj", "*.tests", "*.tests.*")),
|
||||
package_dir={"": "src"},
|
||||
extras_require={"scripts": ["click>=6.0", "twisted>=16.4.0"]},
|
||||
license="MIT",
|
||||
--- a/setup.cfg
|
||||
+++ b/setup.cfg
|
||||
@@ -30,7 +30,10 @@ zip_safe = False
|
||||
|
||||
[options.packages.find]
|
||||
where = src
|
||||
-exclude = exampleproj
|
||||
+exclude =
|
||||
+ exampleproj
|
||||
+ *.tests
|
||||
+ *.tests.*
|
||||
|
||||
[options.package_data]
|
||||
incremental = py.typed
|
||||
|
|
Loading…
Reference in a new issue