zstd: update to 1.4.5
Switch to zst archives for smaller size. Removed patches in favor of a better solution for uClibc-ng. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
2b9f88a4bf
commit
8c23fef9da
3 changed files with 7 additions and 50 deletions
|
@ -1,12 +1,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=zstd
|
PKG_NAME:=zstd
|
||||||
PKG_VERSION:=1.4.4
|
PKG_VERSION:=1.4.5
|
||||||
PKG_RELEASE:=3
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.zst
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/facebook/zstd/tar.gz/v$(PKG_VERSION)?
|
PKG_SOURCE_URL:=https://github.com/facebook/zstd/releases/download/v$(PKG_VERSION)
|
||||||
PKG_HASH:=a364f5162c7d1a455cc915e8e3cf5f4bd8b75d09bc0f53965b0c9ca1383c52c8
|
PKG_HASH:=2c2366874bc449ff539614266d8c0d6ecdb4baf30bb65609c239ab4ed23c03c7
|
||||||
|
|
||||||
PKG_MAINTAINER:=
|
PKG_MAINTAINER:=
|
||||||
PKG_LICENSE:=GPL-2.0-or-later
|
PKG_LICENSE:=GPL-2.0-or-later
|
||||||
|
@ -64,6 +64,8 @@ ifeq ($(CONFIG_ZSTD_OPTIMIZE_O3),y)
|
||||||
TARGET_CFLAGS:= $(filter-out -O%,$(TARGET_CFLAGS)) -O3
|
TARGET_CFLAGS:= $(filter-out -O%,$(TARGET_CFLAGS)) -O3
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
TARGET_CFLAGS += $(if $(CONFIG_USE_UCLIBC),-D_BSD_SOURCE)
|
||||||
|
|
||||||
MESON_ARGS += \
|
MESON_ARGS += \
|
||||||
-Dlegacy_level=1 \
|
-Dlegacy_level=1 \
|
||||||
-Ddebug_level=0 \
|
-Ddebug_level=0 \
|
||||||
|
|
|
@ -1,23 +0,0 @@
|
||||||
From f62cf1fff5dabcfaaa8c85638723bc19842f52f4 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Sergey Dryabzhinsky <sergey.dryabzhinsky+github@gmail.com>
|
|
||||||
Date: Tue, 19 Nov 2019 23:15:28 +0300
|
|
||||||
Subject: [PATCH] Fix typo in util.c
|
|
||||||
|
|
||||||
There must be mtim*e*
|
|
||||||
---
|
|
||||||
programs/util.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/programs/util.c b/programs/util.c
|
|
||||||
index 5d15450d2..d3ffc1133 100644
|
|
||||||
--- a/programs/util.c
|
|
||||||
+++ b/programs/util.c
|
|
||||||
@@ -73,7 +73,7 @@ int UTIL_setFileStat(const char *filename, stat_t *statbuf)
|
|
||||||
{
|
|
||||||
/* (atime, mtime) */
|
|
||||||
struct timespec timebuf[2] = { {0, UTIME_NOW} };
|
|
||||||
- timebuf[1] = statbuf->st_mtim;
|
|
||||||
+ timebuf[1] = statbuf->st_mtime;
|
|
||||||
res += utimensat(AT_FDCWD, filename, timebuf, 0);
|
|
||||||
}
|
|
||||||
#endif
|
|
|
@ -1,22 +0,0 @@
|
||||||
From 612a06eb3ef7f42739ace99fbca6ad63b788d46c Mon Sep 17 00:00:00 2001
|
|
||||||
From: Sergey Dryabzhinsky <sergey.dryabzhinsky+github@gmail.com>
|
|
||||||
Date: Tue, 19 Nov 2019 23:24:00 +0300
|
|
||||||
Subject: [PATCH] Update util.c
|
|
||||||
|
|
||||||
---
|
|
||||||
programs/util.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/programs/util.c b/programs/util.c
|
|
||||||
index d3ffc1133..aa75ca6d4 100644
|
|
||||||
--- a/programs/util.c
|
|
||||||
+++ b/programs/util.c
|
|
||||||
@@ -73,7 +73,7 @@ int UTIL_setFileStat(const char *filename, stat_t *statbuf)
|
|
||||||
{
|
|
||||||
/* (atime, mtime) */
|
|
||||||
struct timespec timebuf[2] = { {0, UTIME_NOW} };
|
|
||||||
- timebuf[1] = statbuf->st_mtime;
|
|
||||||
+ timebuf[1].tv_sec = statbuf->st_mtime;
|
|
||||||
res += utimensat(AT_FDCWD, filename, timebuf, 0);
|
|
||||||
}
|
|
||||||
#endif
|
|
Loading…
Reference in a new issue