snort3: update to 3.1.47.0-1
Build system: x86_64 Build-tested: bcm2711/RPi4B Run-tested: bcm2711/RPi4B Signed-off-by: John Audia <therealgraysky@proton.me>
This commit is contained in:
parent
ae572f4934
commit
8bd96675b2
2 changed files with 6 additions and 24 deletions
|
@ -6,12 +6,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=snort3
|
||||
PKG_VERSION:=3.1.29.0
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
PKG_VERSION:=3.1.47.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/snort3/snort3/archive/refs/tags/
|
||||
PKG_HASH:=becec36b57af3d65ae8289b73cd6d56bf8bde774539c74b35b0ec2262a587281
|
||||
PKG_HASH:=7565411db11b453a98f8bd88eeef0fa9f2e85416a8f595e710aa19c430228b8c
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||
PKG_LICENSE:=GPL-2.0-only
|
||||
|
@ -94,6 +94,9 @@ define Package/snort3/install
|
|||
$(INSTALL_CONF) \
|
||||
$(PKG_INSTALL_DIR)/usr/etc/snort/*.lua \
|
||||
$(1)/etc/snort
|
||||
$(INSTALL_CONF) \
|
||||
$(PKG_INSTALL_DIR)/usr/etc/snort/file_magic.rules \
|
||||
$(1)/etc/snort
|
||||
|
||||
$(INSTALL_DIR) $(1)/etc/init.d
|
||||
$(INSTALL_BIN) \
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
--- a/src/network_inspectors/appid/appid_inspector.cc
|
||||
+++ b/src/network_inspectors/appid/appid_inspector.cc
|
||||
@@ -68,7 +68,6 @@ static THREAD_LOCAL PacketTracer::Tracer
|
||||
// should probably be done outside of appid
|
||||
static void openssl_cleanup()
|
||||
{
|
||||
- CRYPTO_cleanup_all_ex_data();
|
||||
}
|
||||
|
||||
static void add_appid_to_packet_trace(Flow& flow, const OdpContext& odp_context)
|
||||
--- a/src/utils/util.cc
|
||||
+++ b/src/utils/util.cc
|
||||
@@ -111,7 +111,7 @@ int DisplayBanner()
|
||||
LogMessage(" Copyright (C) 1998-2013 Sourcefire, Inc., et al.\n");
|
||||
LogMessage(" Using DAQ version %s\n", daq_version_string());
|
||||
LogMessage(" Using LuaJIT version %s\n", ljv);
|
||||
- LogMessage(" Using %s\n", SSLeay_version(SSLEAY_VERSION));
|
||||
+ LogMessage(" Using %s\n", OpenSSL_version(SSLEAY_VERSION));
|
||||
LogMessage(" Using %s\n", pcap_lib_version());
|
||||
LogMessage(" Using PCRE version %s\n", pcre_version());
|
||||
LogMessage(" Using ZLIB version %s\n", zlib_version);
|
Loading…
Reference in a new issue