keepalived: update to version 2.0.10
Fixes CVE-2018-19046 Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
This commit is contained in:
parent
c7315a6acd
commit
8b6020db7f
2 changed files with 5 additions and 29 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=keepalived
|
||||
PKG_VERSION:=2.0.7
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=2.0.10
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.keepalived.org/software
|
||||
PKG_HASH:=bce45d6d5cf3620bfd88472ec839a75b5a14a54fda12d09e890670244873b8ab
|
||||
PKG_HASH:=40e0e55afed9ca313d621a9c5878579696fafb5504dab521aadaf20ba6e7f597
|
||||
|
||||
PKG_CPE_ID:=cpe:/a:keepalived:keepalived
|
||||
PKG_LICENSE:=GPL-2.0+
|
||||
|
@ -58,7 +58,8 @@ CONFIGURE_ARGS+= \
|
|||
--disable-libnl \
|
||||
--enable-sha1 \
|
||||
--disable-snmp \
|
||||
--with-kernel-dir="$(LINUX_DIR)/$(LINUX_UAPI_DIR)"
|
||||
--with-kernel-dir="$(LINUX_DIR)/$(LINUX_UAPI_DIR)" \
|
||||
--with-init=SYSV
|
||||
|
||||
MAKE_FLAGS += \
|
||||
STRIP="/bin/true" \
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
From 6c7a281473083f7ac47b426b2127a8c8e76caca5 Mon Sep 17 00:00:00 2001
|
||||
From: Quentin Armitage <quentin@armitage.org.uk>
|
||||
Date: Sat, 25 Aug 2018 11:36:11 +0100
|
||||
Subject: [PATCH] Include stdbool.h in process.c
|
||||
|
||||
Signed-off-by: Quentin Armitage <quentin@armitage.org.uk>
|
||||
---
|
||||
keepalived/core/process.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/keepalived/core/process.c b/keepalived/core/process.c
|
||||
index f11c32a3..22bcf254 100644
|
||||
--- a/keepalived/core/process.c
|
||||
+++ b/keepalived/core/process.c
|
||||
@@ -30,6 +30,7 @@
|
||||
#ifdef _HAVE_SCHED_RT_
|
||||
#include <sched.h>
|
||||
#endif
|
||||
+#include <stdbool.h>
|
||||
|
||||
#include "process.h"
|
||||
#include "logger.h"
|
||||
--
|
||||
2.11.0
|
||||
|
Loading…
Reference in a new issue