Merge pull request #7455 from neheb/nail
nail: Remove GSSAPI dependency
This commit is contained in:
commit
8a89b570c6
2 changed files with 53 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=nail
|
||||
PKG_VERSION:=12.5
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=4
|
||||
PKG_LICENSE:=BSD-2-Clause
|
||||
|
||||
PKG_SOURCE:=heirloom-mailx_$(PKG_VERSION).orig.tar.gz
|
||||
|
|
52
mail/nail/patches/010-remove-gssapi.patch
Normal file
52
mail/nail/patches/010-remove-gssapi.patch
Normal file
|
@ -0,0 +1,52 @@
|
|||
diff --git a/makeconfig b/makeconfig
|
||||
index 0ab36b8..ee1e3a1 100644
|
||||
--- a/makeconfig
|
||||
+++ b/makeconfig
|
||||
@@ -413,47 +413,6 @@ int main(void)
|
||||
!
|
||||
fi
|
||||
|
||||
-cat >$tmp2.c <<\!
|
||||
-#include <gssapi/gssapi.h>
|
||||
-
|
||||
-int main(void)
|
||||
-{
|
||||
- gss_import_name(0, 0, GSS_C_NT_HOSTBASED_SERVICE, 0);
|
||||
- gss_init_sec_context(0,0,0,0,0,0,0,0,0,0,0,0,0);
|
||||
- return 0;
|
||||
-}
|
||||
-!
|
||||
-
|
||||
-<$tmp2.c link_check gssapi 'for GSSAPI in libgss' \
|
||||
- '#define USE_GSSAPI' '-lgss' ||
|
||||
- <$tmp2.c link_check gssapi 'for GSSAPI in libgssapi_krb5' \
|
||||
- '#define USE_GSSAPI' '-lgssapi_krb5' ||
|
||||
- link_check gssapi 'for GSSAPI in libgssapi_krb5, old-style' \
|
||||
- '#define USE_GSSAPI
|
||||
-#define GSSAPI_OLD_STYLE' '-lgssapi_krb5' <<\! || \
|
||||
- link_check gssapi 'for GSSAPI in libgssapi' \
|
||||
- '#define USE_GSSAPI
|
||||
-#define GSSAPI_REG_INCLUDE' '-lgssapi' <<\%
|
||||
-#include <gssapi/gssapi.h>
|
||||
-#include <gssapi/gssapi_generic.h>
|
||||
-
|
||||
-int main(void)
|
||||
-{
|
||||
- gss_import_name(0, 0, gss_nt_service_name, 0);
|
||||
- gss_init_sec_context(0,0,0,0,0,0,0,0,0,0,0,0,0);
|
||||
- return 0;
|
||||
-}
|
||||
-!
|
||||
-#include <gssapi.h>
|
||||
-
|
||||
-int main(void)
|
||||
-{
|
||||
- gss_import_name(0, 0, GSS_C_NT_HOSTBASED_SERVICE, 0);
|
||||
- gss_init_sec_context(0,0,0,0,0,0,0,0,0,0,0,0,0);
|
||||
- return 0;
|
||||
-}
|
||||
-%
|
||||
-
|
||||
cat >$tmp2.c <<\!
|
||||
#include "config.h"
|
||||
#ifdef HAVE_NL_LANGINFO
|
Loading…
Reference in a new issue