librsocket-cpp: Update to 2019-09-22

Added URLs.

Added needed Boost patch.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry-picked from 164e706f9d)
This commit is contained in:
Rosen Penev 2019-09-13 14:42:39 -07:00
parent 95b7c86794
commit 8a5cb085b6
No known key found for this signature in database
GPG key ID: 36D31CFA845F0E3B
3 changed files with 28 additions and 25 deletions

View file

@ -1,13 +1,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=librsocket-cpp
PKG_SOURCE_DATE:=2019-06-11
PKG_SOURCE_VERSION:=741f817fd519e0610cddb5783aae812355e19435
PKG_SOURCE_DATE:=2019-09-22
PKG_SOURCE_VERSION:=b268907312af589828634c143b9f35b58cd6cfea
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_DATE).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/rsocket/rsocket-cpp/tar.gz/$(PKG_SOURCE_VERSION)?
PKG_HASH:=56886deba0f3594b4a430b1f515c90a138800b8e387440e6b8bf728d660f457a
PKG_HASH:=7ab4655d3d8148ce689f74a116ae7393d9e802f91d0dfd697ffd8daeff800e61
PKG_BUILD_DIR:=$(BUILD_DIR)/rsocket-cpp-$(PKG_SOURCE_VERSION)
PKG_MAINTAINER:=Amol Bhave <ambhave@fb.com>
@ -22,42 +22,34 @@ include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
define Package/librsocket-cpp
SECTION:=libs
CATEGORY:=Libraries
TITLE:=C++ implementation of RSocket
DEPENDS:=+libyarpl
SECTION:=libs
CATEGORY:=Libraries
TITLE:=C++ implementation of RSocket
URL:=https://rsocket.io/
DEPENDS:=+libyarpl
endef
define Package/libyarpl
SECTION:=libs
CATEGORY:=Libraries
TITLE:=yarpl: Yet Another Reactive Programming Library
DEPENDS:=+libfolly
SECTION:=libs
CATEGORY:=Libraries
TITLE:=yarpl: Yet Another Reactive Programming Library
URL:=https://rsocket.io/
DEPENDS:=+libfolly
endef
define Package/librsocket-cpp/description
C++ implementation of RSocket, and Application protocol providing Reactive Streams semantics
C++ implementation of RSocket, and Application protocol providing Reactive Streams semantics
endef
define Package/libyarpl/description
C++ implementation of reactive functional programming including both Observable and Flowable types.
C++ implementation of reactive functional programming including both Observable and Flowable types.
endef
CMAKE_OPTIONS += \
-DBUILD_BENCHMARKS=OFF \
-DBUILD_EXAMPLES=OFF \
-DBUILD_TESTS=OFF \
-DBUILD_SHARED_LIBS=ON
define Package/librsocket-cpp/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libReactiveSocket.so* $(1)/usr/lib/
endef
define Package/libyarpl/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libyarpl*.so* $(1)/usr/lib/
endef
-DCMAKE_POSITION_INDEPENDENT_CODE=ON
$(eval $(call BuildPackage,librsocket-cpp))
$(eval $(call BuildPackage,libyarpl))

View file

@ -1,4 +1,3 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,7 +67,6 @@

View file

@ -0,0 +1,12 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -194,6 +194,9 @@ find_package(Gflags REQUIRED)
# find glog::glog to satisfy the folly dep.
find_package(Glog REQUIRED)
+find_package(Boost REQUIRED COMPONENTS system thread filesystem regex context
+ date_time program_options)
+
include_directories(SYSTEM ${OPENSSL_INCLUDE_DIR})
include_directories(SYSTEM ${GFLAGS_INCLUDE_DIR})