nano: update to 7.1
Update nano editor to version 7.1 * drop the backported upstream fix for 7.0 * drop AUTORELEASE * disable justify from 'plus'. Rarely needed with OpenWrt Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
This commit is contained in:
parent
6e8e2d571e
commit
89dc1b17e9
2 changed files with 4 additions and 22 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=nano
|
||||
PKG_VERSION:=7.0
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
PKG_VERSION:=7.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@GNU/nano
|
||||
PKG_HASH:=8dd6eac38b2b8786d82681f0e1afd84f6b75210d17391b6443c437e451552149
|
||||
PKG_HASH:=57ba751e9b7519f0f6ddee505202e387c75dde440c1f7aa1b9310cc381406836
|
||||
|
||||
PKG_LICENSE:=GPL-3.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
@ -90,7 +90,6 @@ else ifeq ($(BUILD_VARIANT),plus)
|
|||
# plus variant with some features included
|
||||
CONFIGURE_ARGS += \
|
||||
--enable-help \
|
||||
--enable-justify \
|
||||
--enable-linenumbers \
|
||||
--enable-multibuffer \
|
||||
--enable-nanorc \
|
||||
|
@ -100,6 +99,7 @@ else ifeq ($(BUILD_VARIANT),plus)
|
|||
--disable-comment \
|
||||
--disable-extra \
|
||||
--disable-histories \
|
||||
--disable-justify \
|
||||
--disable-libmagic \
|
||||
--disable-mouse \
|
||||
--disable-operatingdir \
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
--- a/src/nano.c
|
||||
+++ b/src/nano.c
|
||||
@@ -1395,11 +1395,14 @@ bool changes_something(const void *f)
|
||||
#ifndef NANO_TINY
|
||||
f == chop_previous_word || f == chop_next_word ||
|
||||
f == zap_text || f == cut_till_eof || f == do_execute ||
|
||||
- f == do_indent || f == do_unindent || f == do_comment ||
|
||||
+ f == do_indent || f == do_unindent ||
|
||||
#endif
|
||||
#ifdef ENABLE_JUSTIFY
|
||||
f == do_justify || f == do_full_justify ||
|
||||
#endif
|
||||
+#ifdef ENABLE_COMMENT
|
||||
+ f == do_comment ||
|
||||
+#endif
|
||||
#ifdef ENABLE_SPELLER
|
||||
f == do_spell ||
|
||||
#endif
|
Loading…
Reference in a new issue