Merge pull request #3703 from nxhack/icu-update-to-v58_2
icu: Bumped to v58.2
This commit is contained in:
commit
89d23ead80
3 changed files with 67 additions and 28 deletions
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2006-2010 OpenWrt.org
|
# Copyright (C) 2006-2016 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -8,17 +8,17 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=icu4c
|
PKG_NAME:=icu4c
|
||||||
PKG_VERSION:=55.1
|
PKG_VERSION:=58.2
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-55_1-src.tgz
|
PKG_SOURCE:=$(PKG_NAME)-58_2-src.tgz
|
||||||
PKG_SOURCE_URL:=http://download.icu-project.org/files/icu4c/55.1
|
PKG_SOURCE_URL:=http://download.icu-project.org/files/$(PKG_NAME)/$(PKG_VERSION)
|
||||||
PKG_MD5SUM:=e2d523df79d6cb7855c2fbe284f4db29
|
PKG_MD5SUM:=fac212b32b7ec7ab007a12dff1f3aea1
|
||||||
|
|
||||||
PKG_LICENSE:=ICU-1.8.1+
|
PKG_LICENSE:=ICU-1.8.1+
|
||||||
PKG_LICENSE_FILES:=license.html
|
PKG_LICENSE_FILES:=LICENSE
|
||||||
|
|
||||||
PKG_MAINTAINER:=Mirko Vogt <mirko@openwrt.org>
|
PKG_MAINTAINER:=Hirokazu MORIKAWA <morikw2@gmail.com>
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
@ -26,7 +26,6 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
|
||||||
PKG_BUILD_DEPENDS:=icu/host
|
PKG_BUILD_DEPENDS:=icu/host
|
||||||
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
include $(INCLUDE_DIR)/host-build.mk
|
include $(INCLUDE_DIR)/host-build.mk
|
||||||
|
|
||||||
|
@ -41,8 +40,10 @@ define Package/icu
|
||||||
DEPENDS:=+libstdcpp +libpthread
|
DEPENDS:=+libstdcpp +libpthread
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Configure
|
CONFIGURE_CMD:= ./runConfigureICU
|
||||||
$(call Build/Configure/Default, \
|
CONFIGURE_VARS:=
|
||||||
|
CONFIGURE_ARGS:= \
|
||||||
|
Linux/gcc \
|
||||||
--disable-debug \
|
--disable-debug \
|
||||||
--enable-release \
|
--enable-release \
|
||||||
--enable-shared \
|
--enable-shared \
|
||||||
|
@ -52,14 +53,26 @@ define Build/Configure
|
||||||
--disable-tracing \
|
--disable-tracing \
|
||||||
--disable-extras \
|
--disable-extras \
|
||||||
--enable-dyload \
|
--enable-dyload \
|
||||||
--enable-layout \
|
|
||||||
--enable-layoutex \
|
|
||||||
--disable-tools \
|
--disable-tools \
|
||||||
--disable-tests \
|
--disable-tests \
|
||||||
--disable-samples \
|
--disable-samples \
|
||||||
--with-cross-build="$(HOST_BUILD_DIR)" \
|
--with-cross-build="$(HOST_BUILD_DIR)" \
|
||||||
)
|
--prefix=/usr
|
||||||
endef
|
|
||||||
|
HOST_CONFIGURE_CMD:= ./runConfigureICU
|
||||||
|
HOST_CONFIGURE_VARS:=
|
||||||
|
HOST_CONFIGURE_ARGS:= \
|
||||||
|
Linux/gcc \
|
||||||
|
--disable-debug \
|
||||||
|
--enable-release \
|
||||||
|
--enable-shared \
|
||||||
|
--enable-static \
|
||||||
|
--enable-draft \
|
||||||
|
--enable-renaming \
|
||||||
|
--disable-tracing \
|
||||||
|
--disable-extras \
|
||||||
|
--enable-dyload \
|
||||||
|
--prefix=$(HOST_BUILD_PREFIX)
|
||||||
|
|
||||||
define Build/InstallDev
|
define Build/InstallDev
|
||||||
$(INSTALL_DIR) \
|
$(INSTALL_DIR) \
|
||||||
|
|
|
@ -6,7 +6,7 @@ index 9db6c52..6aa2273 100644
|
||||||
$(INSTALL_SCRIPT) $(top_srcdir)/install-sh $(DESTDIR)$(pkgdatadir)/install-sh
|
$(INSTALL_SCRIPT) $(top_srcdir)/install-sh $(DESTDIR)$(pkgdatadir)/install-sh
|
||||||
@$(MKINSTALLDIRS) $(DESTDIR)$(libdir)/pkgconfig
|
@$(MKINSTALLDIRS) $(DESTDIR)$(libdir)/pkgconfig
|
||||||
$(INSTALL_DATA) $(ALL_PKGCONFIG_FILES) $(DESTDIR)$(libdir)/pkgconfig/
|
$(INSTALL_DATA) $(ALL_PKGCONFIG_FILES) $(DESTDIR)$(libdir)/pkgconfig/
|
||||||
- $(INSTALL_DATA) $(top_srcdir)/../license.html $(DESTDIR)$(pkgdatadir)/license.html
|
- $(INSTALL_DATA) $(top_srcdir)/../LICENSE $(DESTDIR)$(pkgdatadir)/LICENSE
|
||||||
$(INSTALL_SCRIPT) $(top_builddir)/config/icu-config $(DESTDIR)$(bindir)/icu-config
|
$(INSTALL_SCRIPT) $(top_builddir)/config/icu-config $(DESTDIR)$(bindir)/icu-config
|
||||||
$(INSTALL_DATA) $(top_builddir)/config/Makefile.inc $(DESTDIR)$(pkglibdir)/Makefile.inc
|
$(INSTALL_DATA) $(top_builddir)/config/Makefile.inc $(DESTDIR)$(pkglibdir)/Makefile.inc
|
||||||
$(INSTALL_DATA) $(top_builddir)/config/pkgdata.inc $(DESTDIR)$(pkglibdir)/pkgdata.inc
|
$(INSTALL_DATA) $(top_builddir)/config/pkgdata.inc $(DESTDIR)$(pkglibdir)/pkgdata.inc
|
||||||
|
|
26
libs/icu/patches/001-disable-strtod_l.patch
Normal file
26
libs/icu/patches/001-disable-strtod_l.patch
Normal file
|
@ -0,0 +1,26 @@
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -893,8 +893,8 @@
|
||||||
|
AC_CHECK_FUNC(strtod_l)
|
||||||
|
if test x$ac_cv_func_strtod_l = xyes
|
||||||
|
then
|
||||||
|
- CONFIG_CPPFLAGS="${CONFIG_CPPFLAGS} -DU_HAVE_STRTOD_L=1"
|
||||||
|
- U_HAVE_STRTOD_L=1
|
||||||
|
+ CONFIG_CPPFLAGS="${CONFIG_CPPFLAGS} -DU_HAVE_STRTOD_L=0"
|
||||||
|
+ U_HAVE_STRTOD_L=0
|
||||||
|
else
|
||||||
|
CONFIG_CPPFLAGS="${CONFIG_CPPFLAGS} -DU_HAVE_STRTOD_L=0"
|
||||||
|
U_HAVE_STRTOD_L=0
|
||||||
|
--- a/configure
|
||||||
|
+++ b/configure
|
||||||
|
@@ -7053,8 +7053,8 @@
|
||||||
|
|
||||||
|
if test x$ac_cv_func_strtod_l = xyes
|
||||||
|
then
|
||||||
|
- CONFIG_CPPFLAGS="${CONFIG_CPPFLAGS} -DU_HAVE_STRTOD_L=1"
|
||||||
|
- U_HAVE_STRTOD_L=1
|
||||||
|
+ CONFIG_CPPFLAGS="${CONFIG_CPPFLAGS} -DU_HAVE_STRTOD_L=0"
|
||||||
|
+ U_HAVE_STRTOD_L=0
|
||||||
|
else
|
||||||
|
CONFIG_CPPFLAGS="${CONFIG_CPPFLAGS} -DU_HAVE_STRTOD_L=0"
|
||||||
|
U_HAVE_STRTOD_L=0
|
Loading…
Reference in a new issue