Merge pull request #11235 from neheb/rhgr
ttyd: fix compilation without deprecated OpenSSL APIs
This commit is contained in:
commit
897414cf56
2 changed files with 12 additions and 3 deletions
|
@ -9,18 +9,18 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=ttyd
|
||||
PKG_VERSION:=1.5.2
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=4
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/tsl0922/ttyd/tar.gz/$(PKG_VERSION)?
|
||||
PKG_HASH:=b5b62ec2ce08add0173e6d1dfdd879e55f02f9490043e89f389981a62e87d376
|
||||
|
||||
PKG_MAINTAINER:=Shuanglei Tao <tsl0922@gmail.com>
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
PKG_MAINTAINER:=Shuanglei Tao <tsl0922@gmail.com>
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_BUILD_DEPENDS:=vim/host
|
||||
CMAKE_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/cmake.mk
|
||||
|
|
9
utils/ttyd/patches/200-openssl.patch
Normal file
9
utils/ttyd/patches/200-openssl.patch
Normal file
|
@ -0,0 +1,9 @@
|
|||
--- a/src/http.c
|
||||
+++ b/src/http.c
|
||||
@@ -1,5 +1,6 @@
|
||||
#include <string.h>
|
||||
#include <libwebsockets.h>
|
||||
+#include <openssl/ssl.h>
|
||||
|
||||
#include "server.h"
|
||||
#include "html.h"
|
Loading…
Reference in a new issue