Merge pull request #763 from morgenroth/Update-to-1.0
Upgrade IBR-DTN to version 1.0.0
This commit is contained in:
commit
881f9d0107
10 changed files with 21 additions and 239 deletions
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ibrcommon
|
||||
PKG_VERSION:=0.12.1
|
||||
PKG_VERSION:=1.0.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
|
||||
PKG_MD5SUM:=45681f48138bbbbd17384d25dc91454a
|
||||
PKG_MAINTAINER:=Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
|
||||
PKG_MD5SUM:=c40e5c8e2ada746c6da7ab2c359c1575
|
||||
PKG_MAINTAINER:=Johannes Morgenroth <jm@m-network.de>
|
||||
PKG_LICENSE:=Apache-2.0
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
|
|
@ -8,17 +8,17 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ibrdtn
|
||||
PKG_VERSION:=0.12.1
|
||||
PKG_VERSION:=1.0.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
|
||||
PKG_MD5SUM:=96428dd4af541ea0c52db80776976a65
|
||||
PKG_MAINTAINER:=Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
|
||||
PKG_MD5SUM:=c30f6164b717132b2c302d965d03c968
|
||||
PKG_MAINTAINER:=Johannes Morgenroth <jm@m-network.de>
|
||||
PKG_LICENSE:=Apache-2.0
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_FIXUP:=libtool autoreconf
|
||||
PKG_FIXUP:=libtool
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
|
|
@ -1,33 +0,0 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -159,12 +159,21 @@ AS_IF([test "x$enable_android" = "xyes"], [
|
||||
dnl -----------------------------------------------
|
||||
dnl check for glib support
|
||||
dnl -----------------------------------------------
|
||||
- PKG_CHECK_MODULES([GLIB], [glib-2.0], [
|
||||
- AC_SUBST(GLIB_CFLAGS)
|
||||
- AC_SUBST(GLIB_LIBS)
|
||||
- AC_DEFINE(HAVE_GLIB, [1], ["glib library is available"])
|
||||
- REQUIRES_LIBS="$REQUIRES_LIBS glib-2.0"
|
||||
- ], [
|
||||
+ AC_ARG_WITH([glib], [AS_HELP_STRING([--without-glib], [Disable linking to glib-2.0 library])], [with_glib=no], [with_glib=yes])
|
||||
+ AS_IF([test "x$with_glib" != xno],
|
||||
+ [
|
||||
+ PKG_CHECK_MODULES([GLIB], [glib-2.0], [
|
||||
+ AC_SUBST(GLIB_CFLAGS)
|
||||
+ AC_SUBST(GLIB_LIBS)
|
||||
+ AC_DEFINE(HAVE_GLIB, [1], ["glib library is available"])
|
||||
+ REQUIRES_LIBS="$REQUIRES_LIBS glib-2.0"
|
||||
+ ], [
|
||||
+ with_glib=no
|
||||
+ ])
|
||||
+ ], [])
|
||||
+
|
||||
+ AS_IF([test "x$with_glib" = xno],
|
||||
+ [
|
||||
AS_IF([test "x$has_endian_h" = "xyes"],[
|
||||
AC_MSG_NOTICE([use endian.h for endianess conversion])
|
||||
],[
|
||||
--
|
||||
1.9.1
|
||||
|
|
@ -8,17 +8,16 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ibrdtn-tools
|
||||
PKG_VERSION:=0.12.1
|
||||
PKG_VERSION:=1.0.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
|
||||
PKG_MD5SUM:=0ce0c6e754263919ad48661967c2f6fd
|
||||
PKG_MAINTAINER:=Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
|
||||
PKG_MD5SUM:=ec522079278bcdf4181e6a1d86f8d72f
|
||||
PKG_MAINTAINER:=Johannes Morgenroth <jm@m-network.de>
|
||||
PKG_LICENSE:=Apache-2.0
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
|
|
@ -1,89 +0,0 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -67,34 +67,57 @@ AC_TYPE_UINT8_T
|
||||
AC_FUNC_MALLOC
|
||||
AC_CHECK_FUNCS([memset])
|
||||
|
||||
-PKG_CHECK_MODULES(DAEMON, libdaemon >= 0.12, [
|
||||
- AC_SUBST(DAEMON_CFLAGS)
|
||||
- AC_SUBST(DAEMON_LIBS)
|
||||
- AC_DEFINE(HAVE_LIBDAEMON, [1], ["daemon library is available"])
|
||||
- AC_CHECK_LIB(daemon, daemon_reset_sigs, [
|
||||
- AC_DEFINE(HAVE_DAEMON_RESET_SIGS, [1], ["daemon library has daemon_reset_sigs() and daemon_unblock_sigs() functions"])
|
||||
- ])
|
||||
-], [
|
||||
- AC_MSG_WARN([daemon library not found, daemonize features disabled])
|
||||
-])
|
||||
+AC_ARG_WITH([libdaemon],
|
||||
+ AS_HELP_STRING([--without-libdaemon], [Build without daemonize support]),
|
||||
+ [
|
||||
+ AC_MSG_NOTICE([daemonize support disabled])
|
||||
+ ], [
|
||||
+ PKG_CHECK_MODULES(DAEMON, libdaemon >= 0.12, [
|
||||
+ AC_SUBST(DAEMON_CFLAGS)
|
||||
+ AC_SUBST(DAEMON_LIBS)
|
||||
+ AC_DEFINE(HAVE_LIBDAEMON, [1], ["daemon library is available"])
|
||||
+ AC_CHECK_LIB(daemon, daemon_reset_sigs, [
|
||||
+ AC_DEFINE(HAVE_DAEMON_RESET_SIGS, [1], ["daemon library has daemon_reset_sigs() and daemon_unblock_sigs() functions"])
|
||||
+ ])
|
||||
+ ], [
|
||||
+ AC_MSG_WARN([daemon library not found, daemonize features disabled])
|
||||
+ ])
|
||||
+ ]
|
||||
+)
|
||||
|
||||
-PKG_CHECK_MODULES(ARCHIVE, libarchive >= 3.0, [
|
||||
- AC_SUBST(ARCHIVE_CFLAGS)
|
||||
- AC_SUBST(ARCHIVE_LIBS)
|
||||
- AC_DEFINE(HAVE_LIBARCHIVE, [1], ["libarchive is available"])
|
||||
- has_libarchive="yes"
|
||||
-], [
|
||||
- AC_MSG_WARN([libarchive not found, dtninbox and dtnoutbox will not be compiled])
|
||||
-])
|
||||
+AC_ARG_WITH([libarchive],
|
||||
+ AS_HELP_STRING([--without-libarchive], [Build without archive support]),
|
||||
+ [
|
||||
+ has_libarchive="no"
|
||||
+ AC_MSG_NOTICE([archive support disabled, dtninbox and dtnoutbox will not be compiled])
|
||||
+ ], [
|
||||
+ PKG_CHECK_MODULES(ARCHIVE, libarchive >= 3.0, [
|
||||
+ AC_SUBST(ARCHIVE_CFLAGS)
|
||||
+ AC_SUBST(ARCHIVE_LIBS)
|
||||
+ AC_DEFINE(HAVE_LIBARCHIVE, [1], ["libarchive is available"])
|
||||
+ has_libarchive="yes"
|
||||
+ ], [
|
||||
+ AC_MSG_WARN([libarchive not found, dtninbox and dtnoutbox will not be compiled])
|
||||
+ ])
|
||||
+ ]
|
||||
+)
|
||||
|
||||
-PKG_CHECK_MODULES(OPENSSL, openssl, [
|
||||
- AC_SUBST(OPENSSL_CFLAGS)
|
||||
- AC_SUBST(OPENSSL_LIBS)
|
||||
- AC_DEFINE(HAVE_OPENSSL, [1], ["openssl available"])
|
||||
- has_openssl="yes"
|
||||
-], [
|
||||
- AC_MSG_WARN([openssl not found, dtninbox and dtnoutbox will not be compiled])
|
||||
-])
|
||||
+AC_ARG_WITH([openssl],
|
||||
+ AS_HELP_STRING([--without-openssl], [Build without openssl support]),
|
||||
+ [
|
||||
+ has_openssl="no"
|
||||
+ AC_MSG_NOTICE([openssl support disabled, dtninbox and dtnoutbox will not be compiled])
|
||||
+ ], [
|
||||
+ PKG_CHECK_MODULES(OPENSSL, openssl, [
|
||||
+ AC_SUBST(OPENSSL_CFLAGS)
|
||||
+ AC_SUBST(OPENSSL_LIBS)
|
||||
+ AC_DEFINE(HAVE_OPENSSL, [1], ["openssl available"])
|
||||
+ has_openssl="yes"
|
||||
+ ], [
|
||||
+ AC_MSG_WARN([openssl not found, dtninbox and dtnoutbox will not be compiled])
|
||||
+ ])
|
||||
+ ]
|
||||
+)
|
||||
|
||||
AC_ARG_WITH([tffs],
|
||||
AS_HELP_STRING([--with-tffs=PATH], [set the tffs path for fat-image support in dtnoutbox]), [
|
||||
--
|
||||
1.9.1
|
||||
|
|
@ -8,17 +8,16 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ibrdtnd
|
||||
PKG_VERSION:=0.12.1
|
||||
PKG_VERSION:=1.0.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
|
||||
PKG_MD5SUM:=8dad5ebbcfaa4c16ba151c9c289066c3
|
||||
PKG_MAINTAINER:=Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
|
||||
PKG_MD5SUM:=7fd48b2eec5058fa15f6977afd4e8dab
|
||||
PKG_MAINTAINER:=Johannes Morgenroth <jm@m-network.de>
|
||||
PKG_LICENSE:=Apache-2.0
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
@ -26,7 +25,7 @@ define Package/ibrdtnd
|
|||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+dtndht +ibrdtn +libsqlite3
|
||||
TITLE:=DTN Deamon
|
||||
TITLE:=DTN Daemon
|
||||
endef
|
||||
|
||||
define Package/ibrdtnd/conffiles
|
||||
|
@ -40,6 +39,7 @@ endef
|
|||
CONFIGURE_ARGS += \
|
||||
--with-tls \
|
||||
--with-sqlite \
|
||||
--with-dht \
|
||||
--without-wifip2p \
|
||||
--without-vmime \
|
||||
--disable-libdaemon
|
||||
|
|
|
@ -116,6 +116,7 @@ add_param $CONFFILE "ibrdtn.dht.allow_neighbour_announcement" "dht_allow_neighbo
|
|||
# iterate through all network interfaces
|
||||
iter=0
|
||||
netinterfaces=
|
||||
netinternet=
|
||||
while [ 1 == 1 ]; do
|
||||
$UCI -q get "ibrdtn.@network[$iter]" > /dev/null
|
||||
if [ $? == 0 ]; then
|
||||
|
@ -123,6 +124,9 @@ while [ 1 == 1 ]; do
|
|||
add_param $CONFFILE "ibrdtn.@network[$iter].type" "net_lan${iter}_type"
|
||||
add_param $CONFFILE "ibrdtn.@network[$iter].interface" "net_lan${iter}_interface"
|
||||
add_param $CONFFILE "ibrdtn.@network[$iter].port" "net_lan${iter}_port"
|
||||
if [ "$(uci -q get ibrdtn.@network[$iter].global)" == "yes" ]; then
|
||||
netinternet="${netinternet} $(uci -q get ibrdtn.@network[$iter].interface)"
|
||||
fi
|
||||
else
|
||||
break
|
||||
fi
|
||||
|
@ -132,6 +136,7 @@ done
|
|||
|
||||
# write list of network interfaces
|
||||
echo "net_interfaces =$netinterfaces" >> $CONFFILE
|
||||
echo "net_internet =${netinternet}" >> $CONFFILE
|
||||
|
||||
# iterate through all static routes
|
||||
iter=0
|
||||
|
|
|
@ -109,6 +109,7 @@ config 'network'
|
|||
option type tcp
|
||||
option interface eth0
|
||||
option port 4556
|
||||
option global yes
|
||||
|
||||
#config 'network'
|
||||
# option type tcp
|
||||
|
|
|
@ -1,75 +0,0 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -333,30 +333,46 @@ AS_IF([test "x$enable_android" = "xyes"], [
|
||||
dnl optional parameter: Wifi-P2P support
|
||||
dnl -----------------------------------------------
|
||||
|
||||
- PKG_CHECK_MODULES([WIFIP2P], wifip2p >= 0.1 , [
|
||||
- with_wifi_p2p="yes"
|
||||
- AC_SUBST(WIFIP2P_CFLAGS)
|
||||
- AC_SUBST(WIFIP2P_LIBS)
|
||||
- AC_DEFINE(WITH_WIFIP2P, [1], ["wifi-p2p support enabled"])
|
||||
- ], [
|
||||
- with_wifi_p2p="no"
|
||||
- AC_MSG_WARN([wifi-p2p library not found. wifi-p2p support is disabled.])
|
||||
- ])
|
||||
+ AC_ARG_WITH([wifip2p],
|
||||
+ AS_HELP_STRING([--without-wifip2p], [Build without wifip2p support]),
|
||||
+ [
|
||||
+ with_wifi_p2p="no"
|
||||
+ AC_MSG_NOTICE([WIFIP2P support disabled])
|
||||
+ ], [
|
||||
+ PKG_CHECK_MODULES([WIFIP2P], wifip2p >= 0.1 , [
|
||||
+ with_wifi_p2p="yes"
|
||||
+ AC_SUBST(WIFIP2P_CFLAGS)
|
||||
+ AC_SUBST(WIFIP2P_LIBS)
|
||||
+ AC_DEFINE(WITH_WIFIP2P, [1], ["wifi-p2p support enabled"])
|
||||
+ ], [
|
||||
+ with_wifi_p2p="no"
|
||||
+ AC_MSG_WARN([wifi-p2p library not found. wifi-p2p support is disabled.])
|
||||
+ ])
|
||||
+ ]
|
||||
+ )
|
||||
|
||||
- dnl -----------------------------------------------
|
||||
- dnl optional parameter: VMime support
|
||||
- dnl -----------------------------------------------
|
||||
-
|
||||
- PKG_CHECK_MODULES([VMIME], vmime >= 0.9.1 , [
|
||||
- with_vmime="yes"
|
||||
- AC_SUBST(VMIME_CFLAGS)
|
||||
- AC_SUBST(VMIME_LIBS)
|
||||
- AC_DEFINE(HAVE_VMIME, [1], ["Email Convergence Layer is available"])
|
||||
- AC_CHECK_HEADERS([vmime/utility/smartPtrInt.hpp])
|
||||
- ], [
|
||||
- with_vmime="no"
|
||||
- AC_MSG_WARN([VMime library not found. Email Convergence Layer is disabled.])
|
||||
- ])
|
||||
+ dnl -----------------------------------------------
|
||||
+ dnl optional parameter: VMime support
|
||||
+ dnl -----------------------------------------------
|
||||
+
|
||||
+ AC_ARG_WITH([vmime],
|
||||
+ AS_HELP_STRING([--without-vmime], [Build without vmime support]),
|
||||
+ [
|
||||
+ with_vmime="no"
|
||||
+ AC_MSG_NOTICE([VMIME support disabled])
|
||||
+ ], [
|
||||
+ PKG_CHECK_MODULES([VMIME], vmime >= 0.9.1 , [
|
||||
+ with_vmime="yes"
|
||||
+ AC_SUBST(VMIME_CFLAGS)
|
||||
+ AC_SUBST(VMIME_LIBS)
|
||||
+ AC_DEFINE(HAVE_VMIME, [1], ["Email Convergence Layer is available"])
|
||||
+ AC_CHECK_HEADERS([vmime/utility/smartPtrInt.hpp])
|
||||
+ ], [
|
||||
+ with_vmime="no"
|
||||
+ AC_MSG_WARN([VMime library not found. Email Convergence Layer is disabled.])
|
||||
+ ])
|
||||
+ ]
|
||||
+ )
|
||||
|
||||
dnl -----------------------------------------------
|
||||
dnl check for regex capabilities
|
||||
--
|
||||
1.9.1
|
||||
|
|
@ -1,26 +0,0 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -138,11 +138,17 @@ AS_IF([test "x$enable_android" = "xyes"], [
|
||||
# Checks for library functions.
|
||||
AC_CHECK_FUNCS([gethostname socket])
|
||||
|
||||
- # Check for presence of pdfLaTeX
|
||||
- AC_CHECK_PROG(PDFLATEX, pdflatex, pdflatex)
|
||||
- if test -z "$PDFLATEX"; then
|
||||
- AC_MSG_WARN([Unable to create PDF version of the documentation.])
|
||||
- fi
|
||||
+ AC_ARG_ENABLE([docs],
|
||||
+ AS_HELP_STRING([--enable-docs], [Build documentation using PDFLaTeX]),
|
||||
+ [
|
||||
+ # Check for presence of pdfLaTeX
|
||||
+ AC_CHECK_PROG(PDFLATEX, pdflatex, pdflatex)
|
||||
+ if test -z "$PDFLATEX"; then
|
||||
+ AC_MSG_WARN([Unable to create PDF version of the documentation.])
|
||||
+ fi
|
||||
+ ], [
|
||||
+ PDFLATEX="no"
|
||||
+ ])
|
||||
|
||||
AC_ARG_ENABLE([libdaemon],
|
||||
AS_HELP_STRING([--disable-libdaemon], [Build without libdaemon support]),
|
||||
--
|
Loading…
Reference in a new issue