diff --git a/net/adblock/Makefile b/net/adblock/Makefile
index 99da155f5..884659b3d 100644
--- a/net/adblock/Makefile
+++ b/net/adblock/Makefile
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=adblock
-PKG_VERSION:=1.4.1
+PKG_VERSION:=1.4.2
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-3.0+
 PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
@@ -23,7 +23,7 @@ endef
 
 define Package/$(PKG_NAME)/description
 Powerful adblock script to block ad/abuse domains.
-Currently the script supports 19 domain blacklist sites plus manual black- and whitelist overrides.
+Currently the script supports 20 domain blacklist sites plus manual black- and whitelist overrides.
 Please see https://github.com/openwrt/packages/blob/master/net/adblock/files/README.md for further information.
 
 endef
diff --git a/net/adblock/files/README.md b/net/adblock/files/README.md
index 4fe67bdeb..9bb849526 100644
--- a/net/adblock/files/README.md
+++ b/net/adblock/files/README.md
@@ -15,6 +15,8 @@ A lot of people already use adblocker plugins within their desktop browsers, but
     * => daily updates, approx. 4.500 entries
     * [feodotracker](https://feodotracker.abuse.ch)
     * => daily updates, approx. 0-10 entries
+    * [hphosts](https://hosts-file.net)
+    * => monthly updates, approx. 390.000 entries
     * [malwaredomains](http://malwaredomains.com)
     * => daily updates, approx. 16.000 entries
     * [malwaredomainlist](http://www.malwaredomainlist.com)
diff --git a/net/adblock/files/adblock-update.sh b/net/adblock/files/adblock-update.sh
index ea7f67810..9a9fb989f 100755
--- a/net/adblock/files/adblock-update.sh
+++ b/net/adblock/files/adblock-update.sh
@@ -10,8 +10,8 @@
 #
 adb_pid="${$}"
 adb_pidfile="/var/run/adblock.pid"
-adb_scriptver="1.4.1"
-adb_mincfgver="2.2"
+adb_scriptver="1.4.2"
+adb_mincfgver="2.3"
 adb_scriptdir="${0%/*}"
 if [ -r "${adb_pidfile}" ]
 then
diff --git a/net/adblock/files/adblock.conf b/net/adblock/files/adblock.conf
index bff60e148..5fdf224e1 100644
--- a/net/adblock/files/adblock.conf
+++ b/net/adblock/files/adblock.conf
@@ -3,7 +3,7 @@
 
 config adblock 'global'
 	option adb_enabled '1'
-	option adb_cfgver '2.2'
+	option adb_cfgver '2.3'
 	option adb_whitelist '/etc/adblock/adblock.whitelist'
 	option adb_whitelist_rset '\$1 ~/^([A-Za-z0-9_-]+\.){1,}[A-Za-z]+/{print tolower(\"^\"\$1\"\\\|[.]\"\$1)}'
 	option adb_forcedns '1'
@@ -42,6 +42,12 @@ config source 'feodo'
 	option adb_src_rset '\$1 ~/^([A-Za-z0-9_-]+\.){1,}[A-Za-z]+/{print tolower(\$1)}'
 	option adb_src_desc 'focus on feodo botnet domains, daily updates, approx. 0-10 entries'
 
+config source 'hphosts'
+	option enabled '0'
+	option adb_src 'https://hosts-file.net/download/hosts.txt'
+	option adb_src_rset '\$0 ~/^127\.0\.0\.1[ \t]+([A-Za-z0-9_-]+\.){1,}[A-Za-z]+/{print tolower(\$2)}'
+	option adb_src_desc 'broad blocklist against ad-, tracking- and other malicious hosts, monthly updates, approx. 390.000 entries'
+
 config source 'malware'
 	option enabled '0'
 	option adb_src 'https://mirror.cedia.org.ec/malwaredomains/justdomains'