flac: update to v1.3.1 (CVE-2014-8962, CVE-2014-9028)
This updates flac to the new upstream release v1.3.1 to fix two known CVEs. Additionally the commit changes the following: * Drop custom Build/Configure recipe in favor to CONFIGURE_ARGS * Refreshes patches and removes changes to *.in files since they're regenerated by autoreconf anyway * Remove now obsolete 020-libFLAC-remove-altivec-options.patch * Add an md5sum for the source archive * Passes --enable-static to configure to force producing a libflac.a Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
This commit is contained in:
parent
efe52d2fe5
commit
87d154e853
5 changed files with 32 additions and 155 deletions
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2006-2014 OpenWrt.org
|
# Copyright (C) 2006-2015 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=flac
|
PKG_NAME:=flac
|
||||||
PKG_VERSION:=1.2.1
|
PKG_VERSION:=1.3.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@SF/flac
|
PKG_SOURCE_URL:=@SF/flac
|
||||||
PKG_MD5SUM:=
|
PKG_MD5SUM:=b9922c9a0378c88d3e901b234f852698
|
||||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
@ -33,8 +33,7 @@ define Package/libflac
|
||||||
URL:=http://flac.sourceforge.net/
|
URL:=http://flac.sourceforge.net/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Configure
|
CONFIGURE_ARGS += \
|
||||||
$(call Build/Configure/Default, \
|
|
||||||
--disable-cpplibs \
|
--disable-cpplibs \
|
||||||
--disable-sse \
|
--disable-sse \
|
||||||
--disable-3dnow \
|
--disable-3dnow \
|
||||||
|
@ -45,8 +44,7 @@ define Build/Configure
|
||||||
--disable-ogg \
|
--disable-ogg \
|
||||||
--disable-oggtest \
|
--disable-oggtest \
|
||||||
--disable-debug \
|
--disable-debug \
|
||||||
)
|
--enable-static \
|
||||||
endef
|
|
||||||
|
|
||||||
TARGET_CFLAGS += $(FPIC)
|
TARGET_CFLAGS += $(FPIC)
|
||||||
|
|
||||||
|
|
|
@ -1,73 +1,25 @@
|
||||||
--- a/Makefile.am
|
--- a/Makefile.am
|
||||||
+++ b/Makefile.am
|
+++ b/Makefile.am
|
||||||
@@ -30,7 +30,7 @@
|
@@ -31,7 +31,7 @@
|
||||||
|
|
||||||
AUTOMAKE_OPTIONS = foreign 1.7
|
ACLOCAL_AMFLAGS = -I m4
|
||||||
|
|
||||||
-SUBDIRS = doc include m4 man src examples test build obj
|
-SUBDIRS = doc include m4 man src examples test build objs
|
||||||
+SUBDIRS = include m4 src build obj
|
+SUBDIRS = include m4 src build objs
|
||||||
|
|
||||||
DISTCLEANFILES = libtool-disable-static
|
|
||||||
|
|
||||||
--- a/Makefile.in
|
|
||||||
+++ b/Makefile.in
|
|
||||||
@@ -234,7 +234,7 @@ target_alias = @target_alias@
|
|
||||||
|
|
||||||
AUTOMAKE_OPTIONS = foreign 1.7
|
|
||||||
|
|
||||||
-SUBDIRS = doc include m4 man src examples test build obj
|
|
||||||
+SUBDIRS = include m4 src build obj
|
|
||||||
|
|
||||||
DISTCLEANFILES = libtool-disable-static
|
|
||||||
|
|
||||||
--- a/src/Makefile.am
|
|
||||||
+++ b/src/Makefile.am
|
|
||||||
@@ -30,12 +30,6 @@ SUBDIRS = \
|
|
||||||
metaflac \
|
|
||||||
monkeys_audio_utilities \
|
|
||||||
$(XMMS_DIRS) \
|
|
||||||
- plugin_winamp2 \
|
|
||||||
- test_grabbag \
|
|
||||||
- test_libs_common \
|
|
||||||
- test_libFLAC \
|
|
||||||
- test_seeking \
|
|
||||||
- test_streams \
|
|
||||||
$(CPPLIBS_DIRS)
|
|
||||||
|
|
||||||
EXTRA_DIST = \
|
EXTRA_DIST = \
|
||||||
--- a/src/Makefile.in
|
COPYING.FDL \
|
||||||
+++ b/src/Makefile.in
|
--- a/src/Makefile.am
|
||||||
@@ -221,7 +221,7 @@ target_alias = @target_alias@
|
+++ b/src/Makefile.am
|
||||||
|
@@ -30,11 +30,6 @@ SUBDIRS = \
|
||||||
@FLaC__HAS_XMMS_TRUE@XMMS_DIRS = plugin_common plugin_xmms
|
flac \
|
||||||
|
|
||||||
-@FLaC__WITH_CPPLIBS_TRUE@CPPLIBS_DIRS = libFLAC++ test_libFLAC++
|
|
||||||
+@FLaC__WITH_CPPLIBS_TRUE@CPPLIBS_DIRS = libFLAC++
|
|
||||||
|
|
||||||
SUBDIRS = \
|
|
||||||
libFLAC \
|
|
||||||
@@ -230,12 +230,6 @@ SUBDIRS = \
|
|
||||||
metaflac \
|
metaflac \
|
||||||
monkeys_audio_utilities \
|
|
||||||
$(XMMS_DIRS) \
|
$(XMMS_DIRS) \
|
||||||
- plugin_winamp2 \
|
|
||||||
- test_grabbag \
|
- test_grabbag \
|
||||||
- test_libs_common \
|
- test_libs_common \
|
||||||
- test_libFLAC \
|
- test_libFLAC \
|
||||||
- test_seeking \
|
- test_seeking \
|
||||||
- test_streams \
|
- test_streams \
|
||||||
|
utils \
|
||||||
$(CPPLIBS_DIRS)
|
$(CPPLIBS_DIRS)
|
||||||
|
|
||||||
|
|
||||||
@@ -256,9 +250,8 @@ RECURSIVE_TARGETS = info-recursive dvi-r
|
|
||||||
check-recursive installcheck-recursive
|
|
||||||
DIST_COMMON = $(srcdir)/Makefile.in Makefile.am
|
|
||||||
DIST_SUBDIRS = libFLAC share flac metaflac monkeys_audio_utilities \
|
|
||||||
- plugin_common plugin_xmms plugin_winamp2 test_grabbag \
|
|
||||||
- test_libs_common test_libFLAC test_seeking test_streams \
|
|
||||||
- libFLAC++ test_libFLAC++
|
|
||||||
+ plugin_common plugin_xmms plugin_winamp2 \
|
|
||||||
+ libFLAC++
|
|
||||||
all: all-recursive
|
|
||||||
|
|
||||||
.SUFFIXES:
|
|
||||||
|
|
|
@ -1,24 +1,13 @@
|
||||||
--- a/src/Makefile.am
|
--- a/src/Makefile.am
|
||||||
+++ b/src/Makefile.am
|
+++ b/src/Makefile.am
|
||||||
@@ -26,9 +26,6 @@ endif
|
@@ -27,10 +27,7 @@ endif
|
||||||
SUBDIRS = \
|
SUBDIRS = \
|
||||||
libFLAC \
|
|
||||||
share \
|
share \
|
||||||
|
libFLAC \
|
||||||
- flac \
|
- flac \
|
||||||
- metaflac \
|
- metaflac \
|
||||||
- monkeys_audio_utilities \
|
|
||||||
$(XMMS_DIRS) \
|
|
||||||
$(CPPLIBS_DIRS)
|
|
||||||
|
|
||||||
--- a/src/Makefile.in
|
|
||||||
+++ b/src/Makefile.in
|
|
||||||
@@ -226,9 +226,6 @@ target_alias = @target_alias@
|
|
||||||
SUBDIRS = \
|
|
||||||
libFLAC \
|
|
||||||
share \
|
|
||||||
- flac \
|
|
||||||
- metaflac \
|
|
||||||
- monkeys_audio_utilities \
|
|
||||||
$(XMMS_DIRS) \
|
$(XMMS_DIRS) \
|
||||||
|
- utils \
|
||||||
$(CPPLIBS_DIRS)
|
$(CPPLIBS_DIRS)
|
||||||
|
|
||||||
|
EXTRA_DIST = \
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
--- a/Makefile.am
|
--- a/Makefile.am
|
||||||
+++ b/Makefile.am
|
+++ b/Makefile.am
|
||||||
@@ -34,6 +34,8 @@ SUBDIRS = include m4 src build obj
|
@@ -33,6 +33,8 @@ ACLOCAL_AMFLAGS = -I m4
|
||||||
|
|
||||||
DISTCLEANFILES = libtool-disable-static
|
SUBDIRS = include m4 src build objs
|
||||||
|
|
||||||
+ACLOCAL_AMFLAGS = -I m4
|
+ACLOCAL_AMFLAGS = -I m4
|
||||||
+
|
+
|
||||||
|
|
|
@ -1,62 +0,0 @@
|
||||||
--- a/src/libFLAC/Makefile.in
|
|
||||||
+++ b/src/libFLAC/Makefile.in
|
|
||||||
@@ -66,6 +66,7 @@ NORMAL_UNINSTALL = :
|
|
||||||
PRE_UNINSTALL = :
|
|
||||||
POST_UNINSTALL = :
|
|
||||||
host_triplet = @host@
|
|
||||||
+@FLaC__CPU_PPC_TRUE@@FLaC__SYS_DARWIN_FALSE@@FLaC__USE_ALTIVEC_TRUE@am__append_1 = -maltivec -mabi=altivec
|
|
||||||
ACLOCAL = @ACLOCAL@
|
|
||||||
ACLOCAL_AMFLAGS = @ACLOCAL_AMFLAGS@
|
|
||||||
AMDEP_FALSE = @AMDEP_FALSE@
|
|
||||||
@@ -234,13 +235,21 @@ target_alias = @target_alias@
|
|
||||||
|
|
||||||
lib_LTLIBRARIES = libFLAC.la
|
|
||||||
@DEBUG_TRUE@DEBUGCFLAGS = -DFLAC__OVERFLOW_DETECT
|
|
||||||
+# Linux-gcc for PPC does not have -force_cpusubtype_ALL, it is Darwin-specific
|
|
||||||
+#@@@ PPC optimizations temporarily disabled
|
|
||||||
+@FLaC__CPU_PPC_TRUE@@FLaC__SYS_DARWIN_FALSE@CPUCFLAGS = \
|
|
||||||
+@FLaC__CPU_PPC_TRUE@@FLaC__SYS_DARWIN_FALSE@ $(am__append_1) \
|
|
||||||
+@FLaC__CPU_PPC_TRUE@@FLaC__SYS_DARWIN_FALSE@ -DFLAC__NO_ASM
|
|
||||||
+
|
|
||||||
+# FIXME: The following logic should be part of configure, not of Makefile.am
|
|
||||||
+
|
|
||||||
# The -force_cpusubtype_ALL is needed to insert a ppc64 instruction
|
|
||||||
# into cpu.c with an asm().
|
|
||||||
#@@@ PPC optimizations temporarily disabled
|
|
||||||
-@FLaC__CPU_PPC_TRUE@@FLaC__SYS_DARWIN_TRUE@CPUCFLAGS = -faltivec -force_cpusubtype_ALL -DFLAC__NO_ASM
|
|
||||||
-# Linux-gcc for PPC does not have -force_cpusubtype_ALL, it is Darwin-specific
|
|
||||||
-#@@@ PPC optimizations temporarily disabled
|
|
||||||
-@FLaC__CPU_PPC_TRUE@@FLaC__SYS_DARWIN_FALSE@CPUCFLAGS = -maltivec -mabi=altivec -DFLAC__NO_ASM
|
|
||||||
+@FLaC__CPU_PPC_TRUE@@FLaC__SYS_DARWIN_TRUE@CPUCFLAGS = -faltivec \
|
|
||||||
+@FLaC__CPU_PPC_TRUE@@FLaC__SYS_DARWIN_TRUE@ -force_cpusubtype_ALL \
|
|
||||||
+@FLaC__CPU_PPC_TRUE@@FLaC__SYS_DARWIN_TRUE@ -DFLAC__NO_ASM \
|
|
||||||
+@FLaC__CPU_PPC_TRUE@@FLaC__SYS_DARWIN_TRUE@ $(am__append_1)
|
|
||||||
|
|
||||||
AM_CFLAGS = $(DEBUGCFLAGS) $(CPUCFLAGS) @OGG_CFLAGS@
|
|
||||||
@FLaC__CPU_PPC_TRUE@@FLaC__NO_ASM_FALSE@ARCH_SUBDIRS = ppc
|
|
||||||
--- a/src/libFLAC/Makefile.am
|
|
||||||
+++ b/src/libFLAC/Makefile.am
|
|
||||||
@@ -32,6 +32,9 @@ lib_LTLIBRARIES = libFLAC.la
|
|
||||||
if DEBUG
|
|
||||||
DEBUGCFLAGS = -DFLAC__OVERFLOW_DETECT
|
|
||||||
endif
|
|
||||||
+
|
|
||||||
+# FIXME: The following logic should be part of configure, not of Makefile.am
|
|
||||||
+
|
|
||||||
if FLaC__CPU_PPC
|
|
||||||
# The -force_cpusubtype_ALL is needed to insert a ppc64 instruction
|
|
||||||
# into cpu.c with an asm().
|
|
||||||
@@ -40,8 +43,12 @@ if FLaC__SYS_DARWIN
|
|
||||||
CPUCFLAGS = -faltivec -force_cpusubtype_ALL -DFLAC__NO_ASM
|
|
||||||
else
|
|
||||||
# Linux-gcc for PPC does not have -force_cpusubtype_ALL, it is Darwin-specific
|
|
||||||
+CPUCFLAGS =
|
|
||||||
+if FLaC__USE_ALTIVEC
|
|
||||||
+CPUCFLAGS += -maltivec -mabi=altivec
|
|
||||||
+endif
|
|
||||||
#@@@ PPC optimizations temporarily disabled
|
|
||||||
-CPUCFLAGS = -maltivec -mabi=altivec -DFLAC__NO_ASM
|
|
||||||
+CPUCFLAGS += -DFLAC__NO_ASM
|
|
||||||
endif
|
|
||||||
endif
|
|
||||||
|
|
Loading…
Reference in a new issue