python-twisted: Update to 19.10.0, refresh patches

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
(cherry picked from c56770a570)
This commit is contained in:
Jeffery To 2019-11-18 04:33:26 +08:00
parent 1feef55c94
commit 87ccd3ddbd
3 changed files with 6 additions and 6 deletions

View file

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-twisted
PKG_VERSION:=19.7.0
PKG_VERSION:=19.10.0
PKG_RELEASE:=1
PKG_SOURCE:=Twisted-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/T/Twisted
PKG_HASH:=d5db93026568f60cacdc0615fcd21d46f694a6bfad0ef3ff53cde2b4bb85a39d
PKG_HASH:=7394ba7f272ae722a74f3d969dcf599bc4ef093bc392038748a490f1724a515d
PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-twisted-$(PKG_VERSION)
PKG_BUILD_DEPENDS:=libtirpc

View file

@ -1,6 +1,6 @@
--- a/src/twisted/python/_setup.py
+++ b/src/twisted/python/_setup.py
@@ -149,7 +149,6 @@ _CONSOLE_SCRIPTS = [
@@ -150,7 +150,6 @@ _CONSOLE_SCRIPTS = [
"conch = twisted.conch.scripts.conch:run",
"mailmail = twisted.mail.scripts.mailmail:run",
"pyhtmlizer = twisted.scripts.htmlizer:run",

View file

@ -1,6 +1,6 @@
--- a/src/twisted/python/_setup.py
+++ b/src/twisted/python/_setup.py
@@ -175,11 +175,6 @@ class ConditionalExtension(Extension, ob
@@ -176,11 +176,6 @@ class ConditionalExtension(Extension, ob
# The C extensions used for Twisted.
_EXTENSIONS = [
ConditionalExtension(
@ -12,7 +12,7 @@
"twisted.internet.iocpreactor.iocpsupport",
sources=[
"src/twisted/internet/iocpreactor/iocpsupport/iocpsupport.c",
@@ -284,12 +279,11 @@ def getSetupArgs(extensions=_EXTENSIONS,
@@ -285,12 +280,11 @@ def getSetupArgs(extensions=_EXTENSIONS,
"incremental >= 16.10.1",
"Automat >= 0.3.0",
"hyperlink >= 17.1.1",
@ -26,7 +26,7 @@
use_incremental=True,
setup_requires=["incremental >= 16.10.1"],
install_requires=requirements,
@@ -299,7 +293,7 @@ def getSetupArgs(extensions=_EXTENSIONS,
@@ -300,7 +294,7 @@ def getSetupArgs(extensions=_EXTENSIONS,
cmdclass=command_classes,
include_package_data=True,
exclude_package_data={