mariadb: bump to 10.2.22

From upstream release notes:

- Backport Information Schema CHECK_CONSTRAINTS Table.
- MDEV-17475: Maximum value of table_definition_cache is now 2097152.
- InnoDB ALTER TABLE fixes: MDEV-16499, MDEV-18186, MDEV-18237, MDEV-18222,
  MDEV-18256, MDEV-18016, MDEV-16849
- Mariabackup fixes: MDEV-18185, MDEV-18201, MDEV-18194
- Galera crash recovery fix: MDEV-15740
- Encryption fixes: MDEV-18129, MDEV-18183, MDEV-18279
- Fixes for the following security vulnerabilities:
  - CVE-2019-2510
  - CVE-2019-2537

OpenWrt notes:
- OpenSSL patch dropped as issue fixed upstream

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
This commit is contained in:
Sebastian Kemper 2019-02-11 21:49:20 +01:00
parent f4fda3f7f6
commit 874701cdab
3 changed files with 3 additions and 17 deletions

View file

@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mariadb
PKG_VERSION:=10.2.21
PKG_VERSION:=10.2.22
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@ -18,7 +18,7 @@ PKG_SOURCE_URL := \
https://ftp.yz.yamagata-u.ac.jp/pub/dbms/mariadb/$(PKG_NAME)-$(PKG_VERSION)/source \
https://downloads.mariadb.org/interstitial/$(PKG_NAME)-$(PKG_VERSION)/source
PKG_HASH:=637f0808b65ec06902897a2f885a60377828d019d35802402dca541f8113536c
PKG_HASH:=42f4c54c29b7c196bd105bbf4d2ea721f869b14cb7ba436c3566e6dd2760614c
PKG_MAINTAINER:=Sebastian Kemper <sebastian_ml@gmx.net>
PKG_LICENSE:=GPL-2.0 LGPL-2.1
PKG_LICENSE_FILES:=COPYING libmariadb/COPYING.LIB

View file

@ -1,6 +1,6 @@
--- a/scripts/mysql_install_db.sh
+++ b/scripts/mysql_install_db.sh
@@ -388,7 +388,7 @@ fi
@@ -399,7 +399,7 @@ fi
# Try to determine the hostname

View file

@ -1,14 +0,0 @@
--- a/libmariadb/libmariadb/secure/openssl.c
+++ b/libmariadb/libmariadb/secure/openssl.c
@@ -419,8 +419,10 @@ void ma_tls_end()
if (mariadb_deinitialize_ssl)
{
#ifndef HAVE_OPENSSL_1_1_API
-#if OPENSSL_VERSION_NUMBER < 0x10100000L
+#if OPENSSL_VERSION_NUMBER < 0x10000000L
ERR_remove_state(0);
+#else
+ ERR_remove_thread_state(NULL);
#endif
EVP_cleanup();
CRYPTO_cleanup_all_ex_data();