commit
86afba7c42
3 changed files with 0 additions and 74 deletions
|
@ -1,51 +0,0 @@
|
|||
#
|
||||
# Copyright (C) 2010-2014 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libartnet
|
||||
PKG_VERSION:=1.1.2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/OpenLightingProject/libartnet/releases/download/1.1.2
|
||||
PKG_HASH:=19cdda434e208a81ddd138377f11046364438e40e34542ae101d6aa3fcaec696
|
||||
|
||||
PKG_MAINTAINER:=Martijn Zilverschoon <martijn@friedzombie.com>
|
||||
PKG_LICENSE:=GPL-2.1
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libartnet
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=Libartnet is an implementation of the ArtNet protocol.
|
||||
URL:=https://www.openlighting.org/libartnet-main/
|
||||
endef
|
||||
|
||||
define Package/libartnet/description
|
||||
Libartnet is an implementation of the ArtNet protocol. ArtNet allows the
|
||||
transmission of DMX and related data over IP networks.
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
mkdir -p $(1)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/artnet $(1)/usr/include/
|
||||
mkdir -p $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libartnet.{so,so.1,so.1.0.0} $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
|
||||
define Package/libartnet/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libartnet.{so,so.1,so.1.0.0} $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libartnet))
|
|
@ -1,12 +0,0 @@
|
|||
--- a/artnet/private.h
|
||||
+++ b/artnet/private.h
|
||||
@@ -100,7 +100,9 @@ extern uint16_t HIGH_BYTE;
|
||||
#endif
|
||||
|
||||
// byte ordering macros
|
||||
+#ifndef bswap_16
|
||||
#define bswap_16(x) ((((x) >> 8) & 0xff) | (((x) & 0xff) << 8))
|
||||
+#endif
|
||||
|
||||
// htols : convert short from host to little endian order
|
||||
#ifdef WIN32
|
|
@ -1,11 +0,0 @@
|
|||
--- a/artnet/transmit.c
|
||||
+++ b/artnet/transmit.c
|
||||
@@ -163,7 +163,7 @@ int artnet_tx_tod_data(node n, int id) {
|
||||
bloc = 0;
|
||||
|
||||
while (remaining > 0) {
|
||||
- memset(&tod.data.toddata.tod,0x00, ARTNET_MAX_UID_COUNT);
|
||||
+ memset(&tod.data.toddata.tod,0x00, sizeof(tod.data.toddata.tod));
|
||||
lim = min(ARTNET_MAX_UID_COUNT, remaining);
|
||||
tod.data.toddata.blockCount = bloc++;
|
||||
tod.data.toddata.uidCount = lim;
|
Loading…
Reference in a new issue