bind: update to 9.14.3
Fixed CVE-2019-6471 ChangeLog: https://ftp.isc.org/isc/bind9/9.14.3/CHANGES Signed-off-by: Deng Qingfang <dengqf6@mail2.sysu.edu.cn>
This commit is contained in:
parent
523c52f6f2
commit
868f29d4ee
2 changed files with 2 additions and 38 deletions
|
@ -9,7 +9,7 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=bind
|
PKG_NAME:=bind
|
||||||
PKG_VERSION:=9.14.2
|
PKG_VERSION:=9.14.3
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
USERID:=bind=57:bind=57
|
USERID:=bind=57:bind=57
|
||||||
|
|
||||||
|
@ -21,7 +21,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:= \
|
PKG_SOURCE_URL:= \
|
||||||
https://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION) \
|
https://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION) \
|
||||||
https://ftp.isc.org/isc/bind9/$(PKG_VERSION)
|
https://ftp.isc.org/isc/bind9/$(PKG_VERSION)
|
||||||
PKG_HASH:=0e4027573726502ec038db3973a086c02508671723a4845e21da1769a5c27f0c
|
PKG_HASH:=ce878aabcf01b61ed114522c32fff9e268b02da55b3c248349860bc3d0c8bdfa
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
PKG_FIXUP:=autoreconf
|
||||||
PKG_REMOVE_FILES:=aclocal.m4 libtool.m4
|
PKG_REMOVE_FILES:=aclocal.m4 libtool.m4
|
||||||
|
|
|
@ -1,36 +0,0 @@
|
||||||
--- a/config.h.in
|
|
||||||
+++ b/config.h.in
|
|
||||||
@@ -45,6 +45,9 @@
|
|
||||||
/* Define to 1 if you have the `arc4random_uniform' function. */
|
|
||||||
#undef HAVE_ARC4RANDOM_UNIFORM
|
|
||||||
|
|
||||||
+/* Define if the ARM yield instruction is available */
|
|
||||||
+#undef HAVE_ARM_YIELD
|
|
||||||
+
|
|
||||||
/* Define to 1 if the compiler supports __builtin_clz. */
|
|
||||||
#undef HAVE_BUILTIN_CLZ
|
|
||||||
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -421,8 +421,8 @@ AS_CASE([$host],
|
|
||||||
[[]],
|
|
||||||
[[__asm__ __volatile__ ("yield")]]
|
|
||||||
)],
|
|
||||||
- [AC_MSG_RESULT([yes])],
|
|
||||||
- [AC_MSG_ERROR([no, try adding -march=native or -march=armv7-a to CFLAGS (see PLATFORMS.md for more information)])])])
|
|
||||||
+ [AC_MSG_RESULT([yes]) AC_DEFINE([HAVE_ARM_YIELD],[1],[Define if the ARM yield instruction is available])],
|
|
||||||
+ [AC_MSG_RESULT([no])])])
|
|
||||||
|
|
||||||
AC_CHECK_FUNCS([sysctlbyname])
|
|
||||||
|
|
||||||
--- a/lib/isc/rwlock.c
|
|
||||||
+++ b/lib/isc/rwlock.c
|
|
||||||
@@ -54,7 +54,7 @@
|
|
||||||
# define isc_rwlock_pause() __asm__ __volatile__ ("rep; nop")
|
|
||||||
#elif defined(__ia64__)
|
|
||||||
# define isc_rwlock_pause() __asm__ __volatile__ ("hint @pause")
|
|
||||||
-#elif defined(__arm__)
|
|
||||||
+#elif defined(__arm__) && HAVE_ARM_YIELD
|
|
||||||
# define isc_rwlock_pause() __asm__ __volatile__ ("yield")
|
|
||||||
#elif defined(sun) && (defined(__sparc) || defined(__sparc__))
|
|
||||||
# define isc_rwlock_pause() smt_pause()
|
|
Loading…
Reference in a new issue