unrar: Import 4.0.7 from packages and update to 5.1.6.
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
This commit is contained in:
parent
10d6a8c22d
commit
864f5d8865
2 changed files with 69 additions and 0 deletions
50
utils/unrar/Makefile
Normal file
50
utils/unrar/Makefile
Normal file
|
@ -0,0 +1,50 @@
|
|||
#
|
||||
# Copyright (C) 2006-2014 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=unrar
|
||||
PKG_VERSION:=5.1.6
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=unrarsrc-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.rarlab.com/rar
|
||||
PKG_MD5SUM:=be9607c59d62c3b101a70cd62c681515
|
||||
PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
|
||||
|
||||
PKG_LICENSE:=UnRAR
|
||||
PKG_LICENSE_FILES:=license.txt
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/unrar
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/uclibc++.mk
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/unrar
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
SUBMENU:=Compression
|
||||
TITLE:=UnRAR application
|
||||
URL:=http://www.rarlab.com/
|
||||
DEPENDS:=$(CXX_DEPENDS) +libpthread
|
||||
endef
|
||||
|
||||
define Package/unrar/description
|
||||
UnRAR is an application that can decompress files and archives created using
|
||||
the RAR compression scheme
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
endef
|
||||
|
||||
define Package/unrar/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/unrar $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,unrar))
|
19
utils/unrar/patches/100-makefile_fixes.patch
Normal file
19
utils/unrar/patches/100-makefile_fixes.patch
Normal file
|
@ -0,0 +1,19 @@
|
|||
diff -uprN a/unrar/makefile b/unrar/makefile
|
||||
--- a/makefile 2014-06-12 13:36:14.723816266 +0200
|
||||
+++ b/makefile 2014-06-12 13:36:36.174531961 +0200
|
||||
@@ -2,12 +2,12 @@
|
||||
# Makefile for UNIX - unrar
|
||||
|
||||
# Linux using GCC
|
||||
-CXX=g++
|
||||
-CXXFLAGS=-O2
|
||||
+#CXX=g++
|
||||
+#CXXFLAGS=-O2
|
||||
LIBFLAGS=-fPIC
|
||||
DEFINES=-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DRAR_SMP
|
||||
STRIP=strip
|
||||
-LDFLAGS=-pthread
|
||||
+LDFLAGS=-lpthread
|
||||
DESTDIR=/usr
|
||||
|
||||
# Linux using LCC
|
Loading…
Reference in a new issue