libarchive: update to 3.6.2
* fixes CVE-2022-36227 * drop upstreamed patch * removed deprecated AUTORELEASE Signed-off-by: Michal Vasilek <michal.vasilek@nic.cz>
This commit is contained in:
parent
df0b2eedd6
commit
85aed680be
2 changed files with 3 additions and 42 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libarchive
|
||||
PKG_VERSION:=3.6.1
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
PKG_VERSION:=3.6.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://www.libarchive.org/downloads
|
||||
PKG_HASH:=5a411aceb978f43e626f0c2d1812ddd8807b645ed892453acabd532376c148e6
|
||||
PKG_HASH:=9e2c1b80d5fbe59b61308fdfab6c79b5021d7ff4ff2489fb12daf0a96a83551d
|
||||
|
||||
PKG_MAINTAINER:=Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
|
||||
PKG_LICENSE:=BSD-2-Clause
|
||||
|
|
|
@ -1,39 +0,0 @@
|
|||
From a2f68263a1da5ad227bcb9cd8fa91b93c8b6c99f Mon Sep 17 00:00:00 2001
|
||||
From: Khem Raj <raj.khem@gmail.com>
|
||||
Date: Mon, 25 Jul 2022 10:56:53 -0700
|
||||
Subject: [PATCH] libarchive: Do not include sys/mount.h when linux/fs.h is
|
||||
present
|
||||
|
||||
These headers are in conflict and only one is needed by
|
||||
archive_read_disk_posix.c therefore include linux/fs.h if it exists
|
||||
otherwise include sys/mount.h
|
||||
|
||||
It also helps compiling with glibc 2.36
|
||||
where sys/mount.h conflicts with linux/mount.h see [1]
|
||||
|
||||
[1] https://sourceware.org/glibc/wiki/Release/2.36
|
||||
---
|
||||
libarchive/archive_read_disk_posix.c | 5 ++---
|
||||
1 file changed, 2 insertions(+), 3 deletions(-)
|
||||
|
||||
--- a/libarchive/archive_read_disk_posix.c
|
||||
+++ b/libarchive/archive_read_disk_posix.c
|
||||
@@ -34,9 +34,6 @@ __FBSDID("$FreeBSD$");
|
||||
#ifdef HAVE_SYS_PARAM_H
|
||||
#include <sys/param.h>
|
||||
#endif
|
||||
-#ifdef HAVE_SYS_MOUNT_H
|
||||
-#include <sys/mount.h>
|
||||
-#endif
|
||||
#ifdef HAVE_SYS_STAT_H
|
||||
#include <sys/stat.h>
|
||||
#endif
|
||||
@@ -54,6 +51,8 @@ __FBSDID("$FreeBSD$");
|
||||
#endif
|
||||
#ifdef HAVE_LINUX_FS_H
|
||||
#include <linux/fs.h>
|
||||
+#elif HAVE_SYS_MOUNT_H
|
||||
+#include <sys/mount.h>
|
||||
#endif
|
||||
/*
|
||||
* Some Linux distributions have both linux/ext2_fs.h and ext2fs/ext2_fs.h.
|
Loading…
Reference in a new issue