commit
84b6e0a934
3 changed files with 7 additions and 27 deletions
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=gpsd
|
PKG_NAME:=gpsd
|
||||||
PKG_VERSION:=3.21
|
PKG_VERSION:=3.23
|
||||||
PKG_RELEASE:=$(AUTORELEASE)
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@SAVANNAH/$(PKG_NAME)
|
PKG_SOURCE_URL:=@SAVANNAH/$(PKG_NAME)
|
||||||
PKG_HASH:=5512a7d3c2e86be83c5555652e5b4cc9049e8878a4320be7f039eb1a7203e5f0
|
PKG_HASH:=e36429b9f6fc42004894dff3dc4453f5b43f95af8533b96d3d135987418da9df
|
||||||
|
|
||||||
PKG_MAINTAINER:=Pushpal Sidhu <psidhu.devel@gmail.com>
|
PKG_MAINTAINER:=Pushpal Sidhu <psidhu.devel@gmail.com>
|
||||||
PKG_LICENSE:=BSD-3-Clause
|
PKG_LICENSE:=BSD-3-Clause
|
||||||
|
@ -87,6 +87,7 @@ define Package/libgps
|
||||||
SECTION:=libs
|
SECTION:=libs
|
||||||
CATEGORY:=Libraries
|
CATEGORY:=Libraries
|
||||||
TITLE:=C service library for communicating with the GPS daemon
|
TITLE:=C service library for communicating with the GPS daemon
|
||||||
|
ABI_VERSION:=29
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/libgps/description
|
define Package/libgps/description
|
||||||
|
@ -157,7 +158,7 @@ endef
|
||||||
|
|
||||||
define Package/libgps/install
|
define Package/libgps/install
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgps.so.* $(1)/usr/lib/
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgps.so.$(ABI_VERSION)* $(1)/usr/lib/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,gpsd))
|
$(eval $(call BuildPackage,gpsd))
|
||||||
|
|
|
@ -1,19 +0,0 @@
|
||||||
--- a/SConstruct
|
|
||||||
+++ b/SConstruct
|
|
||||||
@@ -42,7 +42,6 @@ import re
|
|
||||||
import subprocess
|
|
||||||
import sys
|
|
||||||
import time
|
|
||||||
-from distutils import sysconfig
|
|
||||||
import SCons
|
|
||||||
|
|
||||||
|
|
||||||
@@ -303,7 +302,7 @@ EnsureSConsVersion(2, 3, 0)
|
|
||||||
EnsurePythonVersion(2, 6)
|
|
||||||
|
|
||||||
|
|
||||||
-PYTHON_SYSCONFIG_IMPORT = 'from distutils import sysconfig'
|
|
||||||
+PYTHON_SYSCONFIG_IMPORT = ''
|
|
||||||
|
|
||||||
# Utility productions
|
|
||||||
|
|
|
@ -1,11 +1,9 @@
|
||||||
--- a/SConstruct
|
--- a/SConscript
|
||||||
+++ b/SConstruct
|
+++ b/SConscript
|
||||||
@@ -1068,6 +1068,10 @@ else:
|
@@ -1027,6 +1027,8 @@ if not cleaning and not helping:
|
||||||
ncurseslibs += pkg_config('tinfo', rpath_hack=True)
|
ncurseslibs += pkg_config('tinfo', rpath_hack=True)
|
||||||
# It's not yet known whether rpath_hack is appropriate for
|
# It's not yet known whether rpath_hack is appropriate for
|
||||||
# ncurses5-config.
|
# ncurses5-config.
|
||||||
+ elif WhereIs('ncurses6-config'):
|
|
||||||
+ ncurseslibs = ['!ncurses6-config --libs --cflags']
|
|
||||||
+ elif WhereIs('ncursesw6-config'):
|
+ elif WhereIs('ncursesw6-config'):
|
||||||
+ ncurseslibs = ['!ncursesw6-config --libs --cflags']
|
+ ncurseslibs = ['!ncursesw6-config --libs --cflags']
|
||||||
elif WhereIs('ncurses5-config'):
|
elif WhereIs('ncurses5-config'):
|
||||||
|
|
Loading…
Reference in a new issue