diff --git a/net/pdns/Makefile b/net/pdns/Makefile
index fe80565e8..b8d767cde 100644
--- a/net/pdns/Makefile
+++ b/net/pdns/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pdns
 PKG_VERSION:=4.2.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://downloads.powerdns.com/releases/
diff --git a/net/pdns/patches/300-boost-173.patch b/net/pdns/patches/300-boost-173.patch
new file mode 100644
index 000000000..aefdea7b3
--- /dev/null
+++ b/net/pdns/patches/300-boost-173.patch
@@ -0,0 +1,32 @@
+--- a/pdns/ixfrdist-web.cc
++++ b/pdns/ixfrdist-web.cc
+@@ -25,6 +25,8 @@
+ #include "iputils.hh"
+ #include "ixfrdist-stats.hh"
+ 
++using namespace boost::placeholders;
++
+ string doGetStats();
+ 
+ IXFRDistWebServer::IXFRDistWebServer(const ComboAddress &listenAddress, const NetmaskGroup &acl, const string &loglevel) :
+--- a/pdns/webserver.cc
++++ b/pdns/webserver.cc
+@@ -36,6 +36,8 @@
+ #include "uuid-utils.hh"
+ #include <yahttp/router.hpp>
+ 
++using namespace boost::placeholders;
++
+ json11::Json HttpRequest::json()
+ {
+   string err;
+--- a/pdns/ws-auth.cc
++++ b/pdns/ws-auth.cc
+@@ -49,6 +49,7 @@
+ #include "tsigutils.hh"
+ 
+ using json11::Json;
++using namespace boost::placeholders;
+ 
+ extern StatBag S;
+