libavl: add version 0.3.5
Signed-off-by: Espen Jürgensen <espenjurgensen+openwrt@gmail.com>
This commit is contained in:
parent
d15d70f693
commit
8365b52b20
2 changed files with 100 additions and 0 deletions
55
libs/libavl/Makefile
Normal file
55
libs/libavl/Makefile
Normal file
|
@ -0,0 +1,55 @@
|
|||
#
|
||||
# Copyright (C) 2006-2014 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libavl
|
||||
PKG_VERSION:=0.3.5
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=882c68ea7f71876ca110f3b84d7ab12d
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
|
||||
PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/liba/libavl
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/avl-$(PKG_VERSION)
|
||||
PKG_INSTALL:=1
|
||||
|
||||
PKG_MAINTAINER:=Espen Jürgensen <espenjurgensen+openwrt@gmail.com>
|
||||
PKG_LICENSE:=LGPL-2.0+
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libavl
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=AVLTree (this is not GNU libavl)
|
||||
URL:=https://packages.debian.org/wheezy/libavl1
|
||||
endef
|
||||
|
||||
define Package/libavl/description
|
||||
AVLTree is a small implementation of AVL trees for the C programming language.
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--enable-shared \
|
||||
--enable-static
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/avl.h $(1)/usr/include/
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libavl.so* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Package/libavl/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libavl.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libavl))
|
45
libs/libavl/patches/010-update_GNUmakefile.patch
Normal file
45
libs/libavl/patches/010-update_GNUmakefile.patch
Normal file
|
@ -0,0 +1,45 @@
|
|||
--- a/GNUmakefile 2002-11-15 19:57:48.000000000 +0100
|
||||
+++ a/GNUmakefile 2014-10-02 16:03:02.864803002 +0200
|
||||
@@ -6,7 +6,7 @@
|
||||
LDCONFIG ?= /sbin/ldconfig
|
||||
|
||||
# Some suggestions: (-mcpu= generates i386 compatible code)
|
||||
-CFLAGS ?= -O2 -fomit-frame-pointer -pipe -mcpu=i686 -w
|
||||
+CFLAGS ?= -O2 -pipe -Wall -Werror
|
||||
#CFLAGS = -O2 -fomit-frame-pointer -pipe -march=i586 -Wall -g
|
||||
#CFLAGS = -O6 -fomit-frame-pointer -pipe -march=i586 -Wall -ansi -pedantic
|
||||
#CFLAGS = -O6 -fomit-frame-pointer -pipe -march=i686 -Wall -ansi -pedantic
|
||||
@@ -15,10 +15,9 @@
|
||||
#CFLAGS = -g -pg -a -pipe -march=i686 -Wall
|
||||
#LDFLAGS = -s
|
||||
|
||||
-prefix ?= /usr/local
|
||||
+prefix ?= /usr
|
||||
libdir ?= $(prefix)/lib
|
||||
includedir ?= $(prefix)/include
|
||||
-includedir ?= /usr/include
|
||||
|
||||
PROGRAMS = avlsort setdiff
|
||||
LIBRARY = libavl.so.1.5
|
||||
@@ -34,16 +33,17 @@
|
||||
$(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
|
||||
|
||||
$(LIBRARY): avl.o
|
||||
- $(CC) -nostdlib -shared -Wl,-soname,libavl.so.1 $^ -o $@ -lc
|
||||
+ $(CC) -shared -Wl,-soname,libavl.so.1 $^ -o $@ -lc
|
||||
|
||||
clean:
|
||||
$(RM) *.o $(PROGRAMS) libavl.*
|
||||
|
||||
install: all
|
||||
$(INSTALL) -d $(DESTDIR)$(libdir)
|
||||
- $(INSTALL) avl.h $(DESTDIR)$(includedir)
|
||||
- $(INSTALL) $(LIBRARIES) $(DESTDIR)$(libdir)
|
||||
- for i in $(LIBRARIES); do\
|
||||
+ $(INSTALL) -d $(DESTDIR)$(includedir)
|
||||
+ $(INSTALL) -m 644 avl.h $(DESTDIR)$(includedir)
|
||||
+ $(INSTALL) -m 644 $(LIBRARY) $(DESTDIR)$(libdir)
|
||||
+ for i in $(LIBRARY); do\
|
||||
$(LN) -sf $$i $(DESTDIR)$(libdir)/$${i%.*};\
|
||||
$(LN) -sf $${i%.*} $(DESTDIR)$(libdir)/$${i%.*.*};\
|
||||
done
|
Loading…
Reference in a new issue