nut: update to 2.8.1
Signed-off-by: Paul Doran <ruralroots@gmail.com> [remove upstream patch included in 2.8.1]
This commit is contained in:
parent
9b6bf46957
commit
82f36e0c78
2 changed files with 3 additions and 30 deletions
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=nut
|
PKG_NAME:=nut
|
||||||
PKG_VERSION:=2.8.0
|
PKG_VERSION:=2.8.1
|
||||||
PKG_RELEASE:=3
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://www.networkupstools.org/source/2.8/
|
PKG_SOURCE_URL:=http://www.networkupstools.org/source/2.8/
|
||||||
PKG_HASH:=c3e5a708da797b7c70b653d37b1206a000fcb503b85519fe4cdf6353f792bfe5
|
PKG_HASH:=7da48ee23b1f0d8d72560bb0af84f5c5ae4dbe35452b84cb49840132e47f099c
|
||||||
PKG_LICENSE:=GPL-2.0-or-later GPL-3.0-or-later GPL-1.0-or-later Artistic-1.0-Perl
|
PKG_LICENSE:=GPL-2.0-or-later GPL-3.0-or-later GPL-1.0-or-later Artistic-1.0-Perl
|
||||||
PKG_LICENSE_FILES:=LICENSE-GPL2 LICENSE-GPL3 COPYING
|
PKG_LICENSE_FILES:=LICENSE-GPL2 LICENSE-GPL3 COPYING
|
||||||
PKG_FIXUP:=autoreconf
|
PKG_FIXUP:=autoreconf
|
||||||
|
|
|
@ -1,27 +0,0 @@
|
||||||
From cafd77993ec5e16634b774b65bf6da9b34a21fc5 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jim Klimov <jimklimov+nut@gmail.com>
|
|
||||||
Date: Wed, 31 Aug 2022 11:24:19 +0200
|
|
||||||
Subject: [PATCH] clients/upsclient.h: ensure time_t is defined
|
|
||||||
|
|
||||||
|
|
||||||
--- a/clients/upsclient.h
|
|
||||||
+++ b/clients/upsclient.h
|
|
||||||
@@ -41,6 +41,18 @@
|
|
||||||
#include <limits.h>
|
|
||||||
#endif
|
|
||||||
|
|
||||||
+/* Not including NUT timehead.h because this is part of end-user API */
|
|
||||||
+#ifdef TIME_WITH_SYS_TIME
|
|
||||||
+# include <sys/time.h>
|
|
||||||
+# include <time.h>
|
|
||||||
+#else
|
|
||||||
+# ifdef HAVE_SYS_TIME_H
|
|
||||||
+# include <sys/time.h>
|
|
||||||
+# else
|
|
||||||
+# include <time.h>
|
|
||||||
+# endif
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
#ifdef __cplusplus
|
|
||||||
/* *INDENT-OFF* */
|
|
||||||
extern "C" {
|
|
Loading…
Reference in a new issue