Merge pull request #17169 from mhei/21.02-php8-update
[21.02] php8: update to 8.0.13
This commit is contained in:
commit
82e8726fc3
2 changed files with 3 additions and 56 deletions
|
@ -6,8 +6,8 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=php
|
PKG_NAME:=php
|
||||||
PKG_VERSION:=8.0.12
|
PKG_VERSION:=8.0.13
|
||||||
PKG_RELEASE:=3
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
|
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
|
||||||
PKG_LICENSE:=PHP-3.01
|
PKG_LICENSE:=PHP-3.01
|
||||||
|
@ -16,7 +16,7 @@ PKG_CPE_ID:=cpe:/a:php:php
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=http://www.php.net/distributions/
|
PKG_SOURCE_URL:=http://www.php.net/distributions/
|
||||||
PKG_HASH:=a501017b3b0fd3023223ea25d98e87369b782f8a82310c4033d7ea6a989fea0a
|
PKG_HASH:=cd976805ec2e9198417651027dfe16854ba2c2c388151ab9d4d268513d52ed52
|
||||||
|
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
PKG_USE_MIPS16:=0
|
PKG_USE_MIPS16:=0
|
||||||
|
|
|
@ -1,53 +0,0 @@
|
||||||
From cd1447a6962496fca60a2f5e5d9cf4448575cc24 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ben Ramsey <ramsey@php.net>
|
|
||||||
Date: Tue, 19 Oct 2021 23:59:11 -0500
|
|
||||||
Subject: [PATCH 1/4] Change UBool to bool for equality operators in ICU >=
|
|
||||||
70.1
|
|
||||||
|
|
||||||
Refer to:
|
|
||||||
- https://github.com/unicode-org/icu/commit/633438f8da99fee815e2c61626ea779a84567a3d
|
|
||||||
- https://github.com/unicode-org/icu/commit/f6325d49ba57ec26f320b2865ce09ca47db458d9
|
|
||||||
---
|
|
||||||
ext/intl/breakiterator/codepointiterator_internal.cpp | 4 ++++
|
|
||||||
ext/intl/breakiterator/codepointiterator_internal.h | 4 ++++
|
|
||||||
2 files changed, 8 insertions(+)
|
|
||||||
|
|
||||||
--- a/ext/intl/breakiterator/codepointiterator_internal.cpp
|
|
||||||
+++ b/ext/intl/breakiterator/codepointiterator_internal.cpp
|
|
||||||
@@ -73,7 +73,11 @@ CodePointBreakIterator::~CodePointBreakI
|
|
||||||
clearCurrentCharIter();
|
|
||||||
}
|
|
||||||
|
|
||||||
+#if U_ICU_VERSION_MAJOR_NUM >= 70
|
|
||||||
+bool CodePointBreakIterator::operator==(const BreakIterator& that) const
|
|
||||||
+#else
|
|
||||||
UBool CodePointBreakIterator::operator==(const BreakIterator& that) const
|
|
||||||
+#endif
|
|
||||||
{
|
|
||||||
if (typeid(*this) != typeid(that)) {
|
|
||||||
return false;
|
|
||||||
--- a/ext/intl/breakiterator/codepointiterator_internal.h
|
|
||||||
+++ b/ext/intl/breakiterator/codepointiterator_internal.h
|
|
||||||
@@ -37,7 +37,11 @@ namespace PHP {
|
|
||||||
|
|
||||||
virtual ~CodePointBreakIterator();
|
|
||||||
|
|
||||||
+#if U_ICU_VERSION_MAJOR_NUM >= 70
|
|
||||||
+ virtual bool operator==(const BreakIterator& that) const;
|
|
||||||
+#else
|
|
||||||
virtual UBool operator==(const BreakIterator& that) const;
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
virtual CodePointBreakIterator* clone(void) const;
|
|
||||||
|
|
||||||
--- a/ext/intl/locale/locale_methods.c
|
|
||||||
+++ b/ext/intl/locale/locale_methods.c
|
|
||||||
@@ -1239,7 +1239,7 @@ PHP_FUNCTION(locale_filter_matches)
|
|
||||||
if( token && (token==cur_lang_tag) ){
|
|
||||||
/* check if the char. after match is SEPARATOR */
|
|
||||||
chrcheck = token + (strlen(cur_loc_range));
|
|
||||||
- if( isIDSeparator(*chrcheck) || isEndOfTag(*chrcheck) ){
|
|
||||||
+ if( isIDSeparator(*chrcheck) || isKeywordSeparator(*chrcheck) || isEndOfTag(*chrcheck) ){
|
|
||||||
efree( cur_lang_tag );
|
|
||||||
efree( cur_loc_range );
|
|
||||||
if( can_lang_tag){
|
|
Loading…
Reference in a new issue